Can't start sddm, xfce and lxqt

It's been a few days I can't start sddm in my pinebook 11' pro with manjaro-arm lxqt edition.

If I start sddm the screen remains black and I can't login in every way.

I changed to login manager with lightdm and then the login window appears but I cannot use xfce4 neither lxqt because after th login and the running of some programs like the panel and so the session dies returning to login window.

The same situation starting xfce4 and lxqt with startx and .xinitrc.

I can use my graphical interface only with openbox.

I checked my /var/log/Xorg.0.log and I found this error:

[  1575.199] (II) FBTURBO(0): can't load 'g2d_23' kernel module
[  1575.199] (II) FBTURBO(0): failed to enable the use of sunxi display controller
[  1575.202] (II) FBTURBO(0): No sunxi-g2d hardware detected (check /dev/disp and /dev/g2d)
[  1575.204] (II) FBTURBO(0): G2D hardware acceleration can't be enabled
[  1575.204] (==) FBTURBO(0): Backing store enabled
[  1575.204] (EE) FBTURBO(0): FBIOPUTCMAP: Invalid argument

And then many lines like the last.

Before it worked fine!

Have you checked the forum for the pinebook to see if this a recurring issue? Also have you searched the forum to see if there is a solution?

I searched for these terms but I did not find anything.

And more, it worked fine until some days ago.

I think this is due to an upgrade of these days.

I looked with more attention in /var/log/Xorg.0.log and I found these lines at the end:

[   563.753] (EE) Backtrace:
[   563.754] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x5c) [0xaaaaaef39b8c]
[   563.754] (EE) 1: /usr/lib/Xorg (0xaaaaaedfe000+0x13f048) [0xaaaaaef3d048]
[   563.754] (EE) 2: linux-vdso.so.1 (__kernel_rt_sigreturn+0x0) [0xffffb75a566c
]
[   563.755] (EE) 3: /usr/lib/libc.so.6 (gsignal+0xb4) [0xffffb70eb854]
[   563.755] (EE) 4: /usr/lib/libc.so.6 (abort+0x110) [0xffffb70d92a8]
[   563.755] (EE) 5: /usr/lib/libc.so.6 (0xffffb70b5000+0x2fc98) [0xffffb70e4c98
]
[   563.755] (EE) 6: /usr/lib/libc.so.6 (__assert_perror_fail+0x0) [0xffffb70e4d
00]
[   563.755] (EE) 7: /usr/lib/Xorg (0xaaaaaedfe000+0x1add30) [0xaaaaaefabd30]
[   563.755] (EE) 8: /usr/lib/Xorg (DRI2CreateDrawable2+0x28c) [0xaaaaaefacb64]
[   563.756] (EE) 9: /usr/lib/Xorg (0xaaaaaedfe000+0x1b10b0) [0xaaaaaefaf0b0]
[   563.756] (EE) 10: /usr/lib/Xorg (0xaaaaaedfe000+0x74390) [0xaaaaaee72390]
[   563.756] (EE) 11: /usr/lib/Xorg (0xaaaaaedfe000+0x78428) [0xaaaaaee76428]
[   563.756] (EE) 12: /usr/lib/libc.so.6 (__libc_start_main+0xe4) [0xffffb70d96e
4]
[   563.756] (EE) 13: /usr/lib/Xorg (0xaaaaaedfe000+0x41220) [0xaaaaaee3f220]

We have noticed a similar bug in a testing image that I made. Wouldn't think it would affect current installed images but as a test of a possible fix, install the 4.20 kernel and reboot. We are thinking that the linux 5.0 that comes with the 19.06 pinebook images only has some partial support for the graphical bits.

sudo pacman -S linux-pine64-420 linux-pine64-420-headers

No, I am very sorry but nothing changed installing kernel 4.20. I have the same error either starting sddm via systemctl start sddm.service (instead lightdm starts normally), either running startxfce4 via startx (using ~/.xinitrc file).
I installed kernel and rebooted (obviously) but the error in /var/log/xorg.0.log remained the same.

Can you please make sure your desktop is fully updated and no qt5 packages are still at 5.12. All should have been updated to 5.13.
sudo pacman -Syyuu
We use the downgrade option here, because I had a point release of qt5, that did not work as expected.

1 Like

Yes, this worked!

Now sddm, xfce4 and lxqt session works normally!

Do you think it will work also with kernel 5?

Yes if the issue was the qt packages, kernel wont matter, you should be able to switch back to 5.0 just fine. Just be sure to install the correct headers package as well.

Yes, I can confirm: I am using kernel 5.0.3 and everything works as expected.

Thanks very much!

I think I have marked this report closed!