Can't solve stuck on /dev/sda2 clean

So I just did a fresh install, updated kernel most recent non-experimental version, installed the latest lts as a backup. On hardware configuration I installed video mods setting and the other driver (I forgot what its called.) I don’t think I did anything else. Rebooted now stuck on /dev/sda2 clean.

This is my 5th attempt at installing the system I want but I can’t seem to figure out how to troubleshoot this. I looked online and none of the current instructions seem to help. Mind if someone walks me through this? I can log into tty2 and have ethernet cable attached.

(Update) forgot to mention, I have not used pamac to update my packages. This is on a thinkpad T560. Also grub menu does not show up during boot. Boot method is UEFI only, CSM disabled. Installed manjaro via USB live boot (which is still available to use). I’ll keep adding info as I think of what could be relevant. I found how to use journalctl -b but not sure how to send this log to you all as I can only use a tablet atm

SOLVED: it was indeed those other two video drivers I had installed, so the solution was tty (ctrl + alt F2) login to root. Use mhwd -li to look at the drivers installed (im assuming that is only video drivers? Someone correct me if I’m wrong). I removed all the ones I had added including video-linux, reinstalled video-linux (mhwd -i pci video-linux) rebooted and no problem :smiley:

Errr not sure how to mark as solved lol


Welcome to the forum :wave:

Congratulations on fixing your issue!
Some more info about mhwd: Manjaro Hardware Detection Overview - Manjaro

Solved can only be used on reply posts as far as I can tell, I’ve edited the title for you to mark it solved.

:+1: Thank you for sharing! :+1:

However, could you do me a favour and:

  • edit your question by pressing the 3 dots and the pencil icon
  • cut and paste the solution into a reply to your own question
  • click the 3 dots below your own answer to mark a solution like this:
    so that the next person that has the exact same problem you just had will benefit from your post as your question will now be in the “solved” status.


1 Like

It has worked for me too, thank you very much! I have a hybrid system with a GT630 and Xeon E3-1200, i uninstalled all pci dirvers and i reinstalled (mhwd -i pci video-linux) and work.