Can't see remove option in Kernel page

I have 3 kernels installed 6.2, 6.1 and 5.4 and can’t see their remove option at all

Did you run this from live manjaro ? :face_with_monocle:

The running kernel can’t be removed :man_shrugging:

mhwd-kernel -li
Currently running: 6.1.25-1-MANJARO (linux61)
The following kernels are installed in your system:
   * linux515
   * linux61
   * linux62

only the running one is installed. why do you think further kernels should be installed ?

may you post the output of

 mhwd-kernel -li 

I have the others two installed, it’s just that Manjaro Kernel page needs many open and close and sometimes even rebooting to be able to list other installed kernels.


can you describe your “problem”. from here i even can’t understand what you try to explain

I have 3 kernels installed, but Manjaro Kernel page in Plasma settings shows only that one kernel is installed. In order to see the other two kernels as being installed, I need to open and access Kernel page in settings many times, and sometimes I need to reboot my laptop to be able to see all my 3 kernels marked as installed.

Have you tried to reinstall manjaro-settings-manager-kcm, install/remove a kernel from terminal and check the Manjaro Kernel Settings again?

Did you try to clear the ~/.cache folder and then reboot?

1 Like

You could use the mhwd-kernel -r command to remove the two kernels.

Yes I tried it many times, if fact the system log shows the following error when I select Kernel page in Plasma settings:

That message is coming from manjaro-settings-manager-master/src/libmsm/KernelModel.cpp

Have you open it outside KDE Plasma Settings and see if does the same?

Why do you show me your local source of it, you compile it yourself locally?
We know from where the message comes from in the source, but that does not solve your local issue.
If you compiled yourself, better remove it and use the manjaro-settings-manager-kcm package from the repository.

By any chance do you have mixed -git packages from kde-unstable branch and forgot about them, something you compiled yourself at some point and forgot about, AUR … ?

Have you open it outside KDE Plasma Settings and see if does the same?

Yes it has the same result when I run it outside Plasma settings.

you compile it yourself locally?

No, I just downloaded Manjaro settings source from GitLab and searched for that error to see if it’s coming from Manjaro or outside it.