Can't see login bar after computer goes to sleep

Hi all,

I have a three monitor setup, and, whenever my manjaro goes to sleep and I try to log back in, the middle monitor is black, the login bar isn’t responsive, the cursor is able to move still, and then I have to type my password a few times before it logs in. It’s been driving me up a wall. Does anyone know how I may go about fixing this issue?


Hello and welcome,

Can we see:
inxi -Fxza --no-host

Please share it as formatted text!

Also: inspect your journal for errors arround the time your trying to log back in and post those as well.

System:    Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=a6884f71-99fe-40ef-bd3a-db265ae0decb rw quiet apparmor=1 
           security=apparmor resume=UUID=972d2682-8d8c-4e8a-a5a8-4f864dce2a0a udev.log_priority=3 
           Desktop: KDE Plasma 5.19.3 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: Creator TRX40 (MS-7C59) v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: 1.20 date: 01/07/2020 
CPU:       Topology: 32-Core (4-Die) model: AMD Ryzen Threadripper 3970X bits: 64 type: MT MCP MCM arch: Zen family: 17 (23) 
           model-id: 31 (49) stepping: N/A microcode: 8301025 L2 cache: 16.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 544195 
           Speed: 4250 MHz min/max: 2200/4250 MHz Core speeds (MHz): 1: 4250 2: 4250 3: 4250 4: 4249 5: 4250 6: 4250 7: 4250 
           8: 4249 9: 4250 10: 4249 11: 4250 12: 4249 13: 4250 14: 4249 15: 4249 16: 4247 17: 4250 18: 4249 19: 4250 20: 4249 
           21: 4250 22: 4249 23: 4250 24: 4249 25: 4250 26: 4249 27: 4250 28: 4249 29: 4250 30: 4250 31: 4250 32: 4250 
           33: 4249 34: 4249 35: 4249 36: 4248 37: 4250 38: 4250 39: 4250 40: 4250 41: 4250 42: 4250 43: 4250 44: 4250 
           45: 4249 46: 4250 47: 4250 48: 4250 49: 4250 50: 4249 51: 4249 52: 4250 53: 4249 54: 4250 55: 4250 56: 4250 
           57: 4249 58: 4250 59: 4249 60: 4250 61: 4250 62: 4250 63: 4249 64: 4250 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: driver: nvidia v: 440.100 bus ID: 21:00.0 
           Display: x11 server: X.Org 1.20.8 driver: nvidia tty: N/A 
           OpenGL: renderer: GeForce RTX 2070 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes 
Audio:     Device-1: NVIDIA TU104 HD Audio vendor: driver: snd_hda_intel v: kernel bus ID: 21:00.1 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI driver: N/A bus ID: 23:00.4 
           Device-3: Micro Star USB Audio type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 9-5:3 
           Device-4: Logitech [G533 Wireless Headset Dongle] type: USB driver: hid-generic,snd-usb-audio,usbhid 
           bus ID: 11-6.2:6 
           Sound Server: ALSA v: k5.6.19-2-MANJARO 
Network:   Device-1: Aquantia AQC107 NBase-T/IEEE 802.3bz Ethernet [AQtion] vendor: Micro-Star MSI driver: atlantic 
           v: 5.6.19-2-MANJARO-kern port: 1000 bus ID: 44:00.0 
           IF: enp68s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 1000 bus ID: 45:00.0 
           IF: wlo1 state: down mac: <filter> 
           Device-3: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb v: 5.6.0-k port: 2000 bus ID: 46:00.0 
           IF: enp70s0 state: down mac: <filter> 
Drives:    Local Storage: total: 5.46 TiB used: 79.10 GiB (1.4%) 
           ID-1: /dev/sda vendor: Seagate model: ST4000NE001-2MA101 size: 3.64 TiB block size: physical: 4096 B logical: 512 B 
           ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO 2TB size: 1.82 TiB block size: physical: 512 B logical: 512 B 
Partition: ID-1: / raw size: 1.75 TiB size: 1.72 TiB (98.37%) used: 79.10 GiB (4.5%) fs: ext4 dev: /dev/sdb2 
           ID-2: swap-1 size: 69.03 GiB used: 0 KiB (0.0%) fs: swap swappiness: 5 (default 60) 
           cache pressure: 50 (default 100) dev: /dev/sdb3 
Sensors:   System Temperatures: cpu: 36.1 C mobo: N/A gpu: nvidia temp: 43 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 807 Uptime: 9m Memory: 62.75 GiB used: 9.13 GiB (14.6%) Init: systemd Compilers: gcc: 10.1.0 Shell: fish 
           v: 3.1.2 inxi: 3.0.37

I also thought that I should add that for some strange reason, my monitor configuration will move between monitors, but will maintain their overall orientation with respect to the cursor. For example, if I add widgets on monitor C, rebooting will make them go to monitor A, etc, and sometimes not even show the widgets on that monitor at all.

This is a EOL kernel = end of life. Please install 5.7 as is more stable. I don’t recommend yet the 5.8 kernel, or even go with 5.4 as is LTS
First we have to be sure your system is updated:
sudo pacman-mirrors -f && sudo pacman -Syyu
sudo mhwd-kernel -i linux57

For that you can create a fixed configuration with Nvidia X Settings for the /etc/X11/mhwd.d/nvidia.conf Please pay attention to what entries you keep from old configuration; make a backup of it.

Here is an exemple of what i use in KDE Plasma install:

Example of fixed layout dual screen nvidia.conf
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "LG Electronics"
    ModelName      "LG Electronics W2253"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 960"
    Option         "TripleBuffer"  "On"
    Option  "ConnectToAcpid"    "Off"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-I-1: 1920x1080_60 +0+0 {ForceCompositionPipeline=On}, DVI-D-0: 1920x1080_60 +1920+0 {ForceCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "COMPOSITE" "Enable"

Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"

Because of that Option "TripleBuffer" "On" i also use the /etc/profile.d/ with this lines:

export __GL_MaxFramesAllowed=1

Bare in mind, that this only has some advantages on the X11 session, and will not help if you want to try Wayland.

Next you can safely remove tlp package since you have a Desktop PC.

Thank you for your reply, bodancovaciu. Unfortunately, I’m running into a new error now: it won’t update before changing kernels, because, once it finishes installing the cuda package, it says its corrupted and cancels.

If just cuda gives that error, remove it (i know is a 5GB but better not insist different way), update, reboot, clean the pamac cache and then try to reinstall cuda.

Okay, I’m an arch newbie. Which terminal commands should I enter to accomplish what you suggest? :slight_smile:

EDIT:: It says the cuda package was unexpectedly large, not corrupted. Apologies.

EDIT2:: Using the GUI for software updates fixed the issue. However, the command:
sudo mhwd-kernel -i linux57
: says no targets specified

So you run out of space in the root?
You can clean cache by
pacman -Sc
or even more aggressive with
pacman -Scc
then run again
sudo pacman -Syyu