Can't see Kodi settings page

Hi everyone…I cant your install kodi both on pamac and terminal.After the installation program opens but you can’t see the settings page.I thought it was graphic card related.I have Nvidia GeForce 940 Mx and bumblebee installed.but the problem persists.I am willing to give more information .Any help is appreciated.

Those two things contradict each other.

Did you install kodi-x11 or kodi-wayland? If you’re not sure if you’re using Xorg or Wayland, check with:


Make sure the output matches what package you have installed.

Hi.I meant i couldnt install correctly.Ill inform you presently.

It is wayland

And what does result of

pacman -Qs kodi


Hi Falav.It is: local/p8-platform
Platform support library used by libCEC and binary add-ons for Kodi

Hi Falav…I have another question.If I run sudo mhwd-gpu --status terminal returns

warning: could not find ‘/etc/X11/xorg.conf.d/90-mhwd.conf’! error.Also if I switch with gnome on the bootup screen computer doesnt boot.What can I do?

Hi…I reinstalled manjaro today this time with kde…And reinstalled kodi again…This time its x11…But nothing changed…Kodi just doesnt show settings page

Hello, is kodi-common installed also?

And what do you mean the settings page? Kodi should launch, and there, you can access to several settings menus and submenus.

In short, you should have kodi-common for the program itself if I’m not mistaken, then also kodi-x11.

Hi Falav.I do have kodi x-11 and kodi common.But when I open kodi and come to settings page there are just empty rectangles.And I can’t install any addons or can’t set anything at all.Thank you for your interest.

Mmh, you’re sure you’re with Xorg and not Wayland? :grin:

Have you got additional add-ons?

That’s weird, I can’t see what to do next (except checking Google or Kodi forum/Reddit/FAQ) as Kodi always worked instantly on my KDE installs.

Just to know, how do you install Kodi?

Hi Falav.Im sure its x11.There is no installed addons right now due to settings page doesn’t show anything.I installed from pamac.

Have you got some exotic Plasma theme that could create issues with Kodi?

Otherwise I’m out of ideas right now :man_shrugging:t3:

No.I havent installed any themes.Thank you for your support anyway.

Hm.When i run echo $XDG_SESSION_TYPE command x-11 is written…But

when i run sudo kodi-x11 it says Error: /usr/lib/kodi/kodi-x11 not found

Why do you think this happens?

Why do you run kodi with sudo?
Just run Kodi through Konsole, Application launcher or Krunner.

Don’t run regular applications as root.

Is there any error output just running kodi?

when i run just kodi on terminal it says:

Error: /usr/lib/kodi/kodi-x11 not found

Now i am trying to configure the nvidia-prime display card according to this guide:
Guide: Install and configure optimus-manager for hybrid GPU setups (Intel/NVIDIA) - Tutorials - Manjaro Linux Forum
but it advises me to disable xorg graphic configuration in /etc/x11 by renaming the config files there.The problem is renaming option is greyed out…

A wild guess, try reinstall kodi-common and kodi-x11?

About Nvidia, I have myself a hybrid GPU Intel/Nvidia. But as my laptop is antique and that I gave up trying to play something other than my old games with it, I dunno much about it, as it just works for me.

I can try to give ideas or leads to follow, but the technical solutions will come from someone else…

Thanks for bearing with me Falav.Ill just try the guide without the renaming …If i end up in a black screen again,Ill reinstall kde…

Just to show what’s the result of pacman -Qs kodi for me:

pacman -Qs kodi                                                                                ✔ 
local/kodi-common 19.0-9
    A software media player and entertainment hub for digital media
local/kodi-x11 19.0-9
    x11 kodi binary
    Platform support library used by libCEC and binary add-ons for Kodi

Can you try again and paste the result?