Can't see anything after boot?

When I boot I just see nothing and my GPU and PC is on and my monitor says input but I just see a black screen. every other thread I found about this has stuff about using grub or a terminal or something but I can’t do any of that because my screen is completely black??? Ive tried control alt F2 as well and also tried pressing every key on my keyboard it just doesn’t do anything. I seriously have no idea what to do and I’m panicking because I really really don’t wanna have to reset and reinstall my os.

There are a number of threads about how to proceed.
Here is one.

Now it’s just showing the Manjaro loading screen indefinitely.

What do you mean? What did you do?
We need more information to be helpful.

I booted through a USB and reinstalled GPU drivers and disabled my pcie passthrough stuff in chroot.

can you report from usb live manjaro

inxi - Fza 
sudo manjaro-chroot
mhwd-kernel -li
mhwd -li
exit ( end-chroot )

you may need to add “iommu=pt” on boot

forgot to iommu the first time

  Kernel: 6.1.12-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_KDEM_2204 quiet
    systemd.show_status=1 splash driver=free nouveau.modeset=1 i915.modeset=1
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: B550 VISION D-P v: -CF
    serial: <superuser required>
  Mobo: Gigabyte model: B550 VISION D-P serial: <superuser required>
    UEFI: American Megatrends LLC. v: F14 date: 02/17/2022
  ID-1: hidpp_battery_0 charge: 71% condition: N/A volts: 3.9 min: N/A
    model: Logitech G Pro Wireless Gaming Mouse type: N/A serial: <filter>
    status: discharging
  Info: model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
    L3: 64 MiB desc: 4x16 MiB
  Speed (MHz): avg: 2275 high: 3800 min/max: 2200/4672 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3800 2: 2200
    3: 2200 4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 2200 10: 2200 11: 2200
    12: 2200 13: 2200 14: 2200 15: 2200 16: 2200 17: 2200 18: 2200 19: 2200
    20: 2200 21: 2200 22: 2417 23: 2200 24: 2200 bogomips: 182133
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: ZOTAC
    driver: nouveau v: kernel non-free: 525.xx+ status: current (as of 2023-02)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22 pcie:
    gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16 ports: active: DP-1
    empty: DP-2,DP-3,HDMI-A-1 bus-ID: 51:00.0 chip-ID: 10de:2504
    class-ID: 0300
  Device-2: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: RDNA-1 code: Navi-1x
    process: TSMC n7 (7nm) built: 2019-20 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: none off: HDMI-A-2 empty: DP-4,DP-5,DP-6
    bus-ID: 54:00.0 chip-ID: 1002:731f class-ID: 0300
  Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
    loaded: amdgpu,modesetting unloaded: radeon alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu,nouveau display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: DP-1 res: 1920x1080 hz: 60 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  API: OpenGL v: 4.5 Mesa 22.3.5 renderer: llvmpipe (LLVM 15.0.7 256 bits)
    direct-render: Yes
  Device-1: NVIDIA GA106 High Definition Audio vendor: ZOTAC
    driver: snd_hda_intel v: kernel bus-ID: 1-8:7 chip-ID: 041e:3272 pcie:
    gen: 4 class-ID: 0300 serial: <filter> speed: 16 GT/s lanes: 8 link-max:
    lanes: 16 bus-ID: 51:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 54:00.1 chip-ID: 1002:ab38
    class-ID: 0403
  Device-3: AMD Starship/Matisse HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 56:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-4: Creative Pebble V3 type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-5: Logitech Yeti Nano type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-2:3 chip-ID: 046d:0ab1
    class-ID: 0300 serial: <filter>
  Device-6: Texas Instruments PCM2902 Audio Codec type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-4:5 chip-ID: 08bb:2902
    class-ID: 0300
  Sound API: ALSA v: k6.1.12-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: no
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 4d:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp77s0 state: up speed: 2500 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 4e:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp78s0 state: down mac: <filter>
  Device-3: Intel Ethernet I225-V vendor: Gigabyte driver: igc v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 50:00.0
    chip-ID: 8086:15f3 class-ID: 0200
  IF: enp80s0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-6.1:6 chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 938.97 GiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS100T2B0B-00YS70 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 20WD
    scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Kingston model: DT 101 II
    size: 7.46 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Alert: No swap data was found.
  System Temperatures: cpu: 40.4 C mobo: N/A gpu: amdgpu temp: 40.0 C
    mem: 40.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  Processes: 435 Uptime: 15m wakeups: 3 Memory: 31.25 GiB
  used: 3.39 GiB (10.9%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1107 libs: 310 tools: pamac Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.25
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
==> Mounting (ManjaroLinux) [/dev/sda1]
 --> mount: [/mnt]
[manjaro /]# mhwd-kernel -li
mhwd -li    
Currently running: 6.1.12-1-MANJARO (linux61)
The following kernels are installed in your system:
   * linux61
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Remove all of this. (and update-grub)

Also. Please format your post.
Some helpful links might be
[HowTo] Provide System Information
[HowTo] use public command-line pastebin services without installing anything!

This is strange, any idea why not a single partition has been detected? What have you tried before the issue showed up?

driver=free nouveau.modeset=1 i915.modeset=1

Where do I remove this from?

Also it seems I just can’t update-grub ?

[manjaro ~]# sudo update-grub
/usr/bin/grub-probe: error: failed to get canonical path of `/dev/sda1'.
[manjaro ~]# sudo grub-mkconfig =o /boot/grub/grub.cfg 
/usr/bin/grub-probe: error: failed to get canonical path of `/dev/sda1'.

No clue. I haven’t really tried anything before the issue showed up ?

I mean remove it from your boot options.
You can do this one time by hitting ‘e’ at boot …
But the permanent setting is probably stored in /etc/default/grub
(after which you would update-grub)

Thats a problem. Lets maybe fix that first.

What is the output of

lsblk && cat /etc/fstab

I did check /etc/default/grub but I wasn’t able to find it anywhere there.

lsblk && cat /etc/fstab                                                                                                                                                                                      1 ✘  1h 16m 2s  
loop0    7:0    0  32.8M  1 loop /run/miso/sfs/livefs
loop1    7:1    0 868.9M  1 loop /run/miso/sfs/mhwdfs
loop2    7:2    0   1.4G  1 loop /run/miso/sfs/desktopfs
loop3    7:3    0  1003M  1 loop /run/miso/sfs/rootfs
sda      8:0    0 931.5G  0 disk 
└─sda1   8:1    0 931.5G  0 part /mnt
sdb      8:16   1   7.5G  0 disk /run/miso/bootmnt
├─sdb1   8:17   1   3.3G  0 part 
└─sdb2   8:18   1     4M  0 part 
# /etc/fstab: static file system information
# <file system>        <dir>         <type>    <options>          <dump> <pass>
/dev/mapper/root-image /             auto      defaults           0      0

What is the output of

sudo fdisk -l

I guess you need to re-install grub as explained here, use the BIOS System method:


in the description has to be replaced with your primary disk, most likely

sudo fdisk -l   
Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WDC  WDS100T2B0B
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xef648ba8

Device     Boot Start        End    Sectors   Size Id Type
/dev/sda1  *     2048 1953520064 1953518017 931.5G 83 Linux

Disk /dev/sdb: 7.46 GiB, 8011087872 bytes, 15646656 sectors
Disk model: DT 101 II       
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot   Start     End Sectors  Size Id Type
/dev/sdb1  *         64 6942571 6942508  3.3G  0 Empty
/dev/sdb2       6942572 6950763    8192    4M ef EFI (FAT-12/16/32)

Disk /dev/loop0: 32.78 MiB, 34373632 bytes, 67136 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop1: 868.91 MiB, 911122432 bytes, 1779536 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop2: 1.38 GiB, 1477865472 bytes, 2886456 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop3: 1003.02 MiB, 1051746304 bytes, 2054192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

You might need to be more specific about when you are showing details.
The fstab and lsblk you shared were from the live usb environment so they dont help in relation to your other problems … I dont know if its the same for your update-grub issue as well.

so far I’ve run everything inside manjaro-chroot

Did you try to restore grub as proposed?

yeah. now when I boot up without the USB it’s showing me a rootfs terminal thing

/dev/sda1 contains a file system with errors, check forced. Inode 29889647 extent tree (at level 2) could be narrower. IGNORED. Unattached inode 36992785

/dev/sda1: UNEXPECTED INCONSISTENCY: RUN fsck MANUALLY. (i.e., without -a or -p options)

ERROR: Bailing out. Run 'fsck UUID=e7eb13ec-3824-4fe6-a5b4-c62d1b9cbbfc' manually 
********** FILESYSTEM CHECK FAILED **********

Please run fsck manually. After leaving this maintenance shell, the system will reboot automatically.

sh: can't access tty: job control turned off [rootfs 18

so I ran fsck UUID=e7eb13ec-3824-4fe6-a5b4-c62d1b9cbbfc manually and now I see a grey screen that just says …

Oh it just stopped doing that and I’m back in now I suppose?

could someone please explain wtf I just witnessed in case it happens again?

Looks you had a filesystem error which could be fixed using fsck command. Probably solved in combination with restoring grub.