Can't run Wine or Steam Proton Games with X11 but works with Wayland

Excuse me for posting and ninja editing but please return to the previous post for some more info :wink:

And more here, especially see the Note

yeah no problem I saw your editing :slight_smile:

My inxi -Gxx when commenting # Bus Id …

  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-12.1 ports: active: DP-1,eDP-1 empty: DP-2, DP-3, DP-4,
    HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9a60
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Dell
    driver: nvidia v: 530.41.03 arch: Ampere pcie: speed: 2.5 GT/s lanes: 8
    bus-ID: 01:00.0 chip-ID: 10de:25a2
  Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-5:2 chip-ID: 0c45:6725
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: kwin_x11 driver: X: loaded: modesetting unloaded: nvidia
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96
  Monitor-1: DP-1 pos: primary,left model: CR240DM res: 1920x1080 dpi: 93
    diag: 658mm (25.9")
  Monitor-2: eDP-1 pos: right model: BOE Display 0x093f res: 1920x1080
    dpi: 142 diag: 395mm (15.5")
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: Mesa Intel UHD Graphics (TGL GT1)
    direct-render: Yes

Looks fine. And at the right ID and everything.
Its most certainly modesetting

Another test if you are so inclined would be …

Throw out (or move, whatever) those config files and have mhwd ‘add’ modesetting:

sudo mhwd -i pci video-modesetting

That should work too.

I already have it like posted here

Maybe I should delete i915 or something ? Idk why I have it btw

oops sorry for that I thought I had seen only the hybrid profile.

That does probably mean that profile is not working as intended.

I guess stick with the manual config for now.

The other way we used to do it (back when modesetting was first being adopted) was by just removing the older driver:

sudo pacman -Rns xf86-video-intel

But i suspect that will be tied to some mhwd deps.

sudo pacman -Rns xf86-video-intel
erreur : impossible de trouver la cible : xf86-video-intel

Meaning it doesn't find the target

My installed packages with intel in the name

local/intel-gmmlib 22.3.3-1
    Intel Graphics Memory Management Library
local/intel-media-driver 23.1.0-1
    Intel Media Driver for VAAPI — Broadwell+ iGPUs
local/intel-ucode 20230214-1
    Microcode update files for Intel CPUs
local/intellij-idea-community-edition 4:2023.1-1
    IDE for Java, Groovy and other programming languages with advanced refactoring features
local/lib32-libva-intel-driver 2.4.1-1
    VA-API implementation for Intel G45 and HD Graphics family (32-bit)
local/libmfx 23.1.6-1
    Intel Media SDK dispatcher library
local/libva-intel-driver 2.4.1-2
    VA-API implementation for Intel G45 and HD Graphics family
local/libva-utils 2.18.0-1
    Intel VA-API Media Applications and Scripts for libva
local/nvtop 3.0.1-1
    GPUs process monitoring for AMD, Intel and NVIDIA
local/onetbb 2021.8.0-2
    High level abstract threading library (oneAPI Threading Building Blocks)

It may be worthwhile for one of the maintainers to take a look at the mhwd profile.
But for now I suppose keep those config files … they are pretty nonobtrusive … outside of setting modesetting and the busid theres that backlight option … and thats about it.
Many people keep ones for options anyways - I do for options like TearFree.

Okay I’ll do that
One more question about it
Now my nvidia-smi looks like this

Thu May 11 04:01:57 2023       
| NVIDIA-SMI 530.41.03              Driver Version: 530.41.03    CUDA Version: 12.1     |
| GPU  Name                  Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf            Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                                         |                      |               MIG M. |
|   0  NVIDIA GeForce RTX 3050 L...    On | 00000000:01:00.0 Off |                  N/A |
| N/A   47C    P8                6W /  N/A|      5MiB /  4096MiB |      0%      Default |
|                                         |                      |                  N/A |
| Processes:                                                                            |
|  GPU   GI   CI        PID   Type   Process name                            GPU Memory |
|        ID   ID                                                             Usage      |
|    0   N/A  N/A      1089      G   /usr/lib/Xorg                                 4MiB |

Does it mean my nvidia GPU is never in idle mode ?

And I’ll try adding TearFree too

nvidia specifics are going to be a bit beyond me. never had one.
My intel memory is a bit fuzzy.
I use amd now. :sweat_smile:

Ahah okay :slight_smile:
If someone someday has the solution it would be gladly welcomed. I am a bit anxious to not know what is going on x)

Thanks a lot ! :slight_smile: