Can't run VirtualBox

I am trying to install VirtualBox, but after installing, it won't run. I installed it via pacman. And chose the linux56 module? I think. But, after install. The icon won't start it and thought of running it in Command line. Then this showed up.

[doodmann@doodmann-k52f ~]$ virtualbox
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
         available for the current kernel (5.6.15-1-MANJARO) or it failed to
         load. Please recompile the kernel module and install it by

           sudo /sbin/vboxconfig

         You will not be able to start VMs until this problem is fixed.
/usr/lib/virtualbox/VirtualBox: /usr/lib/libQt5Core.so.5: version `Qt_5.15' not found (required by /usr/lib/virtualbox/VirtualBox)
/usr/lib/virtualbox/VirtualBox: /usr/lib/libQt5Core.so.5: version `Qt_5.15' not found (required by /usr/lib/virtualbox/UICommon.so)
[doodmann@doodmann-k52f ~]$ 


Thanks in advance!

Forum search is your friend

1 Like

Kernel 5.6 is EOL, I think you need to replace it.

1 Like

That's exactly it. Kernel 5.6 and it's modules were dropped from the repos. The last 5.6 release was 5.6.19, so you haven't updated in awhile.

Install 5.7 stable or 5.4 LTS. You can also install the meta packages linux-latest or linux-lts.

Forum kindly sponsored by