Can't run Sparky Linux (installed after manjaro, UEFI)

@EpifanioTequilaMex, you said you cannot run sparky from manjaro po.
In manjaro, have you done “sudo update-grub”?
If yes and sparky cannot boot from manjaro po, it may be swap uuid that’s the problem.
Can you provide at manjaro terminal
o sudo blkid
o sudo fdisk -l
o cat /etc/fstab

And from manjaro’s file manager, contents of
o sparky /etc/fstab
o sparky entry of **manjaro’**s /boot/grub/grub.cfg (one entry will do, sparky entry)
o sparky entry of sparky’s /boot/grub/grub.cfg (one entry will do, sparky entry)

[side note] -
windows booting fine?
what po (or whose grub) and what efi partition (1 or 7)?

@gohlip yes, done sudo update-grub from manjaro, many times.

BUT NOW I’M ON A DIFFERENT SITUATION:

reinstalled sparky, when it asked for EFI partition, i’ve checked sda1 (the manjaro EFI part) without formatting.

what i’ve got is: manjaro PO disappeared, there are only windows boot and sparky PO now.

well, running sparky po, manjaro stops with kernel panic, sparky stops with the microcode error

i can run sparky terminal but not manajro terminal (kernel panic)

i’m on sparky po sda1

Running sparky

MODPROBE: MODULE MICROCODE NOT FOUND IN MODULES.DEP

update-grub

I think your sda2 (Microsoft reserved) is broken. Also, you now have 3 boot partitions. Windows also has its own in sda10. I don’t know but I think you need to contact Sparky Linux and ask them about it. It has something to do with how they do their microcode handling. I think you need to clean up those uneeded efi partitions first.

At sparky grub menu… see here - (case 1)

When booted into manjaro, at manjaro terminal,

sudo grub-install

to get back manjaro PO.
Then update-grub to include sparky entry.

ps; recheck your uuid’s especially swap uuid and see if it coreespond with all.
ie., compare sudo blkid with fstab and grub.cdf; both for manjaro and sparky OS’s.

note: I assume sparky in on grub2, not refind or systemd boot ($esp is mounted as /boot/efi, not /boot)

@gohlip new situation:

i had to reinstall manjaro, then, after upgrading and rebooting, installed nvidia by
sudo mhwd -i pci video-nvidia
without errors, but after rebooting, i got blank screen;

then Ctrl Alt F2, login
(look at the picture, next post)

mhwd -li

video-hybrid-intel-nouveau-bumblebee 2016.01.28 TRUE(freedriver) PCI
video-nvidia------------------------------------- 2016.04.25 FALSE PCI

startx

/etc/X11/mhwd.d/intel.conf

##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 
Section "Device"
	Identifier  "Device0"
	Driver      "intel"
	BusID       "PCI:0:2:0"
	Option      "AccelMethod" "sna"
	Option      "DRI"    "true"
	Option "DRI" "3"
EndSection
 
 
Section "DRI"
        Group  "video"
        Mode   0666
EndSection
 
 
Section "Extensions"
	Option "Composite" "Enable"
	Option "RENDER"    "Enable"
EndSection
 
 
Section "InputClass"
	Identifier          "Keyboard Defaults"
	MatchIsKeyboard	    "yes"
	Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

/etc/X11/mhwd.d/nvidia.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 364.19  (buildmeister@swio-display-x64-rhel04-11)  Tue Apr 19 15:22:17 PDT 2016

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection

 
Section "InputClass"
	Identifier          "Keyboard Defaults"
	MatchIsKeyboard	    "yes"
	Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
inxi -G
Graphics:  Card-1: Intel Skylake Integrated Graphics
               Card-2: NVIDIA GM107M [GeForce GTX 950M]
               Display Server: X.Org 1.17.4 driver: intel
               Resolution: 1368x768@60.00hz
               GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
               GLX Version: 3.0 Mesa 11.2.2

.local/share/xorg/Xorg.0.log

[    51.067] 
X.Org X Server 1.17.4
Release Date: 2015-10-28
[    51.068] X Protocol Version 11, Revision 0
[    51.068] Build Operating System: Linux 4.5.7-1-MANJARO x86_64 
[    51.068] Current Operating System: Linux xmanj 4.7.0-0-MANJARO #1 SMP PREEMPT Sun Jul 24 23:30:32 UTC 2016 x86_64
[    51.068] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.7-x86_64 root=UUID=734ea3de-2b65-4f6d-a731-e918b9708e62 rw quiet splash resume=UUID=a671cf78-05a5-4d77-8212-ed839e58593d
[    51.068] Build Date: 17 July 2016  10:10:01PM
[    51.068]  
[    51.068] Current version of pixman: 0.34.0
[    51.069] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    51.069] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    51.070] (==) Log file: "/home/xmanj/.local/share/xorg/Xorg.0.log", Time: Mon Aug  8 10:32:27 2016
[    51.070] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    51.070] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    51.071] (==) ServerLayout "Layout0"
[    51.071] (**) |-->Screen "Screen0" (0)
[    51.071] (**) |   |-->Monitor "Monitor0"
[    51.071] (**) |   |-->Device "Device0"
[    51.071] (**) |-->Input Device "Keyboard0"
[    51.071] (**) |-->Input Device "Mouse0"
[    51.071] (==) Automatically adding devices
[    51.071] (==) Automatically enabling devices
[    51.071] (==) Automatically adding GPU devices
[    51.071] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    51.071] 	Entry deleted from font path.
[    51.071] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    51.071] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    51.071] 	Entry deleted from font path.
[    51.071] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    51.071] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/OTF/,
	/usr/share/fonts/Type1/
[    51.071] (==) ModulePath set to "/usr/lib/xorg/modules"
[    51.071] (**) Extension "Composite" is enabled
[    51.071] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    51.072] (WW) Disabling Keyboard0
[    51.072] (WW) Disabling Mouse0
[    51.072] (II) Loader magic: 0x81ed20
[    51.072] (II) Module ABI versions:
[    51.072] 	X.Org ANSI C Emulation: 0.4
[    51.072] 	X.Org Video Driver: 19.0
[    51.072] 	X.Org XInput driver : 21.1
[    51.072] 	X.Org Server Extension : 9.0
[    51.080] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[    51.081] (II) xfree86: Adding drm device (/dev/dri/card0)
[    51.082] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[    51.085] (--) PCI:*(0:0:2:0) 8086:1916:1043:24aa rev 7, Mem @ 0xdd000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[    51.085] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    51.085] (II) LoadModule: "glx"
[    51.086] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    51.092] (II) Module glx: vendor="NVIDIA Corporation"
[    51.092] 	compiled for 4.0.2, module version = 1.0.0
[    51.092] 	Module class: X.Org Server Extension
[    51.092] (II) NVIDIA GLX Module  364.19  Tue Apr 19 14:10:52 PDT 2016
[    51.092] (II) LoadModule: "nvidia"
[    51.092] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    51.092] (II) Module nvidia: vendor="NVIDIA Corporation"
[    51.092] 	compiled for 4.0.2, module version = 1.0.0
[    51.092] 	Module class: X.Org Video Driver
[    51.092] (II) NVIDIA dlloader X Driver  364.19  Tue Apr 19 13:48:55 PDT 2016
[    51.092] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    51.092] (++) using VT number 2

[    51.092] (--) controlling tty is VT number 2, auto-enabling KeepTty
[    51.092] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[    51.093] (EE) No devices detected.
[    51.093] (EE) 
Fatal server error:
[    51.093] (EE) no screens found(EE) 
[    51.093] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    51.093] (EE) Please also check the log file at "/home/xmanj/.local/share/xorg/Xorg.0.log" for additional information.
[    51.093] (EE)

Your driver is not nvidia. Use

sudo mhwd -a pci nonfree 0300

to install your graphic driver. Also remove the nvidia driver first. Your driver should be hybrid-intel-nvidia-bumblebee because you’re using a hybrid graphic laptop. Good luck :slight_smile:

sudo pacman -Rdd nvidia
is it enough @crazyg4merz?

inxi -G
Graphics:  Card-1: Intel Skylake Integrated Graphics
           Card-2: NVIDIA GM107M [GeForce GTX 950M]
           Display Server: X.Org 1.17.4 driver: intel Resolution: 1368x768@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) GLX Version: 3.0 Mesa 11.2.2

mhwd -li

Installed PCI configs:


              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2016.04.20                true            PCI

video-hybrid-intel-nvidia-bumblebee 2016.02.05 false PCI

Warning: No installed USB configs!

@crazyg4merz

Use mhwd instead

sudo mhwd -r pci video-hybrid-intel-nouveau-bumblebee
sudo mhwd -r pci video-nvidia
sudo mhwd -a --force pci nonfree 0300

Use --force to force reinstall because removing those above sometimes remove the Xorg.conf too.

sudo mhwd -a pci nonfree 0300
> Skipping already installed config 'video-hybrid-intel-nvidia-bumblebee' for device: 0000:00:02.0 (0300:8086:1916) Display controller Intel Corporation Sky Lake Integrated Graphics.

Forum kindly sponsored by Bytemark