Can't run python IDLE

I’m trying to run Python IDLE but I get this error:

** IDLE can't import Tkinter.
Your Python may not be configured for Tk. **

I tried installing tkinter with pip. That did not work either:

Defaulting to user installation because normal site-packages is not writeable
ERROR: Could not find a version that satisfies the requirement tkinter (from versions: none)
ERROR: No matching distribution found for tkinter

No idea what to do.

You don’t need to install tkinter using pip, it’s in the repositories as tk.

Try

sudo pacman -Syu tk

and see if that helps.

1 Like

I swear I tried this earlier and it didn’t work. But it just worked now. Maybe I haven’t had enough coffee today. Thanks! :laughing:

1 Like

I tried this, I get exactly the same errors as he does. I can’t run any of the Python
scripts I have been practicing with. This is very frustrating. I have tried various other
versions of Linux over the years and this is the first time I have ever had ANY problems
with python. usually it JUST WORKS, what is wrong with this distro that it can’t even
run a simple python program!!!
frustrated!!
bobby

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.