Can't run any waydroid related command without gbinder error

Kernel: 5.14.2-1                                                                                  
DE: Plasma 5.22.5 
WM: KWin
CPU: Intel i7-4790 
GPU: NVIDIA GeForce GTX 970 

I had installed both waydroid and waydroid image from the aur, gbinder is also was installed, but any command that’s related to the waydroid is giving me a gbinder error.


Traceback (most recent call last):
File "/usr/bin/waydroid", line 6, in
import tools
File "/usr/lib/waydroid/tools/**init**.py", line 9, in
from . import actions
File "/usr/lib/waydroid/tools/actions/**init**.py", line 3, in
from tools.actions.initializer import init
File "/usr/lib/waydroid/tools/actions/", line 5, in
from tools import helpers
File "/usr/lib/waydroid/tools/helpers/**init**.py", line 5, in
import tools.helpers.props
File "/usr/lib/waydroid/tools/helpers/", line 7, in
from tools.interfaces import IPlatform
File "/usr/lib/waydroid/tools/interfaces/", line 1, in
import gbinder
ModuleNotFoundError: No module named 'gbinder'

Have you run:
sudo waydroid init
systemctl enable waydroid-container --now
waydroid show-full-ui
in that order before anything else?

and if is not responding after some point, and want to stop it
waydroid session stop

Yep, I’ve tried all of them except this one:

systemctl enable waydroid-container --now

It’s succesefuly created a symlink, but all of the others no matter in which order I input them in the console are giving me a gbinder error.

Well, i only tested it on PinePhone with Phosh, but have you tried to install libgbinder and python-gbinder packages from AUR? I think there are differences between the ARM and x86_64 default official packages …

Both of them were installed.

I saw posts that it’s working on the ubuntu with x86 CPUs, and that’s quite strange for me when you guys are now actively in the cooperation with the Pine64, but on yours own system it’s not working with a dekstops.
Did you tested it only on the phones but not on yours own PCs?

Great, they have a bigger team and time for more experiments. Cool.

The project waydroid started 30 days ago. Not sure why are so high the expectancies from outside …

Tested it only on the PinePhone, yes, i mentioned that. I only have one PC, and no plans to test waydroid on it any time soon. Hands tide with other things to do.

Oh, so you’re the only one who’s working on it, right?
Good luck then and thanks for your job.
Hope that the once waydroid will work on the PC.

100% i am not working on it at all. :slightly_smiling_face:
Other team members do …

Just a little information.

Waydroid only works on a Wayland session.


Yes only on Wayland

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.