Can't reinstall Manjaro on my SSD

I’m trying to reinstall Manjaro on my computer, but for some reason I get the following error message when I start the instalation.

The installer failed to create partition on disk 'Lexar 480GB SSD'.
Create a new partition (50.00 GiB, ext4) on ‘/dev/sda’
Job: Create new partition on device ‘/dev/sda’
Failed to add partition ‘New Partition’ to device ‘/dev/sda’.

I get similar errors no matter which option of partitioning I choose.
Also, I tried deleting the current Manjaro partitions on gparted, so I can start from scratch, but they are seemingly undeletable, they appear to be gone for the moment I do it without error messages, but once I close gparted and open it up again they are back there.
Can someone help me? I don’t know else to do.

If there isn’t anything on the drive, try creating a new partition table via gparted, select GPT. And see if that fixes it.

Note: This will wipe the drive

You need to hit apply in gparted to really apply all the changes you made. Perhaps you just forgot to do that?

1 Like

Could it be because your existing file system is using LVM?

If such inconsistencies happen with me, and I have no data to save, I run a bunch of zeros (32MiB) over the start of the drive, sync, then force a partprobe, and redo the setup in parted / partition manager.

Make sure you use the appropriate device names in your system. Be extra cautious.

sudo dd if=/dev/zero of=/dev/sdX bs=1M count=32 status=progress


sudo partprobe -s

Then I continue to create a new partition scheme with parted, Gparted, or KDE Partition Manager.