Can't press login button - KDE Plasma

Hi, I’m trying to login to my Manjaro KDE but I just can’t press the login button. I can enter my password but it simply doesn’t work, it doesn’t even check it, neither if I press the login button or enter. Half an hour ago it worked perfectly, then it turned black, I rebooted and now I can’t login anymore. What could it be? A few minutes before it stuck I ran sudo pacman -Ruscn ktexteditor to install ktexteditor-git, since kate didn’t work, but I don’t know if it has anything to do with it. I can correctly login with CTRL+ALT+F3

This is what will happen when I run that command:

LANG=EN sudo pacman -Ruscn ktexteditor
checking dependencies...
:: dolphin optionally requires kde-cli-tools: for editing file type options
:: dolphin-plugins optionally requires ktexteditor: Mercurial plugin
:: frameworkintegration optionally requires appstream-qt: dependency resolving via AppStream
:: groff optionally requires libxaw: for gxditview
:: kio-extras optionally requires kactivities-stats: recently used kioslave
:: ksysguard optionally requires networkmanager-qt: improved network statistics
:: xdg-utils optionally requires kde-cli-tools: for KDE Plasma5 support in xdg-open

Packages (40) accountsservice-0.6.55-3  appstream-0.14.0-4  appstream-qt-0.14.0-4  editorconfig-core-c-0.12.4-1
              http-parser-2.9.4-1  kactivities-stats-5.78.0-1  kactivitymanagerd-5.20.5-1  kate-20.12.2-1
              kde-cli-tools-5.20.5-1  kdelibs4support-5.78.0-1  kdeplasma-addons-5.20.5-1  kdesu-5.78.0-1
              kemoticons-5.78.0-1  kholidays-1:5.78.0-1  khotkeys-5.20.5-1  kinfocenter-5.20.5-1  kquickcharts-5.78.0-1
              kunitconversion-5.78.0-1  libdmtx-0.7.5-2  libgit2-1:1.1.0-1  libqalculate-3.16.1-1  libxaw-1.0.13-3
              modemmanager-qt-5.78.0-1  networkmanager-qt-5.78.0-1  plasma-desktop-5.20.5-2  plasma-integration-5.20.5-1
              plasma-nm-5.20.5-1  plasma-pa-5.20.5-1  plasma-workspace-5.20.5-2  polkit-kde-agent-5.20.5-1
              powerdevil-5.20.5-1  prison-5.78.0-1  qqc2-desktop-style-5.78.0-1  qrencode-4.1.1-1
              sddm-breath2-theme-1.0.10-2  systemsettings-5.20.5-1  ttf-hack-3.003-3  xorg-xmessage-1.0.5-2
              xorg-xsetroot-1.1.2-2  ktexteditor-5.78.0-1

Total Removed Size:  201.34 MiB

:: Do you want to remove these packages? [Y/n] 

If you said “yes” and went ahead
it seems you removed a number of some quite essential packages.

Someone else might be able to tell you how to reinstall them easily.
My only idea is to reinstall them one by one - but I’m sure that that is not the most elegant solution.

1 Like

Mh yes, It could be possible. I’ll try to install them one by one, let’s hope it’ll work. I’ll let you know

It’s possible you don’t have network anymore - since parts of NetworkManager got removed.
But the packages should still be in your pacman cache.
ls -al /var/cache/pacman/pkg

WiFi didn’t work but fortunately Lan connection yes, and it seems it worked. Thank you! I’ll be more careful on uninstalling packages in future