Can't make my D-link USB wifi work with ndiswrapper

There was a storm in my town last night and my integrated Lan cards don’t work anymore, so I tried an old wifi card I have.
The device is D-Link DWA-142 with Marvell chipset
I was able to install the XP 64bit driver with ndiswrapper, but have problems with power management.
This is my output:

[neo@neo-manjaro-pc ~]$ ndiswrapper -l
netmw246 : driver installed
        device (07D1:3B10) present
[neo@neo-manjaro-pc ~]$ sudo ndiswrapper -m
module configuration already contains alias directive

[neo@neo-manjaro-pc ~]$ sudo depmod -a
[neo@neo-manjaro-pc ~]$ sudo modprobe ndiswrapper
[neo@neo-manjaro-pc ~]$ sudo dmesg | grep ndiswrapper
[  143.173196] ndiswrapper: loading out-of-tree module taints kernel.
[  143.173456] ndiswrapper: module verification failed: signature and/or required key missing - tainting kernel
[  143.173472] ndiswrapper: module license taints kernel.
[  143.180256] ndiswrapper version 1.63 loaded (smp=yes, preempt=yes)
[  143.593177] ndiswrapper: driver netmw246 (Marvell,09/26/2007, loaded
[  144.620813] usbcore: registered new interface driver ndiswrapper
[  144.630133] ndiswrapper 2-1:1.0 enp1s0u1: renamed from wlan0
[  144.645073] ndiswrapper: interface renamed to 'enp1s0u1'
[  144.694873] ndiswrapper (mp_set_power_state:367): enp1s0u1 does not support power management; halting the device
[  145.263932] ndiswrapper (mp_init:211): couldn't initialize device: C0000001
[  145.263935] ndiswrapper (mp_set_power_state:336): enp1s0u1: couldn't set power to state 1; device not resumed
[  145.263936] ndiswrapper (ndis_reinit:1250): starting device enp1s0u1 failed: C0000001
[neo@neo-manjaro-pc ~]$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp1s0u1: <BROADCAST,MULTICAST> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 00:1b:11:52:2e:3e brd ff:ff:ff:ff:ff:ff
[neo@neo-manjaro-pc ~]$ iwconfig
lo        no wireless extensions.

enp1s0u1  no wireless extensions. 

How do I turn off power save for the device? I tried a few things but they didn’t work, probably because the only instructions I found were for other distros.