Can't make clock show correct time

So, I installed Microsoft Teams bacause I need It for the school. But, In order to work I needed to make my clock on laptop same as the one on internet, and forum which I was looking suggested I type this commands in terminal:

sudo systemctl enable systemd-timesyncd.service
timedatectl set-ntp true

After this It works, but my clock is one hour behind. I tried to change It in settings, but It didn’t work. How can I fix this without making Microsoft Teams broken again?

Check Manjaro Settings Manager. There you will find “Time and Date.” Once there, make sure your time zone is set correctly.


Dual-booting windows I presume?

Yes, I dual boot! I will try this solution soon

This is a solution for me, my computer clock was showing two minutes late compared to my phone. Going to Settings -> Time and date and checking “Make time date automatic” changed the clock to the same time as my phone. I am (currently) running KDE.