cant login to lightdm

Usually i use auto-login but today i was given a login screen. I entered my username, password but was told the password or username was incorrect.

Booted to single mode to check i was entering the correct username and reset the password and root password at the same time. After trying to login to my usual account a few times i decided to try root and it worked. I looked at the lightdm.log and it shows that it is failing to authenticate but doesn't say why and there is nothing outstanding in the journal.

Below is where the auto login fails in lightdm.log.

[+2.27s] DEBUG: XServer 0: Connecting to XServer :0
[+2.28s] DEBUG: posix_spawn avoided (fd close requested) (child_setup specified) 
[+2.28s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+2.28s] DEBUG: Session pid=675: Started with service 'lightdm-autologin', username 'defualt'
[+2.32s] DEBUG: Session pid=675: Authentication complete with return value 7: Authentication failure
[+2.32s] DEBUG: Seat seat0: Switching to greeter due to failed authentication
[+2.32s] DEBUG: Seat seat0: Creating greeter session
[+2.32s] DEBUG: Session pid=676: Started with service 'lightdm-greeter', username 'lightdm'

I don't really know what other information is useful. I haven't downloaded any new software and there have been no updates these past few days. I tried running pamac update and that threw a few errors, not sure if its related or not.

That's a weird spelling of default. Where did that come from X.org log?

Run pacdiff to merge new settings.

1 Like

That was me not noticing when I created the account. Wasn't until a week or two after at which point I didn't want to make a new user.

Done that and then rebooted but now it doesn't load lightDM at all.
Logs says it failed to find session configuration lightdm-gtk-greeter.

Have you considered you edited something wrong?
Can you post your config files?

inxi -SMxxxza
pacman -Qs lightdm
grep -v ^# /etc/lightdm/lightdm.conf
grep -v ^# /etc/lightdm/lightdm-gtk-greeter.conf
2 Likes

I haven't edited any config files, thats why im so confused as to why this has suddenly happened.

Here are the outputs from the four commands in order:

System:    Host: manjaro-pc Kernel: 4.19.69-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 
           root=UUID=e9ef425e-0f14-41fa-8683-e2e7521c33c2 rw quiet 
           Desktop: i3 4.17.1 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 13-5378 v: N/A serial: <filter> Chassis: 
           type: 9 serial: <filter> 
           Mobo: Dell model: 0P87CH v: A00 serial: <filter> UEFI: Dell v: 1.25.0 date: 05/14/2018 




local/lightdm 1:1.30.0-2
    A lightweight display manager
local/lightdm-settings 1.2.8-1
    A configuration tool for the LightDM display manager
local/lightdm-slick-greeter 1.2.7-1
    A slick-looking LightDM greeter




[LightDM]
run-directory=/run/lightdm

[Seat:*]
session-wrapper=/etc/lightdm/Xsession

[XDMCPServer]

[VNCServer]

Thats only 3 :wink:

Sample

~ >>> inxi -SMxxxza                                                                                                                 
System:    Host: mx Kernel: 5.2.14-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=9030b9ef-9aab-4578-92c7-b085e2b31cbb rw loglevel=3 quiet 
           Desktop: i3 4.17.1 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: P8Z77-V DELUXE v: Rev 1.xx serial: <filter> BIOS: American Megatrends v: 2104 
           date: 08/13/2013 

~ >>> pacman -Qs lightdm                                                                                                            
local/light-locker 1.8.0-2
    A simple session locker for LightDM
local/lightdm 1:1.30.0-2
    A lightweight display manager
local/lightdm-gtk-greeter 1:2.0.6-1
    GTK+ greeter for LightDM
local/lightdm-gtk-greeter-settings 1.2.2-3
    Settings editor for the LightDM GTK+ Greeter

~ >>> grep -v \# /etc/lightdm/lightdm.conf                                                                                          
[LightDM]
run-directory=/run/lightdm

[Seat:*]
session-wrapper=/etc/lightdm/Xsession

[XDMCPServer]

[VNCServer]

~ >>> grep -v \# /etc/lightdm/lightdm-gtk-greeter.conf                                                                              
[greeter]
background = /home/sgs/Bilder/Wallpaper/navy-breath-14-2160p-sgs.svg
font-name = Cantarell 14
xft-antialias = true
icon-theme-name = default
screensaver-timeout = 0
theme-name = Matcha-dark-sea
cursor-theme-name = xcursor-breeze
show-clock = false
default-user-image = /usr/share/grub/sgs.png
xft-hintstyle = hintfull
position = 50%,center 50%,center
clock-format = 
panel-position = bottom

Post all , input and output, so we can see typos inside the command.
I use zsh so diff. commands

You have no auto-login set.
As said

pacdiff --help

yeah the last on[quote="SGS, post:8, topic:102577, full:true"]
Thats only 3 :wink:

Sample

~ >>> inxi -SMxxxza                                                                                                                 
System:    Host: mx Kernel: 5.2.14-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=9030b9ef-9aab-4578-92c7-b085e2b31cbb rw loglevel=3 quiet 
           Desktop: i3 4.17.1 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: P8Z77-V DELUXE v: Rev 1.xx serial: <filter> BIOS: American Megatrends v: 2104 
           date: 08/13/2013 

~ >>> pacman -Qs lightdm                                                                                                            
local/light-locker 1.8.0-2
    A simple session locker for LightDM
local/lightdm 1:1.30.0-2
    A lightweight display manager
local/lightdm-gtk-greeter 1:2.0.6-1
    GTK+ greeter for LightDM
local/lightdm-gtk-greeter-settings 1.2.2-3
    Settings editor for the LightDM GTK+ Greeter

~ >>> grep -v \# /etc/lightdm/lightdm.conf                                                                                          
[LightDM]
run-directory=/run/lightdm

[Seat:*]
session-wrapper=/etc/lightdm/Xsession

[XDMCPServer]

[VNCServer]

~ >>> grep -v \# /etc/lightdm/lightdm-gtk-greeter.conf                                                                              
[greeter]
background = /home/sgs/Bilder/Wallpaper/navy-breath-14-2160p-sgs.svg
font-name = Cantarell 14
xft-antialias = true
icon-theme-name = default
screensaver-timeout = 0
theme-name = Matcha-dark-sea
cursor-theme-name = xcursor-breeze
show-clock = false
default-user-image = /usr/share/grub/sgs.png
xft-hintstyle = hintfull
position = 50%,center 50%,center
clock-format = 
panel-position = bottom

Post all , input and output, so we can see typos inside the command.
I use zsh so diff. commands
[/quote]

The last one below said the file/directory does not exist

grep -v # /etc/lightdm/lightdm-gtk-greeter.conf

Maybe slick-greeter.conf

grep -v ^# /etc/lightdm/slick-greeter.conf

Read my previous post...

Oh, so frustrating!!! :scream_cat:

1 Like

Output of:

grep -v ^# /etc/lightdm/slick-greeter.conf
[Greeter]
background=/usr/share/backgrounds/i3_default_background.jpg
background-color=#2e3d44
draw-grid=false
theme-name=Adapta-Nokto-Eta-Maia
icon-theme-name=Papirus-Adapta-Nokto-Maia
font-name='Noto Sans 11'
xft-antialias=true
xft-hintstyle=hintfull
enable-hidpi=auto

Running this has no output.

It should, since you said you had auto-login enabled. How was it enabled, if not at lightdm???

Anyway

Edit:
You have lightdm-gtk-greeter but no conf files.
You don't have lightdm-slick-greeter but have conf files.??

1 Like
^

Dos not work , the \ help
and sometimes are 'needed in 'text,www,..' :wink:
All in all, it makes it clear to me that I now know that I know nothing. :slight_smile:

I did run pacdiff the first time you said. It asked to overwrite lightdm.conf which i said yes to, after rebooting i then replied with:

sudo nano /etc/lightdm/lightdm-gtk-greeter.conf

Look at my .conf and edit to your needs.

  • for nano you can also use vi, vim, ... I prefere 'micro' :slight_smile:
1 Like

Where can i find your config?

Post #8 :wink:
or

~ >>> grep -v \# /etc/lightdm/lightdm-gtk-greeter.conf                                                                              
[greeter]
background = /home/sgs/Bilder/Wallpaper/navy-breath-14-2160p-sgs.svg
font-name = Cantarell 14
xft-antialias = true
icon-theme-name = default
screensaver-timeout = 0
theme-name = Matcha-dark-sea
cursor-theme-name = xcursor-breeze
show-clock = false
default-user-image = /usr/share/grub/sgs.png
xft-hintstyle = hintfull
position = 50%,center 50%,center
clock-format = 
panel-position = bottom

1 Like

Why? There was a question for a reason... :scream_cat::cry:
You should always (V)View differences and merge old with new settings. Next time...
You have to set the greeter value to the one you have installed, plus other stuff.

1 Like

Forum kindly sponsored by Bytemark