Can't login after restarting after interrupting an update

I know I shouldn’t interrupt an update but I did not have a choice in the matter.

I had started a pacman update but was not able to finish it and just now had restarted the machine but now the sign in screen is a different sddm theme and is probably the default screen for kde plasma (I am guessing it was in the update and was not properly installed) all the buttons on the screen work and I can move my cursor around but when I go to sign in and type in the correct password nothing happens and the buttons on the screen stop working. I can no longer edit what I typed into the text bar but I can still move my cursor and the clock stops updating . it gives me an error message in red before I go to sign in: The current theme cannot be loaded due to the errors below, please select another theme.
file:///usr/share/sddm/themes/mountain-heights-11SDDM/Main.qml:26:1 plugin cannot be loaded for module “org.kde.plasma.core”: Cannot load library /usr/lib/qt/qml/org/kde/plasma/core/ (/usr/lib/ undefined symbol: wl_proxy_marshal_flags)

thank you for your time

whatever the cause - we have to deal with the consequences :wink:

one way is:
chroot into your system
using the live system you used to install from
(boot from it - use a terminal to chroot into your dysfunctional system …)
then redo/finish the update there …

when I go to chroot into my system, and run manjaro-chroot /mnt /bash it returns with "chroot failed to run command ‘/bash’ : No such file or directory

manjaro-chroot -a

Thanks, it worked

Your prompt should look a little different.
You could also check with things like

echo $?

(0=regular, 1=chroot)

I think it worked because I am able to update my system, but when I try to chroot in on another tab it says I am 0. I think this is just because i am in chroot on another tab though.

Edit: I tried it with the tab that I was actually chroot on and it came back as 0

Thanks, this worked

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.