Can't log into Manjaro - cgroup: cgroup2: unknown option "nsdelegate"


#9

@bogdancovaciu

Thank you man, but I don’t think my processor supports 64 bit because I tried to install 64 bit windows but it didn’t get installed. I’m waiting for someone fix the issue and I’m on live usb right now, I tried chroot but yet it gave me that “kernel 4.9.20” it’s weird I’m using one of the latest kernels normally.

My last option is to reinstall manjaro but I’m afraid I’ll have the same issue. :S

lscpu:

Architecture:          i686
CPU op-mode(s):        32-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 14
Model name:            Intel(R) Core(TM) Duo CPU      T2450  @ 2.00GHz
Stepping:              12
CPU MHz:               800.000
CPU max MHz:           2000.0000
CPU min MHz:           800.0000
BogoMIPS:              4001.77
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc arch_perfmon bts aperfmperf eagerfpu pni monitor est tm2 xtpr pdcm dtherm

#10

Unfortunately this isn’t true for the Core Duo T2450. If the inxi in post 1 is right, the CPU doesn’t support 64 bit.


#11

I might have looked at wrong specs for your processor …
Can you install a later kernel?


#12

@bogdancovaciu

As I said, I’m on live usb right now and I’m having the problem on the topic, man. I’m already using the latest kernel on the stable packages normally. I’m not able to download or install a new kde manjaro iso right now. I need to get my manjaro back first.


#13

Did you try this, do you have access there?

Once you log in there to try: startx


#14

-only 32 bits
may be try to install kernel 4.4 LTS (32 bits )

you have to see after for any DE 32 bits
this topic is a good one


#15

@bogdancovaciu

I’ll try that but right now I’m waiting for new updates, man.


#16

@stephane

I wanna install linux414 but I can’t. I think there’s no linux414 for 32-bit or I need to switch to the testing repository or the unstable? I don’t know tho


#17

Not linux414, linux44. You may need a older Kernel, so try linux44.


#18

@xabbu

I’m downloading it on chroot, it seems like an older one


#19

@bogdancovaciu

Thank you man, Never thought to type startx on tty, startx did the trick but I can only use the kernel 4.12.14-1 right now and I can’t use the kernel 4.13.9-1 with or without elevator=cfq in grub and I can’t do CTRL + ALT + F2 for TTY when I want to boot the kernel 4.13.9-1 because it doesn’t response. it gives some errors like;

? bfq_max_budget_store+0x2f/0xb0
etc.

Apparently I’ll not able to use manjaro anymore because they won’t support 32-bit. Sad.


#20

restart with USB install
then sudo manjaro-chroot -a

then
pacman -Syy

mhwd-kernel -l
–> install linux4.4 LTS not ( 4.14 or 4.13 )

mhwd-kernel -i linux44
exit ( leave chroot )

restart
and go in details in grub options for select another kernel


#21

@philm

I will go crazy, man. I can’t log into manjaro.

Stuck on cgroup:cgroup2:unknown option “nsdelegate”

Also I don’t know if I still need to use elevator=cfq


#22

I need more info to help you out.


#23

@philm

As I said, man. Stuck on this boot message > cgroup:cgroup2:unknown option “nsdelegate” I can’t see the green log in screen. All I see is that message on black screen.


#24

@manja1: can you either login to a TTY to see where the issue is or at least remove the quiet option from the grub entry so we see some messages.


#25

@philm

I will do it man, I’m on live usb now, it’s hard for me to do the process you know, I’ll be right with you.


#26

@philm

I did ctrl alt f2 and log into on tty and sudo update-grub but nothing changed and gave the same error:

cgroup:cgroup2:unknown option “nsdelegate”

And I also removed “quiet” in grub

Again I didn’t able to see the Green Log in screen

it says;

[ OK ] Started Avahi mDnS/ bla bla
          Starting Network Manager...
[ OK ] Starting...
[ OK ] Starting...
[ OK ] Starting...
[ OK ] Starting...

All of them are [ OK ]

But I didn’t able to see the Green Log in screen again it’s stuck on there and nothing happens

I’m getting this error maybe because of some packages because I’ve seen it before and had to switch back to the stable repo.

Immediately help man


#27

just to be sure: did you check if your main mirror was synced before updating? if not, maybe try a “sudo pacman -Syyu” in tty.


#28

@Termy

Man, I tried everything I know, I’ve said multiple times and I’m tired of rebooting live usb and doing chroot everytime and I believe this happened because of some corrupt packages I’ve experienced this "cgroup:cgroup2:unknown option “nsdelegate” " error before. Someone has to update the packages I think and thus I will get rid of this problem. That’s all I know. I’m using the stable repo but I’m still getting errors. I think I need to use the unstable one instead. The same thing.