Cant log into default user after May 7 update

update
sddm

#1

I updated my system Manjaro KDE 17.1.9 yesterday via pacui(mistake I guess).At the end of installation there was this message shown:

Edit: Also you can see at top of the terminal that there was some pacnew file there, a lot of them. Did not knew what to do so I choose “overwrite” for all those (mistake I guess).

Then I rebooted and there was this message:


Then someone suggested me to change ownership so I did:

chown -Rc sddm:sddm /var/lib/sddm

After that the promt at boot is gone but I cant log into my default user i.e “rahul”.
I can olny log in as root. I changed the permission by logging into root.
I also tried reinstalling sddm but result was same, promt came back.

When I checked into file directory I found that all my files and the user “rahul” is there at /home. But when I tried to do ls -l inside /home/rahul found this:

So this is all I know by now. All I want is log into the user “rahul” and fix this.
Please help.


Warnings From Octopi
#2

Why -Rc ??? Was that a typo or is something i don’t know ?
as root it should be
chown -R sddm:sddm /var/lib/sddm


#3

Ok dont know about what -Rc exactly does. But I did -Rc and it worked. Manjaro Telegram [en] admin told me to do that.


#4

I see that pacui ask to replace config file by the .new files…
did you answered “overide with pacnew” for every files?

if so your /etc/passwd /etc/gshadow /etc/group have been replaced and that put the mess in all created user after installation (yours and some others)

that would explain the "unknown uid 1000: who are you? and the lost of all your users.
and also I guess the user sddm don’t exist anymore


#5

Unfortunately yes. I did overwrite for all of them. So what should I do now?


#6

ok, i don’t know what does that either as i never used it …

So, after that you fixed the sddm rights

That is a big issue, because the overwrite should had been selective with what you already had and only parts of the new files to be added …


#7

to be honest… a clean install is the easier if you don’t have any backup.
as you will have to create all missing user with the same uid etc

as you can see the difference between my actual passwd file and the “pacnew one”

mine:

root:x:0:0:root:/root:/bin/bash
bin:x:1:1:bin:/bin:/usr/bin/nologin
daemon:x:2:2:daemon:/:/usr/bin/nologin
mail:x:8:12:mail:/var/spool/mail:/usr/bin/nologin
ftp:x:14:11:ftp:/srv/ftp:/usr/bin/nologin
http:x:33:33:http:/srv/http:/usr/bin/nologin
dbus:x:81:81:dbus:/:/usr/bin/nologin
nobody:x:99:99:nobody:/:/usr/bin/nologin
systemd-journal-gateway:x:191:191:systemd-journal-gateway:/:/usr/bin/nologin
systemd-timesync:x:192:192:systemd-timesync:/:/usr/bin/nologin
systemd-network:x:193:193:systemd-network:/:/usr/bin/nologin
systemd-bus-proxy:x:194:194:systemd-bus-proxy:/:/usr/bin/nologin
systemd-resolve:x:195:195:systemd-resolve:/:/usr/bin/nologin
systemd-journal-remote:x:997:997:systemd Journal Remote:/:/sbin/nologin
systemd-coredump:x:996:996:systemd Core Dumper:/:/sbin/nologin
uuidd:x:68:68::/:/sbin/nologin
dnsmasq:x:995:995:dnsmasq daemon:/:/sbin/nologin
rpc:x:32:32:Rpcbind Daemon:/var/lib/rpcbind:/sbin/nologin
ntp:x:87:87:Network Time Protocol:/var/lib/ntp:/bin/false
usbmux:x:140:140:usbmux user:/:/sbin/nologin
git:x:994:994:git daemon user:/:/usr/bin/git-shell
avahi:x:991:991:Avahi mDNS/DNS-SD daemon:/:/sbin/nologin
colord:x:990:990:Color management daemon:/var/lib/colord:/sbin/nologin
cups:x:209:209:cups helper user:/:/sbin/nologin
mpd:x:45:45::/var/lib/mpd:/sbin/nologin
nm-openconnect:x:989:989:NetworkManager OpenConnect:/:/sbin/nologin
nm-openvpn:x:988:988:NetworkManager OpenVPN:/:/sbin/nologin
polkitd:x:102:102:PolicyKit daemon:/:/sbin/nologin
rtkit:x:133:133:RealtimeKit:/proc:/sbin/nologin
sddm:x:987:987:Simple Desktop Display Manager:/var/lib/sddm:/sbin/nologin
stephane:x:1000:1000:stephane:/home/stephane:/bin/bash
mysql:x:986:986:MariaDB:/var/lib/mysql:/sbin/nologin

pacnew one:

root:x:0:0::/root:/bin/bash


#8

Ok. But didn’t know what to keep or overwrite. How do I know that what files should I overwrite/skip/quit on that pacnew file found part? Any guide to that would he very helpful. Next time I dont want to make any mistakes for pacnew files.


#9

Wow… so I’m dammed big time with this. There is no way I can find those info anymore I guess. Will go for a clean install. Already took a backup of everything. Thank you for your help. :slight_smile:


#10

the best way to manage the “pacnew” and “pacsave” files is to DON’T overide… keep note of them…
check the difference between your file and the new file or the pacsave ("your file before the update) and the conf file. and if you’re not sure how to merge or if you need… ask on the forum.

and you will learn with time which file do what and if you have to merge it.


#11

@rahzex, In your attempt to master Manjaro, you’ re missing a good backup strategy.
Consider using tools like rsnapshot to automatically take weekly snapshots from places like /etc,… etc.

https://wiki.archlinux.org/index.php/Rsnapshot


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.