Can't log in via graphical login manager

i686

#7

Another option would be to enable haveged. Sometimes this helps.

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

#8

Didn’t work. Can login to normal, super user, and root under console but can’t get past graphic login.


#9

This didn’t work either.


#10

OK, next thing to try is logging in (as your normal user) to a text console then running startx (no sudo).

If it works it’s the DM at fault. If it doesn’t it’s X.


#11

Tried that but that spit out a whole lot of text and failed:

$ startx

/var/log/journal.log looks like this:

[2018-05-26 12:33] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /opt/pacman-mhwd.conf --root / --needed -Sy xf86-video-ati xf86-video-amdgpu xf86-video-intel xf86-video-nouveau vulkan-intel vulkan-radeon libva-mesa-driver libva-vdpau-driver mesa-vdpau'
[2018-05-26 12:33] [PACMAN] synchronizing package lists
[2018-05-26 12:33] [ALPM] transaction started
[2018-05-26 12:33] [ALPM] installed xf86-video-ati (1:18.0.1-1.0)
[2018-05-26 12:33] [ALPM] installed xf86-video-amdgpu (18.0.1-1.0)
[2018-05-26 12:33] [ALPM] installed libxvmc (1.0.10-1)
[2018-05-26 12:33] [ALPM] installed xf86-video-intel (1:2.99.917+812+g75795523-1.0)
[2018-05-26 12:33] [ALPM-SCRIPTLET] >>> This driver now uses DRI3 as the default Direct Rendering
[2018-05-26 12:33] [ALPM-SCRIPTLET]     Infrastructure. You can try falling back to DRI2 if you run
[2018-05-26 12:33] [ALPM-SCRIPTLET]     into trouble. To do so, save a file with the following 
[2018-05-26 12:33] [ALPM-SCRIPTLET]     content as /etc/X11/xorg.conf.d/20-intel.conf :
[2018-05-26 12:33] [ALPM-SCRIPTLET]       Section "Device"
[2018-05-26 12:33] [ALPM-SCRIPTLET]         Identifier  "Intel Graphics"
[2018-05-26 12:33] [ALPM-SCRIPTLET]         Driver      "intel"
[2018-05-26 12:33] [ALPM-SCRIPTLET]         Option      "DRI" "2"             # DRI3 is now default 
[2018-05-26 12:33] [ALPM-SCRIPTLET]         #Option      "AccelMethod"  "sna" # default
[2018-05-26 12:33] [ALPM-SCRIPTLET]         #Option      "AccelMethod"  "uxa" # fallback
[2018-05-26 12:33] [ALPM-SCRIPTLET]       EndSection
[2018-05-26 12:33] [ALPM] installed xf86-video-nouveau (1.0.15-2)
[2018-05-26 12:33] [ALPM] installed vulkan-intel (17.3.6-1.0)
[2018-05-26 12:33] [ALPM] installed vulkan-radeon (17.3.6-1.0)
[2018-05-26 12:33] [ALPM] installed libva-mesa-driver (17.3.6-1.0)
[2018-05-26 12:33] [ALPM] installed libva-vdpau-driver (0.7.4-3)
[2018-05-26 12:33] [ALPM] installed mesa-vdpau (17.3.6-1.0)
[2018-05-26 12:34] [ALPM] transaction completed
[2018-05-26 12:34] [ALPM] running 'systemd-update.hook'...
[2018-05-26 12:35] [PACMAN] Running 'pacman -Syy'
[2018-05-26 12:35] [PACMAN] synchronizing package lists
[2018-05-26 12:57] [PACMAN] Running 'pacman -R sudo'
[2018-05-26 12:57] [ALPM] transaction started
[2018-05-26 12:57] [ALPM] removed sudo (1.8.22-1.0)
[2018-05-26 12:57] [ALPM] transaction completed
[2018-05-26 12:57] [ALPM] running 'systemd-update.hook'...
[2018-05-26 12:57] [PACMAN] Running 'pacman -R catfish'
[2018-05-26 12:57] [ALPM] transaction started
[2018-05-26 12:57] [ALPM] removed catfish (1.4.4-1.0)
[2018-05-26 12:57] [ALPM] transaction completed
[2018-05-26 12:57] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-05-26 12:57] [ALPM] running 'systemd-update.hook'...
[2018-05-26 12:57] [ALPM] running 'update-desktop-database.hook'...
[2018-05-26 12:57] [PACMAN] Running 'pacman -R steam-manjaro'
[2018-05-26 12:57] [ALPM] transaction started
[2018-05-26 12:57] [ALPM] removed steam-manjaro (1.0.0.54-10)
[2018-05-26 12:57] [ALPM] transaction completed
[2018-05-26 12:57] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-05-26 12:57] [ALPM] running 'systemd-udev-reload.hook'...
[2018-05-26 12:57] [ALPM] running 'systemd-update.hook'...
[2018-05-26 12:57] [ALPM] running 'update-desktop-database.hook'...
[2018-05-26 12:57] [PACMAN] Running 'pacman -R pidgin'
[2018-05-26 12:57] [ALPM] transaction started
[2018-05-26 12:58] [ALPM] removed pidgin (2.13.0-1.1)
[2018-05-26 12:58] [ALPM] transaction completed
[2018-05-26 12:58] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-05-26 12:58] [ALPM] running 'systemd-update.hook'...
[2018-05-26 12:58] [ALPM] running 'update-desktop-database.hook'...
[2018-05-26 12:58] [PACMAN] Running 'pacman -R guayadeque'
[2018-05-26 12:58] [PACMAN] Running 'pacman -R hexchat'
[2018-05-26 12:58] [ALPM] transaction started
[2018-05-26 12:58] [ALPM] removed hexchat (2.14.1-1.0)
[2018-05-26 12:58] [ALPM] transaction completed
[2018-05-26 12:58] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-05-26 12:58] [ALPM] running 'systemd-update.hook'...
[2018-05-26 12:58] [ALPM] running 'update-desktop-database.hook'...
[2018-05-26 12:58] [PACMAN] Running 'pacman -R thunderbird'
[2018-05-26 12:58] [ALPM] transaction started
[2018-05-26 12:58] [ALPM] removed thunderbird (52.6.0-2.0)
[2018-05-26 12:58] [ALPM] transaction completed
[2018-05-26 12:58] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-05-26 12:58] [ALPM] running 'systemd-update.hook'...
[2018-05-26 12:58] [ALPM] running 'update-desktop-database.hook'...
[2018-05-26 12:58] [PACMAN] Running 'pacman -Rs gtkspell libpurple zenity'
[2018-05-26 12:58] [ALPM] transaction started
[2018-05-26 12:58] [ALPM] removed zenity (3.26.0-1)
[2018-05-26 12:58] [ALPM] removed libpurple (2.13.0-1.1)
[2018-05-26 12:58] [ALPM] removed libgadu (1.12.2-5.0)
[2018-05-26 12:58] [ALPM] removed protobuf-c (1.3.0-2.0)
[2018-05-26 12:58] [ALPM] removed protobuf (3.5.1.1-1.0)
[2018-05-26 12:58] [ALPM] removed farstream (0.2.8-1)
[2018-05-26 12:58] [ALPM] removed libnice (0.1.14-1.1)
[2018-05-26 12:58] [ALPM] removed gtkspell (2.0.16-7.0)
[2018-05-26 12:58] [ALPM] transaction completed
[2018-05-26 12:58] [ALPM] running 'systemd-update.hook'...
[2018-05-26 12:59] [PAMAC] synchronizing package lists
[2018-05-26 14:25] [PACMAN] Running 'pacman -Syyuw'
[2018-05-26 14:25] [PACMAN] synchronizing package lists
[2018-05-26 14:25] [PACMAN] starting full system upgrade
[2018-05-26 14:49] [PACMAN] Running 'pacman -Syyu'
[2018-05-26 14:49] [PACMAN] synchronizing package lists
[2018-05-26 14:49] [ALPM] transaction started
[2018-05-26 14:49] [ALPM] upgraded archlinux-keyring (20180302-1.0 -> 20180404-1.0)
[2018-05-26 14:49] [ALPM-SCRIPTLET] ==> Appending keys from archlinux.gpg...
[2018-05-26 14:49] [ALPM-SCRIPTLET] ==> Locally signing trusted keys in keyring...
[2018-05-26 14:49] [ALPM-SCRIPTLET]   -> Locally signing key DDB867B92AA789C165EEFA799B729B06A680C281...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
[2018-05-26 14:50] [ALPM-SCRIPTLET] ==> Importing owner trust values...
[2018-05-26 14:50] [ALPM-SCRIPTLET] ==> Disabling revoked keys in keyring...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 40440DC037C05620984379A6761FAD69BA06C6A9...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key B1F2C889CB2CCB2ADA36D963097D629E437520BD...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 4FCF887689C41B09506BE8D5F3E1D5C5D30DB0AD...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 5E7585ADFF106BFFBBA319DC654B877A0864983E...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 8CF934E339CAD8ABF342E822E711306E3C4F88BC...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 5696C003B0854206450C8E5BE613C09CB4440678...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 34C5D94FE7E7913E86DC427E7FB1A3800C84C0A5...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 39F880E50E49A4D11341E8F939E4F17F295AFBF4...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key DBE7D3DD8C81D58D0A13D0E76BC26A17B9B7018A...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 07DFD3A0BC213FA12EDC217559B3122E2FA915EC...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 44D4A033AC140143927397D47EFD567D4C7EA887...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 8840BD07FC24CB7CE394A07CCF7037A4F27FB7DA...
[2018-05-26 14:50] [ALPM-SCRIPTLET] ==> Updating trust database...
[2018-05-26 14:50] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2018-06-01
[2018-05-26 14:50] [ALPM] upgraded manjaro-keyring (20171027-1 -> 20171027-2)
[2018-05-26 14:50] [ALPM-SCRIPTLET] ==> Appending keys from manjaro.gpg...
[2018-05-26 14:50] [ALPM-SCRIPTLET] ==> Locally signing trusted keys in keyring...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 75C1B95A4D9514A57EB2DAE71817DC63CD3B5DF5...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 16DC688DF3EECC72323954237EC47C82A42D53A2...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 76C6E477042BFE985CC220BD9C08A255442FAFF0...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 2D14560CDCE6A75BB186DB758238651DDF5E0594...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key B4663188A692DB1E45A98EE95BD96CC4247B52CC...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 04BB537F5BC2D399BFA72F8F17C752B61B2F2E90...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 35B4FF23EA9477582C2A0AF12B80869C5C0102A6...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 77DC01C9971AC3C39A0626F72C089F09AC97B894...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 39F0EC1AE50B37E5F3196F09DAD3B211663CA268...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 7C89F4D439B2BFACF425107B62443D89B35859F8...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 22C903DE964E6FE321656E318DB9F8C18DF53602...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 5A97ED6B72418199F0C22B23137C934B5DCB998E...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 1E7908935AAB9A00D6B47503363DFFFD59152F77...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Locally signing key 74C2F2CC05A0AB7D859839938934292D604F8BA2...
[2018-05-26 14:50] [ALPM-SCRIPTLET] ==> Importing owner trust values...
[2018-05-26 14:50] [ALPM-SCRIPTLET] ==> Disabling revoked keys in keyring...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key FAA6840E8C3FC7F89BEE0DC8AC7AB10BCB6CDD17...
[2018-05-26 14:50] [ALPM-SCRIPTLET]   -> Disabling key 540DE7083B89314CF70EA6F0C1B1AD0DA80EBF3E...
[2018-05-26 14:50] [ALPM-SCRIPTLET] ==> Updating trust database...
[2018-05-26 14:50] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2018-06-01
[2018-05-26 14:50] [ALPM] upgraded manjaro-system (20180320-1 -> 20180516-1)
[2018-05-26 14:50] [ALPM] transaction completed
[2018-05-26 14:50] [ALPM] running 'systemd-update.hook'...
[2018-05-26 14:50] [PACMAN] starting full system upgrade
[2018-05-26 14:52] [PACMAN] Running 'pacman -Syyu'
[2018-05-26 14:52] [PACMAN] synchronizing package lists
[2018-05-26 14:52] [PACMAN] Running 'pacman -Syyu'
[2018-05-26 14:52] [PACMAN] synchronizing package lists
[2018-05-26 14:52] [PACMAN] starting full system upgrade
[2018-05-26 14:54] [ALPM] transaction started
[2018-05-26 14:54] [ALPM] removed gnome-themes-standard (3.22.3+16+gc092fc89-1.0)
[2018-05-26 14:54] [ALPM] removed xineramaproto (1.2.1-3)
[2018-05-26 14:54] [ALPM] removed xf86vidmodeproto (2.3.1-3)
[2018-05-26 14:54] [ALPM] removed xf86miscproto (0.9.3-1)
[2018-05-26 14:54] [ALPM] removed videoproto (2.3.3-1)
[2018-05-26 14:54] [ALPM] removed scrnsaverproto (1.2.2-2)
[2018-05-26 14:54] [ALPM] removed renderproto (0.11.1-3)
[2018-05-26 14:54] [ALPM] removed recordproto (1.14.2-2)
[2018-05-26 14:54] [ALPM] removed randrproto (1.5.0-1)
[2018-05-26 14:54] [ALPM] removed kbproto (1.0.7-1)
[2018-05-26 14:54] [ALPM] removed inputproto (2.3.2-1)
[2018-05-26 14:54] [ALPM] removed fontsproto (2.1.3-2)
[2018-05-26 14:54] [ALPM] removed damageproto (1.2.1-3)
[2018-05-26 14:54] [ALPM] removed compositeproto (0.4.2-3)
[2018-05-26 14:54] [ALPM] removed fixesproto (5.0+9+g4292ec1-1)
[2018-05-26 14:54] [ALPM] removed xproto (7.0.31-1)
[2018-05-26 14:54] [ALPM] removed xextproto (7.3.0-1)
[2018-05-26 14:54] [ALPM] upgraded linux-api-headers (4.14.8-1.0 -> 4.16.1-1.0)
[2018-05-26 14:54] [ALPM] upgraded tzdata (2018c-1.0 -> 2018e-1.0)
[2018-05-26 14:54] [ALPM] warning: /etc/fstab installed as /etc/fstab.pacnew
[2018-05-26 14:54] [ALPM] warning: /etc/group installed as /etc/group.pacnew
[2018-05-26 14:54] [ALPM] warning: /etc/hosts installed as /etc/hosts.pacnew
[2018-05-26 14:54] [ALPM] warning: /etc/passwd installed as /etc/passwd.pacnew
[2018-05-26 14:54] [ALPM] warning: /etc/resolv.conf installed as /etc/resolv.conf.pacnew
[2018-05-26 14:54] [ALPM] warning: /etc/shells installed as /etc/shells.pacnew
[2018-05-26 14:54] [ALPM] warning: /etc/gshadow installed as /etc/gshadow.pacnew
[2018-05-26 14:54] [ALPM] warning: /etc/shadow installed as /etc/shadow.pacnew
[2018-05-26 14:54] [ALPM] warning: /etc/crypttab installed as /etc/crypttab.pacnew
[2018-05-26 14:54] [ALPM] upgraded filesystem (2017.06-4.5 -> 2018.1-3)
[2018-05-26 14:54] [ALPM] warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
[2018-05-26 14:54] [ALPM] upgraded glibc (2.26-11.0 -> 2.27-3.1)
[2018-05-26 14:54] [ALPM-SCRIPTLET] Generating locales...
[2018-05-26 14:54] [ALPM-SCRIPTLET]   en_CA.UTF-8... done
[2018-05-26 14:54] [ALPM-SCRIPTLET]   en_US.UTF-8... done
[2018-05-26 14:54] [ALPM-SCRIPTLET] Generation complete.
[2018-05-26 14:54] [ALPM] upgraded gcc-libs (7.3.1+20180312-1.0 -> 8.1.0-1.1)
[2018-05-26 14:54] [ALPM] upgraded pcre (8.41-1 -> 8.42-1.0)
[2018-05-26 14:54] [ALPM] upgraded libutil-linux (2.31.1-1.0 -> 2.32-3.0)
[2018-05-26 14:54] [ALPM] upgraded glib2 (2.54.3+2+g94b38beff-1.0 -> 2.56.1-1.0)
[2018-05-26 14:54] [ALPM] upgraded e2fsprogs (1.44.0-1.0 -> 1.44.2-1.0)
[2018-05-26 14:54] [ALPM] upgraded perl (5.26.1-2.0 -> 5.26.2-1.0)
[2018-05-26 14:54] [ALPM] upgraded openssl (1.1.0.g-1 -> 1.1.0.h-1.0)
[2018-05-26 14:54] [ALPM] upgraded libldap (2.4.45-4 -> 2.4.46-1.0)
[2018-05-26 14:54] [ALPM] upgraded krb5 (1.16-1.0 -> 1.16.1-1.0)
[2018-05-26 14:54] [ALPM] upgraded libtirpc (1.0.3-1.0 -> 1.0.3-2.0)
[2018-05-26 14:54] [ALPM] upgraded pam (1.3.0-1 -> 1.3.0-2.0)
[2018-05-26 14:54] [ALPM] upgraded libgpg-error (1.28-1.0 -> 1.31-1.0)
[2018-05-26 14:54] [ALPM] upgraded xz (5.2.3-1 -> 5.2.4-1.0)
[2018-05-26 14:54] [ALPM] upgraded libsystemd (238.0-6 -> 238.76-1)
[2018-05-26 14:54] [ALPM] upgraded cryptsetup (2.0.2-1.0 -> 2.0.3-1.0)
[2018-05-26 14:54] [ALPM] upgraded dbus (1.12.6-1.0 -> 1.12.8-1.0)
[2018-05-26 14:54] [ALPM] upgraded libidn (1.33-2 -> 1.34-2.0)
[2018-05-26 14:54] [ALPM] upgraded util-linux (2.31.1-1.0 -> 2.32-3.0)
[2018-05-26 14:54] [ALPM] upgraded libusb (1.0.21-2 -> 1.0.22-1.0)
[2018-05-26 14:54] [ALPM] upgraded systemd (238.0-6 -> 238.76-1)
[2018-05-26 14:54] [ALPM] installed js52 (52.7.3-2.0)
[2018-05-26 14:54] [ALPM] upgraded polkit (0.113+34+g29ba7af-1.1 -> 0.114-1.1)
[2018-05-26 14:54] [ALPM] upgraded accountsservice (0.6.45-1 -> 0.6.49-1.0)
[2018-05-26 14:54] [ALPM] upgraded acpid (2.0.28-1 -> 2.0.29-2.0)
[2018-05-26 14:55] [ALPM] installed xorgproto (2018.4-1.0)
[2018-05-26 14:55] [ALPM] upgraded icu (60.2-1.0 -> 61.1-1.0)
[2018-05-26 14:55] [ALPM] upgraded libxml2 (2.9.8-1.0 -> 2.9.8-2.0)
[2018-05-26 14:55] [ALPM] upgraded gdk-pixbuf2 (2.36.11-1 -> 2.36.12-1.0)
[2018-05-26 14:55] [ALPM] upgraded harfbuzz (1.7.6-1.1 -> 1.7.6-2.0)
[2018-05-26 14:55] [ALPM] upgraded freetype2 (2.9-2.0 -> 2.9.1-1.0)
[2018-05-26 14:55] [ALPM] upgraded fontconfig (2.12.6+5+g665584a-1 -> 2.13.0+10+g58f5285-1.0)
[2018-05-26 14:55] [ALPM-SCRIPTLET] Rebuilding fontconfig cache... done.
[2018-05-26 14:55] [ALPM] upgraded cairo (1.15.10-1.0 -> 1.15.12-1.0)
[2018-05-26 14:55] [ALPM] upgraded fribidi (1.0.1+8+gdf7252b-1.0 -> 1.0.2-1.0)
[2018-05-26 14:55] [ALPM] upgraded pango (1.40.14-2.0 -> 1.42.1-1.0)
[2018-05-26 14:55] [ALPM] upgraded librsvg (2:2.42.3-1.2 -> 2:2.42.4-1.0)
[2018-05-26 14:55] [ALPM] upgraded gtk-update-icon-cache (3.22.28-1.0 -> 3.22.30-1.0)
[2018-05-26 14:55] [ALPM] upgraded adwaita-icon-theme (3.26.1-1.0 -> 3.28.0-1.0)
[2018-05-26 14:55] [ALPM] upgraded alsa-lib (1.1.5-1 -> 1.1.6-1.0)
[2018-05-26 14:55] [ALPM] upgraded alsa-plugins (1.1.5-1 -> 1.1.6-2.0)
[2018-05-26 14:55] [ALPM] upgraded alsa-utils (1.1.5-2 -> 1.1.6-1.0)
[2018-05-26 14:55] [ALPM] upgraded atk (2.26.1-1 -> 2.28.1-1.0)
[2018-05-26 14:55] [ALPM] upgraded libepoxy (1.5.0-1.0 -> 1.5.2-1.0)
[2018-05-26 14:55] [ALPM] upgraded dconf (0.26.1-1 -> 0.28.0-1.0)
[2018-05-26 14:55] [ALPM] upgraded at-spi2-core (2.26.2-1 -> 2.28.0-1.0)
[2018-05-26 14:55] [ALPM] upgraded at-spi2-atk (2.26.1-1 -> 2.26.2-1.0)
[2018-05-26 14:55] [ALPM] upgraded wayland (1.14.0-1 -> 1.15.0-1.1)
[2018-05-26 14:55] [ALPM] upgraded wayland-protocols (1.13-1.0 -> 1.14-1.0)
[2018-05-26 14:55] [ALPM] upgraded desktop-file-utils (0.23-1 -> 0.23+4+g92af410-1.0)
[2018-05-26 14:55] [ALPM] upgraded libdrm (2.4.91-2.0 -> 2.4.92-1.0)
[2018-05-26 14:55] [ALPM] upgraded llvm-libs (5.0.1-2.0 -> 6.0.0-4.1)
[2018-05-26 14:55] [ALPM] upgraded lm_sensors (3.4.0-2 -> 3.4.0-4.0)
[2018-05-26 14:55] [ALPM] upgraded mesa (17.3.6-1.0 -> 18.0.4-1.0)
[2018-05-26 14:55] [ALPM] upgraded sqlite (3.22.0-1.0 -> 3.23.1-1.0)
[2018-05-26 14:55] [ALPM] upgraded colord (1.4.2-1.0 -> 1.4.3-1.0)
[2018-05-26 14:55] [ALPM] upgraded avahi (0.7-4.0 -> 0.7+4+gd8d8c67-1.0)
[2018-05-26 14:55] [ALPM] upgraded libcups (2.2.6-4.0 -> 2.2.7-2.0)
[2018-05-26 14:55] [ALPM] upgraded libtool (2.4.6+40+g6ca5e224-5.0 -> 2.4.6+40+g6ca5e224-6.0)
[2018-05-26 14:55] [ALPM] upgraded xkeyboard-config (2.23.1-2.0 -> 2.23.1-3.0)
[2018-05-26 14:55] [ALPM] upgraded gsettings-desktop-schemas (3.24.1+3+ge869987-1 -> 3.28.0+1+g85521dc-1.0)
[2018-05-26 14:55] [ALPM] upgraded ca-certificates-mozilla (3.36-1.0 -> 3.37.1-1.0)
[2018-05-26 14:55] [ALPM] upgraded glib-networking (2.54.1-1 -> 2.56.1-1.0)
[2018-05-26 14:55] [ALPM] upgraded libsoup (2.60.3-1.1 -> 2.62.2-1.0)
[2018-05-26 14:55] [ALPM] upgraded gtk3 (3.22.28-1.0 -> 3.22.30-1.0)
[2018-05-26 14:55] [ALPM] upgraded libidn2 (2.0.4-2 -> 2.0.5-1.0)
[2018-05-26 14:55] [ALPM] upgraded libpsl (0.20.1-1.0 -> 0.20.2-1.0)
[2018-05-26 14:55] [ALPM] upgraded libnghttp2 (1.30.0-1.0 -> 1.31.1-1.0)
[2018-05-26 14:55] [ALPM] upgraded curl (7.59.0-2.0 -> 7.60.0-1.0)
[2018-05-26 14:55] [ALPM] upgraded libsecret (0.18.5+14+g9980655-1 -> 0.18.6-1.0)
[2018-05-26 14:55] [ALPM] upgraded pinentry (1.1.0-1.0 -> 1.1.0-3.0)
[2018-05-26 14:55] [ALPM] upgraded gnupg (2.2.5-1.0 -> 2.2.7-1.0)
[2018-05-26 14:55] [ALPM] upgraded gpgme (1.10.0-2.0 -> 1.11.1-1.0)
[2018-05-26 14:55] [ALPM] installed libnsl (1.2.0-1.0)
[2018-05-26 14:55] [ALPM] upgraded python (3.6.4-2.0 -> 3.6.5-3.0)
[2018-05-26 14:55] [ALPM] upgraded pacman-mirrors (4.7.6-2 -> 4.10.1-3)
[2018-05-26 14:55] [ALPM] upgraded appstream-glib (0.7.4-1 -> 0.7.7-1.0)
[2018-05-26 14:55] [ALPM] upgraded archlinux-appstream-data (20180318-1.0 -> 20180424-1.0)
[2018-05-26 14:55] [ALPM] upgraded archlinux32-keyring (20180104-1 -> 20180411-1.1)
[2018-05-26 14:55] [ALPM-SCRIPTLET] ==> Appending keys from archlinux32.gpg...
[2018-05-26 14:55] [ALPM-SCRIPTLET] gpg: WARNING: server 'gpg-agent' is older than us (2.2.5 < 2.2.7)
[2018-05-26 14:55] [ALPM-SCRIPTLET] ==> Locally signing trusted keys in keyring...
[2018-05-26 14:55] [ALPM-SCRIPTLET]   -> Locally signing key CE0BDE71A759A87F23F0F7D8B61DBCE10901C163...
[2018-05-26 14:55] [ALPM-SCRIPTLET]   -> Locally signing key 2FF1E976D6EB2E954A87DC14443904EC9EC51A8A...
[2018-05-26 14:55] [ALPM-SCRIPTLET]   -> Locally signing key D92CDDC155BCC8F550B5FCEC30AB721FE7400FCD...
[2018-05-26 14:55] [ALPM-SCRIPTLET]   -> Locally signing key A0B250C0FC9FC079EC04ADB7A50C0F20AEC3AF00...
[2018-05-26 14:55] [ALPM-SCRIPTLET]   -> Locally signing key 194E37A47A4C671807BACB37B1117BC1094EA6E9...
[2018-05-26 14:55] [ALPM-SCRIPTLET] ==> Importing owner trust values...
[2018-05-26 14:55] [ALPM-SCRIPTLET] ==> Disabling revoked keys in keyring...
[2018-05-26 14:55] [ALPM-SCRIPTLET]   -> Disabling key C3A8190912128B5A2E96C6023ED6490AEF932C8A...
[2018-05-26 14:55] [ALPM-SCRIPTLET]   -> Disabling key 7C98C4C3DE926168DC46FBAA3D06644243BF68D3...
[2018-05-26 14:55] [ALPM-SCRIPTLET] ==> Updating trust database...
[2018-05-26 14:55] [ALPM-SCRIPTLET] gpg: marginals needed: 3  completes needed: 1  trust model: pgp
[2018-05-26 14:55] [ALPM-SCRIPTLET] gpg: depth: 0  valid:   1  signed:  25  trust: 0-, 0q, 0n, 0m, 0f, 1u
[2018-05-26 14:55] [ALPM-SCRIPTLET] gpg: depth: 1  valid:  25  signed:  83  trust: 0-, 0q, 0n, 25m, 0f, 0u
[2018-05-26 14:55] [ALPM-SCRIPTLET] gpg: depth: 2  valid:  78  signed:  12  trust: 78-, 0q, 0n, 0m, 0f, 0u
[2018-05-26 14:55] [ALPM-SCRIPTLET] gpg: next trustdb check due at 2018-06-01
[2018-05-26 14:55] [ALPM] upgraded audacious-plugins (3.9-2.0 -> 3.9-3.0)
[2018-05-26 14:55] [ALPM] upgraded babl (0.1.38-1.0 -> 0.1.50-1.0)
[2018-05-26 14:55] [ALPM] upgraded binutils (2.29.1-3.0 -> 2.30-4.1)
[2018-05-26 14:55] [ALPM] upgraded libical (3.0.3-1.0 -> 3.0.3-2.0)
[2018-05-26 14:55] [ALPM] upgraded bluez (5.49-1.0 -> 5.49-4.0)
[2018-05-26 14:55] [ALPM] upgraded bluez-libs (5.49-1.0 -> 5.49-4.0)
[2018-05-26 14:55] [ALPM] upgraded python-cairo (1.16.3-1.0 -> 1.17.0-1.0)
[2018-05-26 14:55] [ALPM] upgraded gobject-introspection-runtime (1.54.1-1 -> 1.56.1-1.0)
[2018-05-26 14:55] [ALPM] upgraded pygobject-devel (3.26.1-1 -> 3.28.2-1.0)
[2018-05-26 14:55] [ALPM] upgraded python-gobject (3.26.1-1 -> 3.28.2-1.0)
[2018-05-26 14:55] [ALPM] upgraded blueman (2.0.5-1 -> 2.0.5-2.0)
[2018-05-26 14:55] [ALPM] upgraded boost-libs (1.66.0-1.0 -> 1.66.0-2.0)
[2018-05-26 14:55] [ALPM] upgraded breath-wallpaper (0.3.0-2 -> 0.3.1-1)
[2018-05-26 14:55] [ALPM] upgraded zstd (1.3.3-1.0 -> 1.3.4-1.0)
[2018-05-26 14:55] [ALPM] upgraded btrfs-progs (4.15.1-1.0 -> 4.16-2.0)
[2018-05-26 14:55] [ALPM] upgraded gsm (1.0.17-1 -> 1.0.18-1.0)
[2018-05-26 14:55] [ALPM] upgraded libwebp (0.6.1-1.0 -> 1.0.0-1.0)
[2018-05-26 14:56] [ALPM] installed libibus (1.5.18-1.0)
[2018-05-26 14:56] [ALPM] upgraded sdl2 (2.0.8-1.0 -> 2.0.8-8.0)
[2018-05-26 14:56] [ALPM] upgraded libx264 (2:152.20171224-1.0 -> 2:152.20171224-2.1)
[2018-05-26 14:56] [ALPM] upgraded ffmpeg (1:3.4.2-2.0 -> 1:4.0-2.2)
[2018-05-26 14:56] [ALPM] upgraded chromaprint (1.4.3-1.0 -> 1.4.3-2.0)
[2018-05-26 14:56] [ALPM] upgraded cpupower (4.15-1.0 -> 4.16-1.0)
[2018-05-26 14:56] [ALPM] upgraded crda (3.18-1 -> 4.14-1.1)
[2018-05-26 14:56] [ALPM] upgraded nss (3.36-1.0 -> 3.37.1-1.0)
[2018-05-26 14:56] [ALPM] upgraded poppler (0.61.1-1 -> 0.64.0-1.0)
[2018-05-26 14:56] [ALPM] upgraded libmagick (7.0.7.26-1.0 -> 7.0.7.35-1.0)
[2018-05-26 14:56] [ALPM] upgraded imagemagick (7.0.7.26-1.0 -> 7.0.7.35-1.0)
[2018-05-26 14:56] [ALPM] upgraded liblouis (3.4.0-1.0 -> 3.5.0-1.0)
[2018-05-26 14:56] [ALPM] upgraded cups-filters (1.20.1-2.0 -> 1.20.3-2.0)
[2018-05-26 14:56] [ALPM] upgraded cups (2.2.6-4.0 -> 2.2.7-2.0)
[2018-05-26 14:56] [ALPM] upgraded dhcpcd (7.0.1-1.0 -> 7.0.4-1.0)
[2018-05-26 14:56] [ALPM] upgraded ffmpeg2.8 (2.8.13-7.0 -> 2.8.14-1.0)
[2018-05-26 14:56] [ALPM] upgraded ffmpegthumbnailer (2.2.0-1 -> 2.2.0-2.0)
[2018-05-26 14:56] [ALPM] upgraded file (5.32-1 -> 5.33-3.0)
[2018-05-26 14:56] [ALPM] upgraded foomatic-db-engine (4:4.0.12-7 -> 4:4.0.13-1.0)
[2018-05-26 14:56] [ALPM] upgraded fuse-common (3.2.1-1.0 -> 3.2.3-1.0)
[2018-05-26 14:56] [ALPM] upgraded gcc (7.3.1+20180312-1.0 -> 8.1.0-1.1)
[2018-05-26 14:56] [ALPM] upgraded gconf (3.2.6-5 -> 3.2.6+11+g07808097-3.0)
[2018-05-26 14:56] [ALPM] upgraded gcr (3.20.0+55+g470bf4c-1 -> 3.28.0-3.0)
[2018-05-26 14:56] [ALPM] upgraded ghostscript (9.22-7.0 -> 9.23-1.0)
[2018-05-26 14:56] [ALPM] installed libgexiv2 (0.10.8-1.0)
[2018-05-26 14:56] [ALPM] installed gegl (0.4.2-1.0)
[2018-05-26 14:56] [ALPM] installed libmypaint (1.3.0-5.0)
[2018-05-26 14:56] [ALPM] installed mypaint-brushes (1.3.0-2.0)
[2018-05-26 14:56] [ALPM] upgraded poppler-data (0.4.8-1.1 -> 0.4.9-1.0)
[2018-05-26 14:56] [ALPM] upgraded ilmbase (2.2.1-1.0 -> 2.2.1-2.0)
[2018-05-26 14:56] [ALPM] upgraded python2 (2.7.14-2.0 -> 2.7.15-1.0)
[2018-05-26 14:56] [ALPM] upgraded python2-cairo (1.16.3-1.0 -> 1.17.0-1.0)
[2018-05-26 14:56] [ALPM] upgraded gimp (2.8.22-1 -> 2.10.2-1.0)
[2018-05-26 14:56] [ALPM] upgraded perl-error (0.17025-2 -> 0.17026-1.0)
[2018-05-26 14:56] [ALPM] installed perl-timedate (2.30-4)
[2018-05-26 14:56] [ALPM] installed perl-mailtools (2.20-1.0)
[2018-05-26 14:56] [ALPM] upgraded git (2.16.2-2.0 -> 2.17.0-1.0)
[2018-05-26 14:56] [ALPM] upgraded glibmm (2.54.1-1 -> 2.56.0-1.0)
[2018-05-26 14:56] [ALPM] upgraded openssh (7.6p1-2.0 -> 7.7p1-1.0)
[2018-05-26 14:56] [ALPM] upgraded gnome-keyring (1:3.27.4+8+gff229abc-1.0 -> 1:3.28.2-1.0)
[2018-05-26 14:56] [ALPM] upgraded gnome-menus (3.13.3+29+g7f0844e-1 -> 3.13.3+30+g510ef1c-1.0)
[2018-05-26 14:56] [ALPM] installed gnome-themes-extra (3.28-1.0)
[2018-05-26 14:56] [ALPM] upgraded gstreamer (1.12.4-1.0 -> 1.14.1-1.0)
[2018-05-26 14:56] [ALPM] upgraded gst-plugins-base-libs (1.12.4-1.0 -> 1.14.1-1.0)
[2018-05-26 14:56] [ALPM] upgraded gst-libav (1.12.4-1.0 -> 1.14.1-1.0)
[2018-05-26 14:56] [ALPM] upgraded libgme (0.6.1-1 -> 0.6.2-1.0)
[2018-05-26 14:56] [ALPM] upgraded libsrtp (1:2.1.0-1.0 -> 1:2.2.0-1.0)
[2018-05-26 14:56] [ALPM] upgraded openal (1.18.2-1 -> 1.18.2-2.0)
[2018-05-26 14:56] [ALPM] upgraded vulkan-icd-loader (1.1.70.0-3.0 -> 1.1.73.0-1.0)
[2018-05-26 14:56] [ALPM] upgraded neon (0.30.2-2 -> 0.30.2-3.0)
[2018-05-26 14:56] [ALPM] installed libnice (0.1.14+70+gfb2f1f7-1.0)
[2018-05-26 14:56] [ALPM] installed srt (1.3.0-2.0)
[2018-05-26 14:56] [ALPM] upgraded gst-plugins-bad (1.12.4-5.0 -> 1.14.1-1.0)
[2018-05-26 14:56] [ALPM] upgraded gst-plugins-base (1.12.4-1.0 -> 1.14.1-1.0)
[2018-05-26 14:56] [ALPM] upgraded mpg123 (1.25.8-1.0 -> 1.25.10-1.0)
[2018-05-26 14:56] [ALPM] installed twolame (0.3.13-8.0)
[2018-05-26 14:56] [ALPM] upgraded procps-ng (3.3.12-2.1 -> 3.3.14-1.2)
[2018-05-26 14:56] [ALPM] upgraded imlib2 (1.4.10-1 -> 1.5.1-1.0)
[2018-05-26 14:56] [ALPM] upgraded gst-plugins-good (1.12.4-2.0 -> 1.14.0-1.0)
[2018-05-26 14:56] [ALPM] upgraded libx264-all (2:152.20171224-1.0 -> 2:152.20171224-2.1)
[2018-05-26 14:56] [ALPM] upgraded gst-plugins-ugly (1.12.4-3.0 -> 1.14.1-1.0)
[2018-05-26 14:56] [ALPM] upgraded gtksourceview3 (3.24.6-1.0 -> 3.24.7-1.0)
[2018-05-26 14:56] [ALPM] upgraded libbytesize (1.1-1.0 -> 1.3-1.0)
[2018-05-26 14:56] [ALPM] installed ndctl (60.3-1.0)
[2018-05-26 14:57] [ALPM] upgraded libaio (0.3.110-1 -> 0.3.111-1.0)
[2018-05-26 14:57] [ALPM] upgraded thin-provisioning-tools (0.7.5-1 -> 0.7.6-1.0)
[2018-05-26 14:57] [ALPM] upgraded libblockdev (2.16-1.0 -> 2.17-3.0)
[2018-05-26 14:57] [ALPM] upgraded gvfs (1.34.2.1-1.0 -> 1.36.2-1.0)
[2018-05-26 14:57] [ALPM] upgraded gvfs-afc (1.34.2.1-1.0 -> 1.36.2-1.0)
[2018-05-26 14:57] [ALPM] upgraded libgphoto2 (2.5.16-1.0 -> 2.5.18-1.0)
[2018-05-26 14:57] [ALPM] upgraded gvfs-gphoto2 (1.34.2.1-1.0 -> 1.36.2-1.0)
[2018-05-26 14:57] [ALPM] upgraded libmtp (1.1.14-1 -> 1.1.15-1.0)
[2018-05-26 14:57] [ALPM] upgraded gvfs-mtp (1.34.2.1-1.0 -> 1.36.2-1.0)
[2018-05-26 14:57] [ALPM] upgraded gvfs-nfs (1.34.2.1-1.0 -> 1.36.2-1.0)
[2018-05-26 14:57] [ALPM] upgraded libwbclient (4.7.6-1.0 -> 4.8.1-1.1)
[2018-05-26 14:57] [ALPM] upgraded talloc (2.1.11-1.0 -> 2.1.13-1.0)
[2018-05-26 14:57] [ALPM] upgraded ldb (1.3.1-1.0 -> 1.3.2-1.0)
[2018-05-26 14:57] [ALPM] upgraded smbclient (4.7.6-1.0 -> 4.8.1-1.1)
[2018-05-26 14:57] [ALPM] upgraded gvfs-smb (1.34.2.1-1.0 -> 1.36.2-1.0)
[2018-05-26 14:57] [ALPM] upgraded harfbuzz-icu (1.7.6-1.1 -> 1.7.6-2.0)
[2018-05-26 14:57] [ALPM] upgraded hdparm (9.54-1.0 -> 9.56-1.0)
[2018-05-26 14:57] [ALPM] upgraded net-snmp (5.7.3-7 -> 5.7.3-8.0)
[2018-05-26 14:57] [ALPM] upgraded hplip (3.18.3-1.0 -> 3.18.4-2.0)
[2018-05-26 14:57] [ALPM] upgraded htop (2.1.0-2.0 -> 2.2.0-2.0)
[2018-05-26 14:57] [ALPM] upgraded intel-ucode (20180312-1.0 -> 20180425-1.0)
[2018-05-26 14:57] [ALPM] upgraded sed (4.4-1 -> 4.5-1.0)
[2018-05-26 14:57] [ALPM] upgraded inxi (2.3.56-1.0 -> 3.0.08-1)
[2018-05-26 14:57] [ALPM] upgraded iproute2 (4.15.0-1.0 -> 4.16.0-1.0)
[2018-05-26 14:57] [ALPM] upgraded xdg-utils (1.1.2-2.0 -> 1.1.3-1.0)
[2018-05-26 14:57] [ALPM] upgraded tslib (1.15-1.0 -> 1.16-1.0)
[2018-05-26 14:57] [ALPM] upgraded libwacom (0.28-2.0 -> 0.29-1.0)
[2018-05-26 14:57] [ALPM] upgraded libinput (1.10.3-1.0 -> 1.10.7-1.0)
[2018-05-26 14:57] [ALPM] upgraded qt5-base (5.10.1-5.0 -> 5.10.1-8.0)
[2018-05-26 14:57] [ALPM] upgraded kcoreaddons (5.44.0-1.0 -> 5.46.0-1.0)
[2018-05-26 14:57] [ALPM] upgraded kauth (5.44.0-1.0 -> 5.46.0-1.0)
[2018-05-26 14:57] [ALPM] upgraded kitemmodels (5.44.0-1.0 -> 5.46.0-1.0)
[2018-05-26 14:57] [ALPM] upgraded libatomic_ops (7.6.2-1.0 -> 7.6.4-1.0)
[2018-05-26 14:57] [ALPM] upgraded libcdr (0.1.4-2 -> 0.1.4-3.0)
[2018-05-26 14:57] [ALPM] upgraded libdvbpsi (1:1.3.1-1 -> 1:1.3.2-1.0)
[2018-05-26 14:57] [ALPM] upgraded libdvdcss (1.4.1-1.0 -> 1.4.2-1.0)
[2018-05-26 14:57] [ALPM] upgraded libe-book (0.1.3-1.0 -> 0.1.3-2.0)
[2018-05-26 14:57] [ALPM] upgraded libebml (1.3.5-1 -> 1.3.6-1.0)
[2018-05-26 14:57] [ALPM] upgraded libetonyek (0.1.7-1 -> 0.1.8-1.0)
[2018-05-26 14:57] [ALPM] upgraded libgsf (1.14.42-1 -> 1.14.43-1.0)
[2018-05-26 14:57] [ALPM] upgraded libgtop (2.38.0+1+g487e584a-2 -> 2.38.0+13+gcab8791f-1.0)
[2018-05-26 14:57] [ALPM] upgraded libmatroska (1.4.8-1 -> 1.4.9-1.0)
[2018-05-26 14:57] [ALPM] upgraded libmm-glib (1.8rc1+6+g0f377f94-1.0 -> 1.8rc2+1+g7e949283-1.0)
[2018-05-26 14:57] [ALPM] upgraded libmspub (0.1.4-1.0 -> 0.1.4-2.0)
[2018-05-26 14:57] [ALPM] upgraded libmwaw (0.3.13-1 -> 0.3.14-1.0)
[2018-05-26 14:57] [ALPM] upgraded libnetfilter_conntrack (1.0.6-1 -> 1.0.7-1.0)
[2018-05-26 14:57] [ALPM] upgraded libnm (1.10.6-2.01 -> 1.10.8-1.0)
[2018-05-26 14:57] [ALPM] upgraded libnm-glib (1.10.6-2.01 -> 1.10.8-1.0)
[2018-05-26 14:57] [ALPM] upgraded libwps (0.4.8-1.0 -> 0.4.9-1.0)
[2018-05-26 14:57] [ALPM] upgraded libvisio (0.1.6-2 -> 0.1.6-3.0)
[2018-05-26 14:57] [ALPM] upgraded libzmf (0.0.2-2 -> 0.0.2-3.0)
[2018-05-26 14:57] [ALPM] upgraded raptor (2.0.15-7 -> 2.0.15-8.0)
[2018-05-26 14:57] [ALPM] upgraded libreoffice-still (5.4.5-1.0 -> 5.4.6-2.0)
[2018-05-26 14:57] [ALPM] upgraded libsynctex (2017.44590-11.0 -> 2017.44590-14.0)
[2018-05-26 14:57] [ALPM] upgraded libva-mesa-driver (17.3.6-1.0 -> 18.0.4-1.0)
[2018-05-26 14:57] [ALPM] upgraded lightdm (1:1.24.1-3.0 -> 1:1.26.0-1.0)
[2018-05-26 14:57] [ALPM] warning: /etc/lightdm/lightdm-gtk-greeter.conf installed as /etc/lightdm/lightdm-gtk-greeter.conf.pacnew
[2018-05-26 14:57] [ALPM] upgraded lightdm-gtk-greeter (1:2.0.4-1.0 -> 1:2.0.5-1.0)
[2018-05-26 14:58] [ALPM] upgraded linux-firmware (20180119.2a713be-2 -> 20180525.7518922-1)
[2018-05-26 14:58] [ALPM] upgraded mkinitcpio-busybox (1.28.1-1.0 -> 1.28.3-1.0)
[2018-05-26 14:58] [ALPM] upgraded linux414 (4.14.29-1 -> 4.14.44-1)
[2018-05-26 14:58] [ALPM] upgraded logrotate (3.13.0-1.0 -> 3.14.0-1.0)
[2018-05-26 14:58] [ALPM] upgraded man-db (2.8.2-1.0 -> 2.8.3-1.0)
[2018-05-26 14:58] [ALPM] upgraded man-pages (4.15-1.0 -> 4.16-1.0)
[2018-05-26 14:58] [ALPM] upgraded manjaro-browser-settings (20180317-1 -> 20180523-1)
[2018-05-26 14:58] [ALPM] upgraded manjaro-hello (0.5.11-1 -> 0.5.11-2)
[2018-05-26 14:58] [ALPM] upgraded manjaro-release (17.1.6-1 -> 18.0alpha1-1)
[2018-05-26 14:58] [ALPM] upgraded manjaro-settings-manager (0.5.4-9 -> 0.5.4-13)
[2018-05-26 14:58] [ALPM] upgraded manjaro-settings-manager-notifier (0.5.4-9 -> 0.5.4-13)
[2018-05-26 14:58] [ALPM] upgraded qt5ct (0.35-1.0 -> 0.35-2.0)
[2018-05-26 14:58] [ALPM] upgraded qt5-styleplugins (5.0.0.20170311-5.0 -> 5.0.0.20170311-6.0)
[2018-05-26 14:58] [ALPM] upgraded vertex-maia-themes (20171126-1 -> 20180429-1)
[2018-05-26 14:58] [ALPM-SCRIPTLET] 
[2018-05-26 14:58] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m vertex-maia-themes:
[2018-05-26 14:58] [ALPM-SCRIPTLET]   -> For seamless integration of Firefox and Palemoon browsers
[2018-05-26 14:58] [ALPM-SCRIPTLET]   -> please copy the 'chrome' folder of the desired theme to your browser profile
[2018-05-26 14:58] [ALPM-SCRIPTLET]   -> or create a symlink.e[1;0m
[2018-05-26 14:58] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m For example:
[2018-05-26 14:58] [ALPM-SCRIPTLET]   -> 'ln -s /usr/share/themes/Palemoon/Vertex-Maia-Dark/chrome/ ~/.moonchild\ productions/pale\ moon/<xyz123>.default/chrome'
[2018-05-26 14:58] [ALPM-SCRIPTLET]   e[1;0m
[2018-05-26 14:58] [ALPM] upgraded manjaro-xfce-settings (20180208-1 -> 20180505-1)
[2018-05-26 14:58] [ALPM] upgraded mesa-vdpau (17.3.6-1.0 -> 18.0.4-1.0)
[2018-05-26 14:58] [ALPM] installed mhwd-nvidia-390xx (390.59-1)
[2018-05-26 14:58] [ALPM] upgraded mhwd-db (0.6.2-5 -> 0.6.3-1)
[2018-05-26 14:58] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Updating Config: '/var/lib/mhwd/local/pci/video-linux'e[1;0m
[2018-05-26 14:58] [ALPM] upgraded mhwd (0.6.2-5 -> 0.6.3-1)
[2018-05-26 14:58] [ALPM] upgraded modemmanager (1.8rc1+6+g0f377f94-1.0 -> 1.8rc2+1+g7e949283-1.0)
[2018-05-26 14:58] [ALPM] installed brotli (1.0.4-1.0)
[2018-05-26 14:58] [ALPM] installed woff2 (1.0.2-1.0)
[2018-05-26 14:58] [ALPM] upgraded webkit2gtk (2.18.6-1.0 -> 2.20.2-1.0)
[2018-05-26 14:58] [ALPM] upgraded python-jade-application-kit (0.a34-1 -> 1.3.5-1)
[2018-05-26 14:58] [ALPM] upgraded ms-office-online (18.01.0-1 -> 18.04.4-1)
[2018-05-26 14:58] [ALPM] upgraded nano (2.9.4-1.0 -> 2.9.7-1.0)
[2018-05-26 14:58] [ALPM] upgraded openssl-1.0 (1.0.2.n-1.0 -> 1.0.2.o-1.0)
[2018-05-26 14:58] [ALPM] upgraded networkmanager (1.10.6-2.01 -> 1.10.8-1.0)
[2018-05-26 14:58] [ALPM] upgraded openvpn (2.4.5-1.0 -> 2.4.6-1.0)
[2018-05-26 14:58] [ALPM] upgraded networkmanager-openvpn (1.8.1dev+10+ge4d8cda-2.0 -> 1.8.2-1.0)
[2018-05-26 14:58] [ALPM] upgraded networkmanager-pptp (1.2.4-3.0 -> 1.2.6-1.0)
[2018-05-26 14:58] [ALPM] upgraded ntp (4.2.8.p11-1.0 -> 4.2.8.p11-2.0)
[2018-05-26 14:58] [ALPM] upgraded os-prober (1.76-1 -> 1.76-2)
[2018-05-26 14:58] [ALPM] upgraded vte-common (0.50.2+6+g7fe155b9-1.0 -> 0.52.2-1.0)
[2018-05-26 14:58] [ALPM] upgraded vte3 (0.50.2+6+g7fe155b9-1.0 -> 0.52.2-1.0)
[2018-05-26 14:58] [ALPM] upgraded pamac (6.2.4-2 -> 6.3.1-1)
[2018-05-26 14:58] [ALPM] upgraded pcsclite (1.8.23-1.0 -> 1.8.23-3.0)
[2018-05-26 14:58] [ALPM] upgraded perl-file-basedir (0.07-3 -> 0.08-1.0)
[2018-05-26 14:58] [ALPM] upgraded perl-uri (1.73-1.0 -> 1.74-1.0)
[2018-05-26 14:58] [ALPM] upgraded poppler-glib (0.61.1-1 -> 0.64.0-1.0)
[2018-05-26 14:58] [ALPM] upgraded poppler-qt5 (0.61.1-1 -> 0.64.0-1.0)
[2018-05-26 14:58] [ALPM] upgraded pyqt5-common (5.10.1-1.0 -> 5.10.1-2.0)
[2018-05-26 14:58] [ALPM] upgraded python-packaging (16.8-2 -> 17.1-1.0)
[2018-05-26 14:58] [ALPM] upgraded python-pexpect (4.4.0-1.0 -> 4.5.0-1.0)
[2018-05-26 14:58] [ALPM] upgraded python-pillow (5.0.0-1.0 -> 5.1.0-1.0)
[2018-05-26 14:58] [ALPM] upgraded python-psutil (5.4.3-1.0 -> 5.4.5-1.0)
[2018-05-26 14:58] [ALPM] upgraded python-pyqt5 (5.10.1-1.0 -> 5.10.1-2.0)
[2018-05-26 14:58] [ALPM] upgraded python-setuptools (1:39.0.1-1.0 -> 1:39.2.0-1.0)
[2018-05-26 14:58] [ALPM] upgraded python-xdg (0.25-4 -> 0.26-1.0)
[2018-05-26 14:58] [ALPM] upgraded qpdfview (0.4.17beta1-5.0 -> 0.4.17beta1-6.0)
[2018-05-26 14:58] [ALPM] upgraded s-nail (14.9.9-1.0 -> 14.9.10-1.0)
[2018-05-26 14:59] [ALPM] warning: directory permissions differ on /var/lib/samba/private/
filesystem: 755  package: 700
[2018-05-26 14:59] [ALPM] upgraded samba (4.7.6-1.0 -> 4.8.1-1.1)
[2018-05-26 14:59] [ALPM] upgraded spectre-meltdown-checker (0.35-1 -> 0.37-1)
[2018-05-26 14:59] [ALPM] installed libutf8proc (1.3.1_3-2.0)
[2018-05-26 14:59] [ALPM] upgraded subversion (1.9.7-4.0 -> 1.10.0-2.0)
[2018-05-26 14:59] [ALPM] upgraded systemd-sysvcompat (238.0-6 -> 238.76-1)
[2018-05-26 14:59] [ALPM] upgraded tcl (8.6.8-2.0 -> 8.6.8-3.0)
[2018-05-26 14:59] [ALPM] upgraded thunar (1.6.14-1.0 -> 1.6.15-1.0)
[2018-05-26 14:59] [ALPM] upgraded ttf-inconsolata (20151221.480630d-2 -> 1:2.0.0.1-3.0)
[2018-05-26 14:59] [ALPM] upgraded tumbler (0.2.0-1 -> 0.2.1-1.0)
[2018-05-26 14:59] [ALPM] upgraded unrar (1:5.6.1-1.0 -> 1:5.6.4-1.0)
[2018-05-26 14:59] [ALPM] installed qt5-x11extras (5.10.1-1.0)
[2018-05-26 14:59] [ALPM] installed libplacebo (0.4.0-1.0)
[2018-05-26 14:59] [ALPM] upgraded vlc (2.2.8-4.0 -> 3.0.2-1.0)
[2018-05-26 14:59] [ALPM] upgraded vulkan-intel (17.3.6-1.0 -> 18.0.4-1.0)
[2018-05-26 14:59] [ALPM] upgraded vulkan-radeon (17.3.6-1.0 -> 18.0.4-1.0)
[2018-05-26 14:59] [ALPM] upgraded wget (1.19.4-3.0 -> 1.19.5-1.0)
[2018-05-26 14:59] [ALPM] upgraded xdg-user-dirs (0.16-1 -> 0.17-1.0)
[2018-05-26 14:59] [ALPM] upgraded xf86-input-libinput (0.26.0-1 -> 0.27.1-1.0)
[2018-05-26 14:59] [ALPM] upgraded xf86-video-amdgpu (18.0.1-1.0 -> 18.0.1-2.0)
[2018-05-26 14:59] [ALPM] upgraded xf86-video-ati (1:18.0.1-1.0 -> 1:18.0.1-2.0)
[2018-05-26 14:59] [ALPM] upgraded xf86-video-intel (1:2.99.917+812+g75795523-1.0 -> 1:2.99.917+831+ge7bfc906-1.0)
[2018-05-26 14:59] [ALPM] upgraded xf86-video-nouveau (1.0.15-2 -> 1.0.15-3.0)
[2018-05-26 14:59] [ALPM] upgraded xfce4-cpufreq-plugin (1.1.3-1 -> 1.2.0-1.0)
[2018-05-26 14:59] [ALPM] upgraded xfce4-pulseaudio-plugin (0.3.5-1 -> 0.4.1-1.1)
[2018-05-26 14:59] [ALPM] upgraded xfce4-screenshooter (1.9.1-1 -> 1.9.2-1.0)
[2018-05-26 14:59] [ALPM] upgraded xfce4-sensors-plugin (1.2.6-3 -> 1.3.0-1.0)
[2018-05-26 14:59] [ALPM] upgraded xfce4-terminal (0.8.7.2-1.0 -> 0.8.7.4-1.0)
[2018-05-26 14:59] [ALPM] upgraded xfce4-verve-plugin (1.1.0-1 -> 2.0.0-1.0)
[2018-05-26 14:59] [ALPM] upgraded xfce4-whiskermenu-plugin (1.7.5-1.0 -> 2.2.0-1.0)
[2018-05-26 14:59] [ALPM] upgraded xorg-server-common (1.19.6+13+gd0d1a694f-1.0 -> 1.20.0-2.0)
[2018-05-26 14:59] [ALPM] upgraded xorg-server (1.19.6+13+gd0d1a694f-1.0 -> 1.20.0-2.0)
[2018-05-26 14:59] [ALPM] upgraded yelp-xsl (3.20.1-2 -> 3.28.0-1.0)
[2018-05-26 14:59] [ALPM] upgraded yelp (3.26.0-1 -> 3.28.1-1.0)
[2018-05-26 14:59] [ALPM] upgraded zsh (5.4.2-2.0 -> 5.5.1-1.0)
[2018-05-26 14:59] [ALPM] transaction completed
[2018-05-26 14:59] [ALPM] running '60-linux414.hook'...
[2018-05-26 14:59] [ALPM] running '90-linux414.hook'...
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: 'default'
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.14-i686 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-i686.img
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> Starting build: 4.14.44-1-MANJARO
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.14-i686.img
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: 'fallback'
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.14-i686 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-i686-fallback.img -S autodetect
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> Starting build: 4.14.44-1-MANJARO
[2018-05-26 14:59] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> ERROR: file not found: `'
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> ERROR: file not found: `'
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> ERROR: file not found: `'
[2018-05-26 14:59] [ALPM-SCRIPTLET] /usr/lib/initcpio/functions: line 728: : No such file or directory
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> ERROR: Failed to read 
[2018-05-26 14:59] [ALPM-SCRIPTLET] /usr/lib/initcpio/functions: line 728: : No such file or directory
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> ERROR: Failed to read 
[2018-05-26 14:59] [ALPM-SCRIPTLET] /usr/lib/initcpio/functions: line 728: : No such file or directory
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> ERROR: Failed to read 
[2018-05-26 14:59] [ALPM-SCRIPTLET] /usr/lib/initcpio/functions: line 728: : No such file or directory
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> ERROR: Failed to read 
[2018-05-26 14:59] [ALPM-SCRIPTLET] /usr/lib/initcpio/functions: line 728: : No such file or directory
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> ERROR: Failed to read 
[2018-05-26 14:59] [ALPM-SCRIPTLET] /usr/lib/initcpio/functions: line 728: : No such file or directory
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> ERROR: Failed to read 
[2018-05-26 14:59] [ALPM-SCRIPTLET] /usr/lib/initcpio/functions: line 728: : No such file or directory
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> ERROR: Failed to read 
[2018-05-26 14:59] [ALPM-SCRIPTLET] /usr/lib/initcpio/functions: line 728: : No such file or directory
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> ERROR: Failed to read 
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> WARNING: No modules were added to the image. This is probably not what you want.
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> Creating -compressed initcpio image: 
[2018-05-26 14:59] [ALPM-SCRIPTLET] ==> WARNING: errors were encountered during the build. The image may not be complete.
[2018-05-26 14:59] [ALPM] running '99-grub.hook'...
[2018-05-26 14:59] [ALPM-SCRIPTLET] Generating grub configuration file ...
[2018-05-26 14:59] [ALPM-SCRIPTLET] Found background: /usr/share/grub/background.png
[2018-05-26 14:59] [ALPM-SCRIPTLET] Found Intel Microcode image
[2018-05-26 14:59] [ALPM-SCRIPTLET] Found linux image: /boot/vmlinuz-4.14-i686
[2018-05-26 14:59] [ALPM-SCRIPTLET] Found initrd image: /boot/initramfs-4.14-i686.img
[2018-05-26 14:59] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.14-i686-fallback.img
[2018-05-26 15:00] [ALPM-SCRIPTLET] Found memtest86+ image: /boot/memtest86+/memtest.bin
[2018-05-26 15:00] [ALPM-SCRIPTLET] done
[2018-05-26 15:00] [ALPM] running 'detect-old-perl-modules.hook'...
[2018-05-26 15:00] [ALPM] running 'fontconfig.hook'...
[2018-05-26 15:00] [ALPM] running 'gdk-pixbuf-query-loaders.hook'...
[2018-05-26 15:00] [ALPM] running 'gio-querymodules.hook'...
[2018-05-26 15:00] [ALPM] running 'glib-compile-schemas.hook'...
[2018-05-26 15:00] [ALPM] running 'gtk-query-immodules-3.0.hook'...
[2018-05-26 15:00] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-05-26 15:00] [ALPM] running 'gvfsd.hook'...
[2018-05-26 15:00] [ALPM] running 'manjaro-xfce-settings.hook'...
[2018-05-26 15:00] [ALPM-SCRIPTLET] '/usr/share/backgrounds/xfce/breath.png' -> '/usr/share/backgrounds/breath.png'
[2018-05-26 15:00] [ALPM-SCRIPTLET] '/usr/share/backgrounds/xfce/manjarowall17_01.jpg' -> '/usr/share/backgrounds/manjarowall17_01.jpg'
[2018-05-26 15:00] [ALPM-SCRIPTLET] '/usr/share/backgrounds/xfce/manjarowall17_02.jpg' -> '/usr/share/backgrounds/manjarowall17_02.jpg'
[2018-05-26 15:00] [ALPM-SCRIPTLET] '/usr/share/backgrounds/xfce/manjarowall17_03.jpg' -> '/usr/share/backgrounds/manjarowall17_03.jpg'
[2018-05-26 15:00] [ALPM-SCRIPTLET] '/usr/share/backgrounds/xfce/manjarowall17_04.jpg' -> '/usr/share/backgrounds/manjarowall17_04.jpg'
[2018-05-26 15:00] [ALPM-SCRIPTLET] '/usr/share/backgrounds/xfce/manjarowall17_05.jpg' -> '/usr/share/backgrounds/manjarowall17_05.jpg'
[2018-05-26 15:00] [ALPM-SCRIPTLET] '/usr/share/backgrounds/xfce/manjarowall17_06.jpg' -> '/usr/share/backgrounds/manjarowall17_06.jpg'
[2018-05-26 15:00] [ALPM-SCRIPTLET] '/usr/share/backgrounds/xfce/manjarowall17_07.jpg' -> '/usr/share/backgrounds/manjarowall17_07.jpg'
[2018-05-26 15:00] [ALPM-SCRIPTLET] '/usr/share/backgrounds/xfce/manjarowall17_08.jpg' -> '/usr/share/backgrounds/manjarowall17_08.jpg'
[2018-05-26 15:00] [ALPM] running 'pacman-mirrors-upgrade.hook'...
[2018-05-26 15:00] [ALPM-SCRIPTLET] .: e[1;37mINFOe[1;m Downloading mirrors from repo.manjaro.org
[2018-05-26 15:00] [ALPM-SCRIPTLET] hint: use `pacman-mirrors` to generate and update your pacman mirrorlist.
[2018-05-26 15:00] [ALPM] running 'systemd-catalog.hook'...
[2018-05-26 15:00] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-05-26 15:00] [ALPM] running 'systemd-hwdb.hook'...
[2018-05-26 15:00] [ALPM] running 'systemd-sysctl.hook'...
[2018-05-26 15:00] [ALPM] running 'systemd-sysusers.hook'...
[2018-05-26 15:00] [ALPM] running 'systemd-tmpfiles.hook'...
[2018-05-26 15:00] [ALPM] running 'systemd-udev-reload.hook'...
[2018-05-26 15:00] [ALPM] running 'systemd-update.hook'...
[2018-05-26 15:00] [ALPM] running 'texinfo-install.hook'...
[2018-05-26 15:00] [ALPM] running 'update-ca-trust.hook'...
[2018-05-26 15:00] [ALPM] running 'update-desktop-database.hook'...
[2018-05-26 15:00] [ALPM] running 'update-mime-database.hook'...
[2018-05-26 15:00] [ALPM] running 'update-vlc-plugin-cache.hook'...
[2018-05-26 15:00] [ALPM] running 'xorg-mkfontdir.hook'...
[2018-05-26 15:05] [ALPM] transaction started
[2018-05-26 15:05] [ALPM] removed ms-office-online (18.04.4-1)
[2018-05-26 15:05] [ALPM] transaction completed
[2018-05-26 15:05] [ALPM] running 'systemd-update.hook'...
[2018-05-26 15:05] [ALPM] running 'update-desktop-database.hook'...
[2018-05-26 15:19] [PACMAN] Running 'pacman -S haveged'
[2018-05-26 15:19] [ALPM] transaction started
[2018-05-26 15:19] [ALPM] reinstalled haveged (1.9.1-4)
[2018-05-26 15:19] [ALPM] transaction completed
[2018-05-26 15:19] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-05-26 15:19] [ALPM] running 'systemd-update.hook'...

Installed manjaro-xfce-17.1.7-rc1-testing-i686.iso fresh and updated to most current and still no success.

Is there another log file I can post that shows what was displayed when tried to $ startx from console?


#12

During the system update, received errors:

# pacman -Syyu
:: Synchronizing package databases...
 core                     188.8 KiB   203K/s 00:01 [######################] 100%
 extra                      2.3 MiB   731K/s 00:03 [######################] 100%
 community                  5.1 MiB   913K/s 00:06 [######################] 100%
:: Some packages should be upgraded first...
resolving dependencies...
looking for conflicting packages...

Packages (3) archlinux-keyring-20180404-1.0  manjaro-keyring-20171027-2
             manjaro-system-20180516-1

Total Installed Size:  1.04 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
(3/3) checking keys in keyring                     [######################] 100%
(3/3) checking package integrity                   [######################] 100%
(3/3) loading package files                        [######################] 100%
(3/3) checking for file conflicts                  [######################] 100%
(3/3) checking available disk space                [######################] 100%
:: Processing package changes...
(1/3) upgrading archlinux-keyring                  [######################] 100%
==> Appending keys from archlinux.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key DDB867B92AA789C165EEFA799B729B06A680C281...
  -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
  -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
  -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
  -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
==> Importing owner trust values...
==> Disabling revoked keys in keyring...
  -> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...
  -> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...
  -> Disabling key 40440DC037C05620984379A6761FAD69BA06C6A9...
  -> Disabling key B1F2C889CB2CCB2ADA36D963097D629E437520BD...
  -> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...
  -> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...
  -> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...
  -> Disabling key 4FCF887689C41B09506BE8D5F3E1D5C5D30DB0AD...
  -> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...
  -> Disabling key 5E7585ADFF106BFFBBA319DC654B877A0864983E...
  -> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...
  -> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...
  -> Disabling key 8CF934E339CAD8ABF342E822E711306E3C4F88BC...
  -> Disabling key 5696C003B0854206450C8E5BE613C09CB4440678...
  -> Disabling key 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5...
  -> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...
  -> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...
  -> Disabling key 34C5D94FE7E7913E86DC427E7FB1A3800C84C0A5...
  -> Disabling key 39F880E50E49A4D11341E8F939E4F17F295AFBF4...
  -> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...
  -> Disabling key DBE7D3DD8C81D58D0A13D0E76BC26A17B9B7018A...
  -> Disabling key 07DFD3A0BC213FA12EDC217559B3122E2FA915EC...
  -> Disabling key 44D4A033AC140143927397D47EFD567D4C7EA887...
  -> Disabling key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
  -> Disabling key 8840BD07FC24CB7CE394A07CCF7037A4F27FB7DA...
==> Updating trust database...
gpg: next trustdb check due at 2018-06-01
(2/3) upgrading manjaro-keyring                    [######################] 100%
==> Appending keys from manjaro.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key 75C1B95A4D9514A57EB2DAE71817DC63CD3B5DF5...
  -> Locally signing key 16DC688DF3EECC72323954237EC47C82A42D53A2...
  -> Locally signing key 76C6E477042BFE985CC220BD9C08A255442FAFF0...
  -> Locally signing key 2D14560CDCE6A75BB186DB758238651DDF5E0594...
  -> Locally signing key B4663188A692DB1E45A98EE95BD96CC4247B52CC...
  -> Locally signing key 04BB537F5BC2D399BFA72F8F17C752B61B2F2E90...
  -> Locally signing key 35B4FF23EA9477582C2A0AF12B80869C5C0102A6...
  -> Locally signing key 77DC01C9971AC3C39A0626F72C089F09AC97B894...
  -> Locally signing key 39F0EC1AE50B37E5F3196F09DAD3B211663CA268...
  -> Locally signing key E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E...
  -> Locally signing key 7C89F4D439B2BFACF425107B62443D89B35859F8...
  -> Locally signing key 22C903DE964E6FE321656E318DB9F8C18DF53602...
  -> Locally signing key 5A97ED6B72418199F0C22B23137C934B5DCB998E...
  -> Locally signing key 2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA...
  -> Locally signing key 1E7908935AAB9A00D6B47503363DFFFD59152F77...
  -> Locally signing key 74C2F2CC05A0AB7D859839938934292D604F8BA2...
==> Importing owner trust values...
==> Disabling revoked keys in keyring...
  -> Disabling key FAA6840E8C3FC7F89BEE0DC8AC7AB10BCB6CDD17...
  -> Disabling key 540DE7083B89314CF70EA6F0C1B1AD0DA80EBF3E...
==> Updating trust database...
gpg: next trustdb check due at 2018-06-01
(3/3) upgrading manjaro-system                     [######################] 100%
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...

:: Starting full system upgrade...
:: Replace compositeproto with extra/xorgproto? [Y/n] y
:: Replace damageproto with extra/xorgproto? [Y/n] y
warning: firefox: ignoring package upgrade (59.0.1-1.1 => 60.0.1-1.0)
:: Replace fixesproto with extra/xorgproto? [Y/n] y
:: Replace fontsproto with extra/xorgproto? [Y/n] y
:: Replace gnome-themes-standard with extra/gnome-themes-extra? [Y/n] y
:: Replace inputproto with extra/xorgproto? [Y/n] y
:: Replace kbproto with extra/xorgproto? [Y/n] y
:: Replace randrproto with extra/xorgproto? [Y/n] y
:: Replace recordproto with extra/xorgproto? [Y/n] y
:: Replace renderproto with extra/xorgproto? [Y/n] y
:: Replace scrnsaverproto with extra/xorgproto? [Y/n] y
:: Replace videoproto with extra/xorgproto? [Y/n] y
:: Replace xextproto with extra/xorgproto? [Y/n] y
:: Replace xf86miscproto with extra/xorgproto? [Y/n] y
:: Replace xf86vidmodeproto with extra/xorgproto? [Y/n] y
:: Replace xineramaproto with extra/xorgproto? [Y/n] y
:: Replace xproto with extra/xorgproto? [Y/n] y
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency

Packages (321) accountsservice-0.6.49-1.0  acpid-2.0.29-2.0
               adwaita-icon-theme-3.28.0-1.0  alsa-lib-1.1.6-1.0
               alsa-plugins-1.1.6-2.0  alsa-utils-1.1.6-1.0
               appstream-glib-0.7.7-1.0  archlinux-appstream-data-20180424-1.0
               archlinux32-keyring-20180411-1.1  at-spi2-atk-2.26.2-1.0
               at-spi2-core-2.28.0-1.0  atk-2.28.1-1.0
               audacious-plugins-3.9-3.0  avahi-0.7+4+gd8d8c67-1.0
               babl-0.1.50-1.0  binutils-2.30-4.1  blueman-2.0.5-2.0
               bluez-5.49-4.0  bluez-libs-5.49-4.0  boost-libs-1.66.0-2.0
               breath-wallpaper-0.3.1-1  brotli-1.0.4-1.0  btrfs-progs-4.16-2.0
               ca-certificates-mozilla-3.37.1-1.0  cairo-1.15.12-1.0
               chromaprint-1.4.3-2.0  colord-1.4.3-1.0
               compositeproto-0.4.2-3 [removal]  cpupower-4.16-1.0
               crda-4.14-1.1  cryptsetup-2.0.3-1.0  cups-2.2.7-2.0
               cups-filters-1.20.3-2.0  curl-7.60.0-1.0
               damageproto-1.2.1-3 [removal]  dbus-1.12.8-1.0  dconf-0.28.0-1.0
               desktop-file-utils-0.23+4+g92af410-1.0  dhcpcd-7.0.4-1.0
               e2fsprogs-1.44.2-1.0  ffmpeg-1:4.0-2.2  ffmpeg2.8-2.8.14-1.0
               ffmpegthumbnailer-2.2.0-2.0  file-5.33-3.0  filesystem-2018.1-3
               fixesproto-5.0+9+g4292ec1-1 [removal]
               fontconfig-2.13.0+10+g58f5285-1.0  fontsproto-2.1.3-2 [removal]
               foomatic-db-engine-4:4.0.13-1.0  freetype2-2.9.1-1.0
               fribidi-1.0.2-1.0  fuse-common-3.2.3-1.0  gcc-8.1.0-1.1
               gcc-libs-8.1.0-1.1  gconf-3.2.6+11+g07808097-3.0  gcr-3.28.0-3.0
               gdk-pixbuf2-2.36.12-1.0  gegl-0.4.2-1.0  ghostscript-9.23-1.0
               gimp-2.10.2-1.0  git-2.17.0-1.0  glib-networking-2.56.1-1.0
               glib2-2.56.1-1.0  glibc-2.27-3.1  glibmm-2.56.0-1.0
               gnome-keyring-1:3.28.2-1.0  gnome-menus-3.13.3+30+g510ef1c-1.0
               gnome-themes-extra-3.28-1.0
               gnome-themes-standard-3.22.3+16+gc092fc89-1.0 [removal]
               gnupg-2.2.7-1.0  gobject-introspection-runtime-1.56.1-1.0
               gpgme-1.11.1-1.0
               gsettings-desktop-schemas-3.28.0+1+g85521dc-1.0  gsm-1.0.18-1.0
               gst-libav-1.14.1-1.0  gst-plugins-bad-1.14.1-1.0
               gst-plugins-base-1.14.1-1.0  gst-plugins-base-libs-1.14.1-1.0
               gst-plugins-good-1.14.0-1.0  gst-plugins-ugly-1.14.1-1.0
               gstreamer-1.14.1-1.0  gtk-update-icon-cache-3.22.30-1.0
               gtk3-3.22.30-1.0  gtksourceview3-3.24.7-1.0  gvfs-1.36.2-1.0
               gvfs-afc-1.36.2-1.0  gvfs-gphoto2-1.36.2-1.0
               gvfs-mtp-1.36.2-1.0  gvfs-nfs-1.36.2-1.0  gvfs-smb-1.36.2-1.0
               harfbuzz-1.7.6-2.0  harfbuzz-icu-1.7.6-2.0  hdparm-9.56-1.0
               hplip-3.18.4-2.0  htop-2.2.0-2.0  icu-61.1-1.0
               ilmbase-2.2.1-2.0  imagemagick-7.0.7.35-1.0  imlib2-1.5.1-1.0
               inputproto-2.3.2-1 [removal]  intel-ucode-20180425-1.0
               inxi-3.0.08-1  iproute2-4.16.0-1.0  js52-52.7.3-2.0
               kauth-5.46.0-1.0  kbproto-1.0.7-1 [removal]
               kcoreaddons-5.46.0-1.0  kitemmodels-5.46.0-1.0  krb5-1.16.1-1.0
               ldb-1.3.2-1.0  libaio-0.3.111-1.0  libatomic_ops-7.6.4-1.0
               libblockdev-2.17-3.0  libbytesize-1.3-1.0  libcdr-0.1.4-3.0
               libcups-2.2.7-2.0  libdrm-2.4.92-1.0  libdvbpsi-1:1.3.2-1.0
               libdvdcss-1.4.2-1.0  libe-book-0.1.3-2.0  libebml-1.3.6-1.0
               libepoxy-1.5.2-1.0  libetonyek-0.1.8-1.0  libgexiv2-0.10.8-1.0
               libgme-0.6.2-1.0  libgpg-error-1.31-1.0  libgphoto2-2.5.18-1.0
               libgsf-1.14.43-1.0  libgtop-2.38.0+13+gcab8791f-1.0
               libibus-1.5.18-1.0  libical-3.0.3-2.0  libidn-1.34-2.0
               libidn2-2.0.5-1.0  libinput-1.10.7-1.0  libldap-2.4.46-1.0
               liblouis-3.5.0-1.0  libmagick-7.0.7.35-1.0
               libmatroska-1.4.9-1.0  libmm-glib-1.8rc2+1+g7e949283-1.0
               libmspub-0.1.4-2.0  libmtp-1.1.15-1.0  libmwaw-0.3.14-1.0
               libmypaint-1.3.0-5.0  libnetfilter_conntrack-1.0.7-1.0
               libnghttp2-1.31.1-1.0  libnice-0.1.14+70+gfb2f1f7-1.0
               libnm-1.10.8-1.0  libnm-glib-1.10.8-1.0  libnsl-1.2.0-1.0
               libplacebo-0.4.0-1.0  libpsl-0.20.2-1.0
               libreoffice-still-5.4.6-2.0  librsvg-2:2.42.4-1.0
               libsecret-0.18.6-1.0  libsoup-2.62.2-1.0  libsrtp-1:2.2.0-1.0
               libsynctex-2017.44590-14.0  libsystemd-238.76-1
               libtirpc-1.0.3-2.0  libtool-2.4.6+40+g6ca5e224-6.0
               libusb-1.0.22-1.0  libutf8proc-1.3.1_3-2.0
               libutil-linux-2.32-3.0  libva-mesa-driver-18.0.4-1.0
               libvisio-0.1.6-3.0  libwacom-0.29-1.0  libwbclient-4.8.1-1.1
               libwebp-1.0.0-1.0  libwps-0.4.9-1.0  libx264-2:152.20171224-2.1
               libx264-all-2:152.20171224-2.1  libxml2-2.9.8-2.0
               libzmf-0.0.2-3.0  lightdm-1:1.26.0-1.0
               lightdm-gtk-greeter-1:2.0.5-1.0  linux-api-headers-4.16.1-1.0
               linux-firmware-20180525.7518922-1  linux414-4.14.44-1
               llvm-libs-6.0.0-4.1  lm_sensors-3.4.0-4.0  logrotate-3.14.0-1.0
               man-db-2.8.3-1.0  man-pages-4.16-1.0
               manjaro-browser-settings-20180523-1  manjaro-hello-0.5.11-2
               manjaro-release-18.0alpha1-1  manjaro-settings-manager-0.5.4-13
               manjaro-settings-manager-notifier-0.5.4-13
               manjaro-xfce-settings-20180505-1  mesa-18.0.4-1.0
               mesa-vdpau-18.0.4-1.0  mhwd-0.6.3-1  mhwd-db-0.6.3-1
               mhwd-nvidia-390xx-390.59-1  mkinitcpio-busybox-1.28.3-1.0
               modemmanager-1.8rc2+1+g7e949283-1.0  mpg123-1.25.10-1.0
               ms-office-online-18.04.4-1  mypaint-brushes-1.3.0-2.0
               nano-2.9.7-1.0  ndctl-60.3-1.0  neon-0.30.2-3.0
               net-snmp-5.7.3-8.0  networkmanager-1.10.8-1.0
               networkmanager-openvpn-1.8.2-1.0  networkmanager-pptp-1.2.6-1.0
               nss-3.37.1-1.0  ntp-4.2.8.p11-2.0  openal-1.18.2-2.0
               openssh-7.7p1-1.0  openssl-1.1.0.h-1.0  openssl-1.0-1.0.2.o-1.0
               openvpn-2.4.6-1.0  os-prober-1.76-2  pacman-mirrors-4.10.1-3
               pam-1.3.0-2.0  pamac-6.3.1-1  pango-1.42.1-1.0  pcre-8.42-1.0
               pcsclite-1.8.23-3.0  perl-5.26.2-1.0  perl-error-0.17026-1.0
               perl-file-basedir-0.08-1.0  perl-mailtools-2.20-1.0
               perl-timedate-2.30-4  perl-uri-1.74-1.0  pinentry-1.1.0-3.0
               polkit-0.114-1.1  poppler-0.64.0-1.0  poppler-data-0.4.9-1.0
               poppler-glib-0.64.0-1.0  poppler-qt5-0.64.0-1.0
               procps-ng-3.3.14-1.2  pygobject-devel-3.28.2-1.0
               pyqt5-common-5.10.1-2.0  python-3.6.5-3.0
               python-cairo-1.17.0-1.0  python-gobject-3.28.2-1.0
               python-jade-application-kit-1.3.5-1  python-packaging-17.1-1.0
               python-pexpect-4.5.0-1.0  python-pillow-5.1.0-1.0
               python-psutil-5.4.5-1.0  python-pyqt5-5.10.1-2.0
               python-setuptools-1:39.2.0-1.0  python-xdg-0.26-1.0
               python2-2.7.15-1.0  python2-cairo-1.17.0-1.0
               qpdfview-0.4.17beta1-6.0  qt5-base-5.10.1-8.0
               qt5-styleplugins-5.0.0.20170311-6.0  qt5-x11extras-5.10.1-1.0
               qt5ct-0.35-2.0  randrproto-1.5.0-1 [removal]  raptor-2.0.15-8.0
               recordproto-1.14.2-2 [removal]  renderproto-0.11.1-3 [removal]
               s-nail-14.9.10-1.0  samba-4.8.1-1.1
               scrnsaverproto-1.2.2-2 [removal]  sdl2-2.0.8-8.0  sed-4.5-1.0
               smbclient-4.8.1-1.1  spectre-meltdown-checker-0.37-1
               sqlite-3.23.1-1.0  srt-1.3.0-2.0  subversion-1.10.0-2.0
               systemd-238.76-1  systemd-sysvcompat-238.76-1  talloc-2.1.13-1.0
               tcl-8.6.8-3.0  thin-provisioning-tools-0.7.6-1.0
               thunar-1.6.15-1.0  tslib-1.16-1.0  ttf-inconsolata-1:2.0.0.1-3.0
               tumbler-0.2.1-1.0  twolame-0.3.13-8.0  tzdata-2018e-1.0
               unrar-1:5.6.4-1.0  util-linux-2.32-3.0
               vertex-maia-themes-20180429-1  videoproto-2.3.3-1 [removal]
               vlc-3.0.2-1.0  vte-common-0.52.2-1.0  vte3-0.52.2-1.0
               vulkan-icd-loader-1.1.73.0-1.0  vulkan-intel-18.0.4-1.0
               vulkan-radeon-18.0.4-1.0  wayland-1.15.0-1.1
               wayland-protocols-1.14-1.0  webkit2gtk-2.20.2-1.0
               wget-1.19.5-1.0  woff2-1.0.2-1.0  xdg-user-dirs-0.17-1.0
               xdg-utils-1.1.3-1.0  xextproto-7.3.0-1 [removal]
               xf86-input-libinput-0.27.1-1.0  xf86-video-amdgpu-18.0.1-2.0
               xf86-video-ati-1:18.0.1-2.0
               xf86-video-intel-1:2.99.917+831+ge7bfc906-1.0
               xf86-video-nouveau-1.0.15-3.0  xf86miscproto-0.9.3-1 [removal]
               xf86vidmodeproto-2.3.1-3 [removal]
               xfce4-cpufreq-plugin-1.2.0-1.0
               xfce4-pulseaudio-plugin-0.4.1-1.1  xfce4-screenshooter-1.9.2-1.0
               xfce4-sensors-plugin-1.3.0-1.0  xfce4-terminal-0.8.7.4-1.0
               xfce4-verve-plugin-2.0.0-1.0  xfce4-whiskermenu-plugin-2.2.0-1.0
               xineramaproto-1.2.1-3 [removal]  xkeyboard-config-2.23.1-3.0
               xorg-server-1.20.0-2.0  xorg-server-common-1.20.0-2.0
               xorgproto-2018.4-1.0  xproto-7.0.31-1 [removal]  xz-5.2.4-1.0
               yelp-3.28.1-1.0  yelp-xsl-3.28.0-1.0  zsh-5.5.1-1.0
               zstd-1.3.4-1.0

Total Download Size:     10.75 MiB
Total Installed Size:  3079.05 MiB
Net Upgrade Size:       234.52 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 qt5-x11extras-5.10....    13.8 KiB  4.48M/s 00:00 [######################] 100%
 libplacebo-0.4.0-1....   137.9 KiB   183K/s 00:01 [######################] 100%
 vlc-3.0.2-1.0-i686        10.6 MiB   888K/s 00:12 [######################] 100%
(304/304) checking keys in keyring                 [######################] 100%
*** buffer overflow detected ***: pacman terminated[###########-----------]  52%
Aborted (core dumped)
# pacman -Syyu
:: Synchronizing package databases...
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to synchronize any databases
error: failed to init transaction (unable to lock database)
error: could not lock database: File exists
  if you're sure a package manager is not already
  running, you can remove /var/lib/pacman/db.lck
# rm /var/lib/pacman/db.lck
# pacman -Syyu
:: Synchronizing package databases...
 core                     188.8 KiB   208K/s 00:01 [######################] 100%
 extra                      2.3 MiB   754K/s 00:03 [######################] 100%
 community                  5.1 MiB  1160K/s 00:05 [######################] 100%
:: Starting full system upgrade...
:: Replace compositeproto with extra/xorgproto? [Y/n] y
:: Replace damageproto with extra/xorgproto? [Y/n] y
warning: firefox: ignoring package upgrade (59.0.1-1.1 => 60.0.1-1.0)
:: Replace fixesproto with extra/xorgproto? [Y/n] y
:: Replace fontsproto with extra/xorgproto? [Y/n] y
:: Replace gnome-themes-standard with extra/gnome-themes-extra? [Y/n] y
:: Replace inputproto with extra/xorgproto? [Y/n] y
:: Replace kbproto with extra/xorgproto? [Y/n] y
y:: Replace randrproto with extra/xorgproto? [Y/n] 
:: Replace recordproto with extra/xorgproto? [Y/n] y
:: Replace renderproto with extra/xorgproto? [Y/n] y
:: Replace scrnsaverproto with extra/xorgproto? [Y/n] y
:: Replace videoproto with extra/xorgproto? [Y/n] y
:: Replace xextproto with extra/xorgproto? [Y/n] y
:: Replace xf86miscproto with extra/xorgproto? [Y/n] y
:: Replace xf86vidmodeproto with extra/xorgproto? [Y/n] y
:: Replace xineramaproto with extra/xorgproto? [Y/n] y
:: Replace xproto with extra/xorgproto? [Y/n] y
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency

Packages (321) accountsservice-0.6.49-1.0  acpid-2.0.29-2.0
               adwaita-icon-theme-3.28.0-1.0  alsa-lib-1.1.6-1.0
               alsa-plugins-1.1.6-2.0  alsa-utils-1.1.6-1.0
               appstream-glib-0.7.7-1.0  archlinux-appstream-data-20180424-1.0
               archlinux32-keyring-20180411-1.1  at-spi2-atk-2.26.2-1.0
               at-spi2-core-2.28.0-1.0  atk-2.28.1-1.0
               audacious-plugins-3.9-3.0  avahi-0.7+4+gd8d8c67-1.0
               babl-0.1.50-1.0  binutils-2.30-4.1  blueman-2.0.5-2.0
               bluez-5.49-4.0  bluez-libs-5.49-4.0  boost-libs-1.66.0-2.0
               breath-wallpaper-0.3.1-1  brotli-1.0.4-1.0  btrfs-progs-4.16-2.0
               ca-certificates-mozilla-3.37.1-1.0  cairo-1.15.12-1.0
               chromaprint-1.4.3-2.0  colord-1.4.3-1.0
               compositeproto-0.4.2-3 [removal]  cpupower-4.16-1.0
               crda-4.14-1.1  cryptsetup-2.0.3-1.0  cups-2.2.7-2.0
               cups-filters-1.20.3-2.0  curl-7.60.0-1.0
               damageproto-1.2.1-3 [removal]  dbus-1.12.8-1.0  dconf-0.28.0-1.0
               desktop-file-utils-0.23+4+g92af410-1.0  dhcpcd-7.0.4-1.0
               e2fsprogs-1.44.2-1.0  ffmpeg-1:4.0-2.2  ffmpeg2.8-2.8.14-1.0
               ffmpegthumbnailer-2.2.0-2.0  file-5.33-3.0  filesystem-2018.1-3
               fixesproto-5.0+9+g4292ec1-1 [removal]
               fontconfig-2.13.0+10+g58f5285-1.0  fontsproto-2.1.3-2 [removal]
               foomatic-db-engine-4:4.0.13-1.0  freetype2-2.9.1-1.0
               fribidi-1.0.2-1.0  fuse-common-3.2.3-1.0  gcc-8.1.0-1.1
               gcc-libs-8.1.0-1.1  gconf-3.2.6+11+g07808097-3.0  gcr-3.28.0-3.0
               gdk-pixbuf2-2.36.12-1.0  gegl-0.4.2-1.0  ghostscript-9.23-1.0
               gimp-2.10.2-1.0  git-2.17.0-1.0  glib-networking-2.56.1-1.0
               glib2-2.56.1-1.0  glibc-2.27-3.1  glibmm-2.56.0-1.0
               gnome-keyring-1:3.28.2-1.0  gnome-menus-3.13.3+30+g510ef1c-1.0
               gnome-themes-extra-3.28-1.0
               gnome-themes-standard-3.22.3+16+gc092fc89-1.0 [removal]
               gnupg-2.2.7-1.0  gobject-introspection-runtime-1.56.1-1.0
               gpgme-1.11.1-1.0
               gsettings-desktop-schemas-3.28.0+1+g85521dc-1.0  gsm-1.0.18-1.0
               gst-libav-1.14.1-1.0  gst-plugins-bad-1.14.1-1.0
               gst-plugins-base-1.14.1-1.0  gst-plugins-base-libs-1.14.1-1.0
               gst-plugins-good-1.14.0-1.0  gst-plugins-ugly-1.14.1-1.0
               gstreamer-1.14.1-1.0  gtk-update-icon-cache-3.22.30-1.0
               gtk3-3.22.30-1.0  gtksourceview3-3.24.7-1.0  gvfs-1.36.2-1.0
               gvfs-afc-1.36.2-1.0  gvfs-gphoto2-1.36.2-1.0
               gvfs-mtp-1.36.2-1.0  gvfs-nfs-1.36.2-1.0  gvfs-smb-1.36.2-1.0
               harfbuzz-1.7.6-2.0  harfbuzz-icu-1.7.6-2.0  hdparm-9.56-1.0
               hplip-3.18.4-2.0  htop-2.2.0-2.0  icu-61.1-1.0
               ilmbase-2.2.1-2.0  imagemagick-7.0.7.35-1.0  imlib2-1.5.1-1.0
               inputproto-2.3.2-1 [removal]  intel-ucode-20180425-1.0
               inxi-3.0.08-1  iproute2-4.16.0-1.0  js52-52.7.3-2.0
               kauth-5.46.0-1.0  kbproto-1.0.7-1 [removal]
               kcoreaddons-5.46.0-1.0  kitemmodels-5.46.0-1.0  krb5-1.16.1-1.0
               ldb-1.3.2-1.0  libaio-0.3.111-1.0  libatomic_ops-7.6.4-1.0
               libblockdev-2.17-3.0  libbytesize-1.3-1.0  libcdr-0.1.4-3.0
               libcups-2.2.7-2.0  libdrm-2.4.92-1.0  libdvbpsi-1:1.3.2-1.0
               libdvdcss-1.4.2-1.0  libe-book-0.1.3-2.0  libebml-1.3.6-1.0
               libepoxy-1.5.2-1.0  libetonyek-0.1.8-1.0  libgexiv2-0.10.8-1.0
               libgme-0.6.2-1.0  libgpg-error-1.31-1.0  libgphoto2-2.5.18-1.0
               libgsf-1.14.43-1.0  libgtop-2.38.0+13+gcab8791f-1.0
               libibus-1.5.18-1.0  libical-3.0.3-2.0  libidn-1.34-2.0
               libidn2-2.0.5-1.0  libinput-1.10.7-1.0  libldap-2.4.46-1.0
               liblouis-3.5.0-1.0  libmagick-7.0.7.35-1.0
               libmatroska-1.4.9-1.0  libmm-glib-1.8rc2+1+g7e949283-1.0
               libmspub-0.1.4-2.0  libmtp-1.1.15-1.0  libmwaw-0.3.14-1.0
               libmypaint-1.3.0-5.0  libnetfilter_conntrack-1.0.7-1.0
               libnghttp2-1.31.1-1.0  libnice-0.1.14+70+gfb2f1f7-1.0
               libnm-1.10.8-1.0  libnm-glib-1.10.8-1.0  libnsl-1.2.0-1.0
               libplacebo-0.4.0-1.0  libpsl-0.20.2-1.0
               libreoffice-still-5.4.6-2.0  librsvg-2:2.42.4-1.0
               libsecret-0.18.6-1.0  libsoup-2.62.2-1.0  libsrtp-1:2.2.0-1.0
               libsynctex-2017.44590-14.0  libsystemd-238.76-1
               libtirpc-1.0.3-2.0  libtool-2.4.6+40+g6ca5e224-6.0
               libusb-1.0.22-1.0  libutf8proc-1.3.1_3-2.0
               libutil-linux-2.32-3.0  libva-mesa-driver-18.0.4-1.0
               libvisio-0.1.6-3.0  libwacom-0.29-1.0  libwbclient-4.8.1-1.1
               libwebp-1.0.0-1.0  libwps-0.4.9-1.0  libx264-2:152.20171224-2.1
               libx264-all-2:152.20171224-2.1  libxml2-2.9.8-2.0
               libzmf-0.0.2-3.0  lightdm-1:1.26.0-1.0
               lightdm-gtk-greeter-1:2.0.5-1.0  linux-api-headers-4.16.1-1.0
               linux-firmware-20180525.7518922-1  linux414-4.14.44-1
               llvm-libs-6.0.0-4.1  lm_sensors-3.4.0-4.0  logrotate-3.14.0-1.0
               man-db-2.8.3-1.0  man-pages-4.16-1.0
               manjaro-browser-settings-20180523-1  manjaro-hello-0.5.11-2
               manjaro-release-18.0alpha1-1  manjaro-settings-manager-0.5.4-13
               manjaro-settings-manager-notifier-0.5.4-13
               manjaro-xfce-settings-20180505-1  mesa-18.0.4-1.0
               mesa-vdpau-18.0.4-1.0  mhwd-0.6.3-1  mhwd-db-0.6.3-1
               mhwd-nvidia-390xx-390.59-1  mkinitcpio-busybox-1.28.3-1.0
               modemmanager-1.8rc2+1+g7e949283-1.0  mpg123-1.25.10-1.0
               ms-office-online-18.04.4-1  mypaint-brushes-1.3.0-2.0
               nano-2.9.7-1.0  ndctl-60.3-1.0  neon-0.30.2-3.0
               net-snmp-5.7.3-8.0  networkmanager-1.10.8-1.0
               networkmanager-openvpn-1.8.2-1.0  networkmanager-pptp-1.2.6-1.0
               nss-3.37.1-1.0  ntp-4.2.8.p11-2.0  openal-1.18.2-2.0
               openssh-7.7p1-1.0  openssl-1.1.0.h-1.0  openssl-1.0-1.0.2.o-1.0
               openvpn-2.4.6-1.0  os-prober-1.76-2  pacman-mirrors-4.10.1-3
               pam-1.3.0-2.0  pamac-6.3.1-1  pango-1.42.1-1.0  pcre-8.42-1.0
               pcsclite-1.8.23-3.0  perl-5.26.2-1.0  perl-error-0.17026-1.0
               perl-file-basedir-0.08-1.0  perl-mailtools-2.20-1.0
               perl-timedate-2.30-4  perl-uri-1.74-1.0  pinentry-1.1.0-3.0
               polkit-0.114-1.1  poppler-0.64.0-1.0  poppler-data-0.4.9-1.0
               poppler-glib-0.64.0-1.0  poppler-qt5-0.64.0-1.0
               procps-ng-3.3.14-1.2  pygobject-devel-3.28.2-1.0
               pyqt5-common-5.10.1-2.0  python-3.6.5-3.0
               python-cairo-1.17.0-1.0  python-gobject-3.28.2-1.0
               python-jade-application-kit-1.3.5-1  python-packaging-17.1-1.0
               python-pexpect-4.5.0-1.0  python-pillow-5.1.0-1.0
               python-psutil-5.4.5-1.0  python-pyqt5-5.10.1-2.0
               python-setuptools-1:39.2.0-1.0  python-xdg-0.26-1.0
               python2-2.7.15-1.0  python2-cairo-1.17.0-1.0
               qpdfview-0.4.17beta1-6.0  qt5-base-5.10.1-8.0
               qt5-styleplugins-5.0.0.20170311-6.0  qt5-x11extras-5.10.1-1.0
               qt5ct-0.35-2.0  randrproto-1.5.0-1 [removal]  raptor-2.0.15-8.0
               recordproto-1.14.2-2 [removal]  renderproto-0.11.1-3 [removal]
               s-nail-14.9.10-1.0  samba-4.8.1-1.1
               scrnsaverproto-1.2.2-2 [removal]  sdl2-2.0.8-8.0  sed-4.5-1.0
               smbclient-4.8.1-1.1  spectre-meltdown-checker-0.37-1
               sqlite-3.23.1-1.0  srt-1.3.0-2.0  subversion-1.10.0-2.0
               systemd-238.76-1  systemd-sysvcompat-238.76-1  talloc-2.1.13-1.0
               tcl-8.6.8-3.0  thin-provisioning-tools-0.7.6-1.0
               thunar-1.6.15-1.0  tslib-1.16-1.0  ttf-inconsolata-1:2.0.0.1-3.0
               tumbler-0.2.1-1.0  twolame-0.3.13-8.0  tzdata-2018e-1.0
               unrar-1:5.6.4-1.0  util-linux-2.32-3.0
               vertex-maia-themes-20180429-1  videoproto-2.3.3-1 [removal]
               vlc-3.0.2-1.0  vte-common-0.52.2-1.0  vte3-0.52.2-1.0
               vulkan-icd-loader-1.1.73.0-1.0  vulkan-intel-18.0.4-1.0
               vulkan-radeon-18.0.4-1.0  wayland-1.15.0-1.1
               wayland-protocols-1.14-1.0  webkit2gtk-2.20.2-1.0
               wget-1.19.5-1.0  woff2-1.0.2-1.0  xdg-user-dirs-0.17-1.0
               xdg-utils-1.1.3-1.0  xextproto-7.3.0-1 [removal]
               xf86-input-libinput-0.27.1-1.0  xf86-video-amdgpu-18.0.1-2.0
               xf86-video-ati-1:18.0.1-2.0
               xf86-video-intel-1:2.99.917+831+ge7bfc906-1.0
               xf86-video-nouveau-1.0.15-3.0  xf86miscproto-0.9.3-1 [removal]
               xf86vidmodeproto-2.3.1-3 [removal]
               xfce4-cpufreq-plugin-1.2.0-1.0
               xfce4-pulseaudio-plugin-0.4.1-1.1  xfce4-screenshooter-1.9.2-1.0
               xfce4-sensors-plugin-1.3.0-1.0  xfce4-terminal-0.8.7.4-1.0
               xfce4-verve-plugin-2.0.0-1.0  xfce4-whiskermenu-plugin-2.2.0-1.0
               xineramaproto-1.2.1-3 [removal]  xkeyboard-config-2.23.1-3.0
               xorg-server-1.20.0-2.0  xorg-server-common-1.20.0-2.0
               xorgproto-2018.4-1.0  xproto-7.0.31-1 [removal]  xz-5.2.4-1.0
               yelp-3.28.1-1.0  yelp-xsl-3.28.0-1.0  zsh-5.5.1-1.0
               zstd-1.3.4-1.0

Total Installed Size:  3079.05 MiB
Net Upgrade Size:       234.52 MiB

:: Proceed with installation? [Y/n] y
(304/304) checking keys in keyring                 [######################] 100%
(304/304) checking package integrity               [######################] 100%
(304/304) loading package files                    [######################] 100%
(304/304) checking for file conflicts              [######################] 100%
(321/321) checking available disk space            [######################] 100%
:: Processing package changes...
( 1/17) removing gnome-themes-standard             [######################] 100%
( 2/17) removing xineramaproto                     [######################] 100%
( 3/17) removing xf86vidmodeproto                  [######################] 100%
( 4/17) removing xf86miscproto                     [######################] 100%
( 5/17) removing videoproto                        [######################] 100%
( 6/17) removing scrnsaverproto                    [######################] 100%
( 7/17) removing renderproto                       [######################] 100%
( 8/17) removing recordproto                       [######################] 100%
( 9/17) removing randrproto                        [######################] 100%
(10/17) removing kbproto                           [######################] 100%
(11/17) removing inputproto                        [######################] 100%
(12/17) removing fontsproto                        [######################] 100%
(13/17) removing damageproto                       [######################] 100%
(14/17) removing compositeproto                    [######################] 100%
(15/17) removing fixesproto                        [######################] 100%
(16/17) removing xproto                            [######################] 100%
(17/17) removing xextproto                         [######################] 100%
(  1/304) upgrading linux-api-headers              [######################] 100%
(  2/304) upgrading tzdata                         [######################] 100%
(  3/304) upgrading filesystem                     [######################] 100%
warning: /etc/fstab installed as /etc/fstab.pacnew
warning: /etc/group installed as /etc/group.pacnew
warning: /etc/hosts installed as /etc/hosts.pacnew
warning: /etc/passwd installed as /etc/passwd.pacnew
warning: /etc/resolv.conf installed as /etc/resolv.conf.pacnew
warning: /etc/shells installed as /etc/shells.pacnew
warning: /etc/gshadow installed as /etc/gshadow.pacnew
warning: /etc/shadow installed as /etc/shadow.pacnew
warning: /etc/crypttab installed as /etc/crypttab.pacnew
(  4/304) upgrading glibc                          [######################] 100%
warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
Generating locales...
  en_CA.UTF-8... done
  en_US.UTF-8... done
Generation complete.
(  5/304) upgrading gcc-libs                       [######################] 100%
(  6/304) upgrading pcre                           [######################] 100%
(  7/304) upgrading libutil-linux                  [######################] 100%
(  8/304) upgrading glib2                          [######################] 100%
New optional dependencies for glib2
    python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report
    [installed]
(  9/304) upgrading e2fsprogs                      [######################] 100%
( 10/304) upgrading perl                           [######################] 100%
( 11/304) upgrading openssl                        [######################] 100%
( 12/304) upgrading libldap                        [######################] 100%
( 13/304) upgrading krb5                           [######################] 100%
( 14/304) upgrading libtirpc                       [######################] 100%
( 15/304) upgrading pam                            [######################] 100%
( 16/304) upgrading libgpg-error                   [######################] 100%
( 17/304) upgrading xz                             [######################] 100%
( 18/304) upgrading libsystemd                     [######################] 100%
( 19/304) upgrading cryptsetup                     [######################] 100%
( 20/304) upgrading dbus                           [######################] 100%
( 21/304) upgrading libidn                         [######################] 100%
( 22/304) upgrading util-linux                     [######################] 100%
( 23/304) upgrading libusb                         [######################] 100%
( 24/304) upgrading systemd                        [######################] 100%
( 25/304) installing js52                          [######################] 100%
( 26/304) upgrading polkit                         [######################] 100%
( 27/304) upgrading accountsservice                [######################] 100%
( 28/304) upgrading acpid                          [######################] 100%
( 29/304) installing xorgproto                     [######################] 100%
( 30/304) upgrading icu                            [######################] 100%
( 31/304) upgrading libxml2                        [######################] 100%
( 32/304) upgrading gdk-pixbuf2                    [######################] 100%
( 33/304) upgrading harfbuzz                       [######################] 100%
( 34/304) upgrading freetype2                      [######################] 100%
( 35/304) upgrading fontconfig                     [######################] 100%
Rebuilding fontconfig cache... done.
( 36/304) upgrading cairo                          [######################] 100%
( 37/304) upgrading fribidi                        [######################] 100%
( 38/304) upgrading pango                          [######################] 100%
( 39/304) upgrading librsvg                        [######################] 100%
( 40/304) upgrading gtk-update-icon-cache          [######################] 100%
( 41/304) upgrading adwaita-icon-theme             [######################] 100%
( 42/304) upgrading alsa-lib                       [######################] 100%
( 43/304) upgrading alsa-plugins                   [######################] 100%
( 44/304) upgrading alsa-utils                     [######################] 100%
( 45/304) upgrading atk                            [######################] 100%
( 46/304) upgrading libepoxy                       [######################] 100%
( 47/304) upgrading dconf                          [######################] 100%
( 48/304) upgrading at-spi2-core                   [######################] 100%
( 49/304) upgrading at-spi2-atk                    [######################] 100%
( 50/304) upgrading wayland                        [######################] 100%
( 51/304) upgrading wayland-protocols              [######################] 100%
( 52/304) upgrading desktop-file-utils             [######################] 100%
( 53/304) upgrading libdrm                         [######################] 100%
( 54/304) upgrading llvm-libs                      [######################] 100%
( 55/304) upgrading lm_sensors                     [######################] 100%
( 56/304) upgrading mesa                           [######################] 100%
( 57/304) upgrading sqlite                         [######################] 100%
( 58/304) upgrading colord                         [######################] 100%
New optional dependencies for colord
    colord-sane: SANE support
( 59/304) upgrading avahi                          [######################] 100%
( 60/304) upgrading libcups                        [######################] 100%
( 61/304) upgrading libtool                        [######################] 100%
( 62/304) upgrading xkeyboard-config               [######################] 100%
( 63/304) upgrading gsettings-desktop-schemas      [######################] 100%
( 64/304) upgrading ca-certificates-mozilla        [######################] 100%
( 65/304) upgrading glib-networking                [######################] 100%
( 66/304) upgrading libsoup                        [######################] 100%
( 67/304) upgrading gtk3                           [######################] 100%
( 68/304) upgrading libidn2                        [######################] 100%
( 69/304) upgrading libpsl                         [######################] 100%
( 70/304) upgrading libnghttp2                     [######################] 100%
( 71/304) upgrading curl                           [######################] 100%
( 72/304) upgrading libsecret                      [######################] 100%
( 73/304) upgrading pinentry                       [######################] 100%
( 74/304) upgrading gnupg                          [######################] 100%
( 75/304) upgrading gpgme                          [######################] 100%
( 76/304) installing libnsl                        [######################] 100%
( 77/304) upgrading python                         [######################] 100%
( 78/304) upgrading pacman-mirrors                 [######################] 100%
( 79/304) upgrading appstream-glib                 [######################] 100%
( 80/304) upgrading archlinux-appstream-data       [######################] 100%
( 81/304) upgrading archlinux32-keyring            [######################] 100%
==> Appending keys from archlinux32.gpg...
gpg: WARNING: server 'gpg-agent' is older than us (2.2.5 < 2.2.7)
==> Locally signing trusted keys in keyring...
  -> Locally signing key CE0BDE71A759A87F23F0F7D8B61DBCE10901C163...
  -> Locally signing key 2FF1E976D6EB2E954A87DC14443904EC9EC51A8A...
  -> Locally signing key D92CDDC155BCC8F550B5FCEC30AB721FE7400FCD...
  -> Locally signing key A0B250C0FC9FC079EC04ADB7A50C0F20AEC3AF00...
  -> Locally signing key 194E37A47A4C671807BACB37B1117BC1094EA6E9...
==> Importing owner trust values...
==> Disabling revoked keys in keyring...
  -> Disabling key C3A8190912128B5A2E96C6023ED6490AEF932C8A...
  -> Disabling key 7C98C4C3DE926168DC46FBAA3D06644243BF68D3...
==> Updating trust database...
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   1  signed:  25  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:  25  signed:  83  trust: 0-, 0q, 0n, 25m, 0f, 0u
gpg: depth: 2  valid:  78  signed:  12  trust: 78-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2018-06-01
( 82/304) upgrading audacious-plugins              [######################] 100%
( 83/304) upgrading babl                           [######################] 100%
( 84/304) upgrading binutils                       [######################] 100%
( 85/304) upgrading libical                        [######################] 100%
( 86/304) upgrading bluez                          [######################] 100%
( 87/304) upgrading bluez-libs                     [######################] 100%
( 88/304) upgrading python-cairo                   [######################] 100%
( 89/304) upgrading gobject-introspection-runtime  [######################] 100%
( 90/304) upgrading pygobject-devel                [######################] 100%
( 91/304) upgrading python-gobject                 [######################] 100%
( 92/304) upgrading blueman                        [######################] 100%
New optional dependencies for blueman
    net-tools: Network Access Point (NAP) support
( 93/304) upgrading boost-libs                     [######################] 100%
( 94/304) upgrading breath-wallpaper               [######################] 100%
( 95/304) upgrading zstd                           [######################] 100%
( 96/304) upgrading btrfs-progs                    [######################] 100%
( 97/304) upgrading gsm                            [######################] 100%
( 98/304) upgrading libwebp                        [######################] 100%
( 99/304) installing libibus                       [######################] 100%
(100/304) upgrading sdl2                           [######################] 100%
(101/304) upgrading libx264                        [######################] 100%
(102/304) upgrading ffmpeg                         [######################] 100%
(103/304) upgrading chromaprint                    [######################] 100%
(104/304) upgrading cpupower                       [######################] 100%
(105/304) upgrading crda                           [######################] 100%
(106/304) upgrading nss                            [######################] 100%
(107/304) upgrading poppler                        [######################] 100%
(108/304) upgrading libmagick                      [######################] 100%
(109/304) upgrading imagemagick                    [######################] 100%
(110/304) upgrading liblouis                       [######################] 100%
(111/304) upgrading cups-filters                   [######################] 100%
(112/304) upgrading cups                           [######################] 100%
(113/304) upgrading dhcpcd                         [######################] 100%
(114/304) upgrading ffmpeg2.8                      [######################] 100%
(115/304) upgrading ffmpegthumbnailer              [######################] 100%
(116/304) upgrading file                           [######################] 100%
(117/304) upgrading foomatic-db-engine             [######################] 100%
(118/304) upgrading fuse-common                    [######################] 100%
(119/304) upgrading gcc                            [######################] 100%
New optional dependencies for gcc
    gcc-libs: for generating code for 32-bit ABI [installed]
(120/304) upgrading gconf                          [######################] 100%
(121/304) upgrading gcr                            [######################] 100%
(122/304) upgrading ghostscript                    [######################] 100%
(123/304) installing libgexiv2                     [######################] 100%
(124/304) installing gegl                          [######################] 100%
Optional dependencies for gegl
    libraw: raw plugin
    openexr: openexr plugin [installed]
    ffmpeg: ffmpeg plugin [installed]
    suitesparse: matting-levin plugin
    librsvg: svg plugin [installed]
    jasper: jasper plugin [installed]
    libtiff: tiff plugin [installed]
    lua: lua plugin [installed]
    lensfun: lens-correct plugin
(125/304) installing libmypaint                    [######################] 100%
(126/304) installing mypaint-brushes               [######################] 100%
(127/304) upgrading poppler-data                   [######################] 100%
(128/304) upgrading ilmbase                        [######################] 100%
(129/304) upgrading python2                        [######################] 100%
New optional dependencies for python2
    IDLE
    for
    tk:
(130/304) upgrading python2-cairo                  [######################] 100%
(131/304) upgrading gimp                           [######################] 100%
(132/304) upgrading perl-error                     [######################] 100%
(133/304) installing perl-timedate                 [######################] 100%
(134/304) installing perl-mailtools                [######################] 100%
(135/304) upgrading git                            [######################] 100%
(136/304) upgrading glibmm                         [######################] 100%
(137/304) upgrading openssh                        [######################] 100%
(138/304) upgrading gnome-keyring                  [######################] 100%
(139/304) upgrading gnome-menus                    [######################] 100%
(140/304) installing gnome-themes-extra            [######################] 100%
Optional dependencies for gnome-themes-extra
    gtk-engines: HighContrast GTK2 theme
(141/304) upgrading gstreamer                      [######################] 100%
(142/304) upgrading gst-plugins-base-libs          [######################] 100%
(143/304) upgrading gst-libav                      [######################] 100%
(144/304) upgrading libgme                         [######################] 100%
(145/304) upgrading libsrtp                        [######################] 100%
(146/304) upgrading openal                         [######################] 100%
(147/304) upgrading vulkan-icd-loader              [######################] 100%
(148/304) upgrading neon                           [######################] 100%
(149/304) installing libnice                       [######################] 100%
Optional dependencies for libnice
    gstreamer [installed]
(150/304) installing srt                           [######################] 100%
(151/304) upgrading gst-plugins-bad                [######################] 100%
(152/304) upgrading gst-plugins-base               [######################] 100%
(153/304) upgrading mpg123                         [######################] 100%
(154/304) installing twolame                       [######################] 100%
(155/304) upgrading procps-ng                      [######################] 100%
(156/304) upgrading imlib2                         [######################] 100%
(157/304) upgrading gst-plugins-good               [######################] 100%
(158/304) upgrading libx264-all                    [######################] 100%
(159/304) upgrading gst-plugins-ugly               [######################] 100%
(160/304) upgrading gtksourceview3                 [######################] 100%
(161/304) upgrading libbytesize                    [######################] 100%
(162/304) installing ndctl                         [######################] 100%
(163/304) upgrading libaio                         [######################] 100%
(164/304) upgrading thin-provisioning-tools        [######################] 100%
(165/304) upgrading libblockdev                    [######################] 100%
(166/304) upgrading gvfs                           [######################] 100%
(167/304) upgrading gvfs-afc                       [######################] 100%
(168/304) upgrading libgphoto2                     [######################] 100%
(169/304) upgrading gvfs-gphoto2                   [######################] 100%
(170/304) upgrading libmtp                         [######################] 100%
(171/304) upgrading gvfs-mtp                       [######################] 100%
(172/304) upgrading gvfs-nfs                       [######################] 100%
(173/304) upgrading libwbclient                    [######################] 100%
(174/304) upgrading talloc                         [######################] 100%
(175/304) upgrading ldb                            [######################] 100%
(176/304) upgrading smbclient                      [######################] 100%
(177/304) upgrading gvfs-smb                       [######################] 100%
(178/304) upgrading harfbuzz-icu                   [######################] 100%
(179/304) upgrading hdparm                         [######################] 100%
(180/304) upgrading net-snmp                       [######################] 100%
(181/304) upgrading hplip                          [######################] 100%
(182/304) upgrading htop                           [######################] 100%
(183/304) upgrading intel-ucode                    [######################] 100%
(184/304) upgrading sed                            [######################] 100%
(185/304) upgrading inxi                           [######################] 100%
(186/304) upgrading iproute2                       [######################] 100%
(187/304) upgrading xdg-utils                      [######################] 100%
(188/304) upgrading tslib                          [######################] 100%
(189/304) upgrading libwacom                       [######################] 100%
(190/304) upgrading libinput                       [######################] 100%
(191/304) upgrading qt5-base                       [######################] 100%
(192/304) upgrading kcoreaddons                    [######################] 100%
(193/304) upgrading kauth                          [######################] 100%
(194/304) upgrading kitemmodels                    [######################] 100%
(195/304) upgrading libatomic_ops                  [######################] 100%
(196/304) upgrading libcdr                         [######################] 100%
(197/304) upgrading libdvbpsi                      [######################] 100%
(198/304) upgrading libdvdcss                      [######################] 100%
(199/304) upgrading libe-book                      [######################] 100%
(200/304) upgrading libebml                        [######################] 100%
(201/304) upgrading libetonyek                     [######################] 100%
(202/304) upgrading libgsf                         [######################] 100%
(203/304) upgrading libgtop                        [######################] 100%
(204/304) upgrading libmatroska                    [######################] 100%
(205/304) upgrading libmm-glib                     [######################] 100%
(206/304) upgrading libmspub                       [######################] 100%
(207/304) upgrading libmwaw                        [######################] 100%
(208/304) upgrading libnetfilter_conntrack         [######################] 100%
(209/304) upgrading libnm                          [######################] 100%
(210/304) upgrading libnm-glib                     [######################] 100%
(211/304) upgrading libwps                         [######################] 100%
(212/304) upgrading libvisio                       [######################] 100%
(213/304) upgrading libzmf                         [######################] 100%
(214/304) upgrading raptor                         [######################] 100%
(215/304) upgrading libreoffice-still              [######################] 100%
(216/304) upgrading libsynctex                     [######################] 100%
(217/304) upgrading libva-mesa-driver              [######################] 100%
(218/304) upgrading lightdm                        [######################] 100%
(219/304) upgrading lightdm-gtk-greeter            [######################] 100%
warning: /etc/lightdm/lightdm-gtk-greeter.conf installed as /etc/lightdm/lightdm-gtk-greeter.conf.pacnew
(220/304) upgrading linux-firmware                 [######################] 100%
(221/304) upgrading mkinitcpio-busybox             [######################] 100%
(222/304) upgrading linux414                       [######################] 100%
(223/304) upgrading logrotate                      [######################] 100%
(224/304) upgrading man-db                         [######################] 100%
(225/304) upgrading man-pages                      [######################] 100%
(226/304) upgrading manjaro-browser-settings       [######################] 100%
(227/304) upgrading manjaro-hello                  [######################] 100%
(228/304) upgrading manjaro-release                [######################] 100%
(229/304) upgrading manjaro-settings-manager       [######################] 100%
(230/304) upgrading manjaro-settings-manager-n...  [######################] 100%
(231/304) upgrading qt5ct                          [######################] 100%
(232/304) upgrading qt5-styleplugins               [######################] 100%
(233/304) upgrading vertex-maia-themes             [######################] 100%

==> vertex-maia-themes:
  -> For seamless integration of Firefox and Palemoon browsers
  -> please copy the 'chrome' folder of the desired theme to your browser profile
  -> or create a symlink.
==> For example:
  -> 'ln -s /usr/share/themes/Palemoon/Vertex-Maia-Dark/chrome/ ~/.moonchild\ productions/pale\ moon/<xyz123>.default/chrome'
  
(234/304) upgrading manjaro-xfce-settings          [######################] 100%
(235/304) upgrading mesa-vdpau                     [######################] 100%
(236/304) installing mhwd-nvidia-390xx             [######################] 100%
(237/304) upgrading mhwd-db                        [######################] 100%
==> Updating Config: '/var/lib/mhwd/local/pci/video-linux'
(238/304) upgrading mhwd                           [######################] 100%
(239/304) upgrading modemmanager                   [######################] 100%
(240/304) installing brotli                        [######################] 100%
(241/304) installing woff2                         [######################] 100%
(242/304) upgrading webkit2gtk                     [######################] 100%
(243/304) upgrading python-jade-application-kit    [######################] 100%
(244/304) upgrading ms-office-online               [######################] 100%
(245/304) upgrading nano                           [######################] 100%
(246/304) upgrading openssl-1.0                    [######################] 100%
(247/304) upgrading networkmanager                 [######################] 100%
(248/304) upgrading openvpn                        [######################] 100%
(249/304) upgrading networkmanager-openvpn         [######################] 100%
(250/304) upgrading networkmanager-pptp            [######################] 100%
(251/304) upgrading ntp                            [######################] 100%
(252/304) upgrading os-prober                      [######################] 100%
(253/304) upgrading vte-common                     [######################] 100%
(254/304) upgrading vte3                           [######################] 100%
(255/304) upgrading pamac                          [######################] 100%
(256/304) upgrading pcsclite                       [######################] 100%
(257/304) upgrading perl-file-basedir              [######################] 100%
(258/304) upgrading perl-uri                       [######################] 100%
(259/304) upgrading poppler-glib                   [######################] 100%
(260/304) upgrading poppler-qt5                    [######################] 100%
(261/304) upgrading pyqt5-common                   [######################] 100%
(262/304) upgrading python-packaging               [######################] 100%
(263/304) upgrading python-pexpect                 [######################] 100%
(264/304) upgrading python-pillow                  [######################] 100%
(265/304) upgrading python-psutil                  [######################] 100%
(266/304) upgrading python-pyqt5                   [######################] 100%
(267/304) upgrading python-setuptools              [######################] 100%
(268/304) upgrading python-xdg                     [######################] 100%
(269/304) upgrading qpdfview                       [######################] 100%
(270/304) upgrading s-nail                         [######################] 100%
(271/304) upgrading samba                          [######################] 100%
warning: directory permissions differ on /var/lib/samba/private/
filesystem: 755  package: 700
(272/304) upgrading spectre-meltdown-checker       [######################] 100%
(273/304) installing libutf8proc                   [######################] 100%
(274/304) upgrading subversion                     [######################] 100%
New optional dependencies for subversion
    kwallet: for KWallet for auth credentials
(275/304) upgrading systemd-sysvcompat             [######################] 100%
(276/304) upgrading tcl                            [######################] 100%
(277/304) upgrading thunar                         [######################] 100%
(278/304) upgrading ttf-inconsolata                [######################] 100%
(279/304) upgrading tumbler                        [######################] 100%
(280/304) upgrading unrar                          [######################] 100%
(281/304) installing qt5-x11extras                 [######################] 100%
(282/304) installing libplacebo                    [######################] 100%
(283/304) upgrading vlc                            [######################] 100%
New optional dependencies for vlc
    aalib: ASCII art video output [installed]
    alsa-lib: ALSA audio output [installed]
    avahi: service discovery using bonjour protocol [installed]
    chromaprint: Chromaprint audio fingerprinter [installed]
    flac: Free Lossless Audio Codec plugin [installed]
    gst-plugins-base-libs: for libgst plugins [installed]
    gtk3: notification plugin [installed]
    jack: jack audio server [installed]
    kwallet: kwallet keystore
    libass: Subtitle support [installed]
    libavc1394: devices using the 1394ta AV/C [installed]
    libbluray: Blu-Ray video input [installed]
    libcaca: colored ASCII art video output [installed]
    libcdio: audio CD playback [installed]
    libdc1394: IEEE 1394 access plugin [installed]
    libdvdcss: decoding encrypted DVDs [installed]
    libdvdnav: DVD with navigation input module [installed]
    libdvdread: DVD input module [installed]
    libgme: Game Music Emu plugin [installed]
    libgoom2: Goom visualization
    libjpeg-turbo: JPEG support [installed]
    libkate: Kate codec [installed]
    libmicrodns: mDNS services discovery (chromecast etc)
    libmodplug: MOD output plugin [installed]
    libmtp: MTP devices discovery [installed]
    libnfs: NFS access [installed]
    libnotify: notification plugin [installed]
    libogg: Ogg and OggSpots codec [installed]
    libpng: PNG support [installed]
    libpulse: PulseAudio audio output [installed]
    librsvg: SVG plugin [installed]
    libsamplerate: audio Resampler [installed]
    libshout: shoutcast/icecast output plugin [installed]
    libsoxr: SoX audio Resampler [installed]
    libssh2: sftp access [installed]
    libsystemd: udev services discovery [installed]
    libtheora: theora codec [installed]
    libtiger: Tiger rendering for Kate streams [installed]
    libva-intel-driver: video backend intel
    libva-vdpau-driver: vdpau backend nvidia [installed]
    libvorbis: Vorbis decoder/encoder [installed]
    libvpx: VP8 and VP9 codec [installed]
    libx264: H264 encoding [installed]
    lirc: lirc control
    live-media: RTSP input
    lua-socket: http interface
    mpg123: mpg123 codec [installed]
    ncurses: ncurses interface [installed]
    opus: opus codec [installed]
    projectm: ProjectM visualisation
    protobuf: chromecast streaming
    sdl_image: SDL image support [installed]
    smbclient: SMB access plugin [installed]
    speex: Speex codec [installed]
    ttf-dejavu: subtitle font
    ttf-freefont: subtitle font 
    twolame: TwoLAME mpeg2 encoder plugin [installed]
    x265: HEVC/H.265 encoder [installed]
    zvbi: VBI/Teletext decoding [installed]
(284/304) upgrading vulkan-intel                   [######################] 100%
(285/304) upgrading vulkan-radeon                  [######################] 100%
(286/304) upgrading wget                           [######################] 100%
(287/304) upgrading xdg-user-dirs                  [######################] 100%
(288/304) upgrading xf86-input-libinput            [######################] 100%
(289/304) upgrading xf86-video-amdgpu              [######################] 100%
(290/304) upgrading xf86-video-ati                 [######################] 100%
(291/304) upgrading xf86-video-intel               [######################] 100%
(292/304) upgrading xf86-video-nouveau             [######################] 100%
(293/304) upgrading xfce4-cpufreq-plugin           [######################] 100%
(294/304) upgrading xfce4-pulseaudio-plugin        [######################] 100%
(295/304) upgrading xfce4-screenshooter            [######################] 100%
(296/304) upgrading xfce4-sensors-plugin           [######################] 100%
(297/304) upgrading xfce4-terminal                 [######################] 100%
(298/304) upgrading xfce4-verve-plugin             [######################] 100%
(299/304) upgrading xfce4-whiskermenu-plugin       [######################] 100%
(300/304) upgrading xorg-server-common             [######################] 100%
(301/304) upgrading xorg-server                    [######################] 100%
(302/304) upgrading yelp-xsl                       [######################] 100%
(303/304) upgrading yelp                           [######################] 100%
(304/304) upgrading zsh                            [######################] 100%
:: Running post-transaction hooks...
( 1/27) Updating linux414 module dependencies...
( 2/27) Updating linux414 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: 'default'
  -> -k /boot/vmlinuz-4.14-i686 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-i686.img
==> Starting build: 4.14.44-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.14-i686.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: 'fallback'
  -> -k /boot/vmlinuz-4.14-i686 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-i686-fallback.img -S autodetect
==> Starting build: 4.14.44-1-MANJARO
  -> Running build hook: [base]
==> ERROR: file not found: `'
==> ERROR: file not found: `'
==> ERROR: file not found: `'
/usr/lib/initcpio/functions: line 728: : No such file or directory
==> ERROR: Failed to read 
/usr/lib/initcpio/functions: line 728: : No such file or directory
==> ERROR: Failed to read 
/usr/lib/initcpio/functions: line 728: : No such file or directory
==> ERROR: Failed to read 
/usr/lib/initcpio/functions: line 728: : No such file or directory
==> ERROR: Failed to read 
/usr/lib/initcpio/functions: line 728: : No such file or directory
==> ERROR: Failed to read 
/usr/lib/initcpio/functions: line 728: : No such file or directory
==> ERROR: Failed to read 
/usr/lib/initcpio/functions: line 728: : No such file or directory
==> ERROR: Failed to read 
/usr/lib/initcpio/functions: line 728: : No such file or directory
==> ERROR: Failed to read 
==> WARNING: No modules were added to the image. This is probably not what you want.
==> Creating -compressed initcpio image: 
==> WARNING: errors were encountered during the build. The image may not be complete.
error: command failed to execute correctly
( 3/27) Updating Grub-Bootmenu
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found Intel Microcode image
Found linux image: /boot/vmlinuz-4.14-i686
Found initrd image: /boot/initramfs-4.14-i686.img
Found initrd fallback image: /boot/initramfs-4.14-i686-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
( 4/27) Warn about old perl modules
( 5/27) Updating fontconfig cache...
( 6/27) Probing GDK-Pixbuf loader modules...
( 7/27) Updating GIO module cache...
( 8/27) Compiling GSettings XML schema files...
( 9/27) Probing GTK3 input method modules...
(10/27) Updating icon theme caches...
(11/27) Reloading GVFS config...
(12/27) Creating background picture sym-links for XFCE...
'/usr/share/backgrounds/xfce/breath.png' -> '/usr/share/backgrounds/breath.png'
'/usr/share/backgrounds/xfce/manjarowall17_01.jpg' -> '/usr/share/backgrounds/manjarowall17_01.jpg'
'/usr/share/backgrounds/xfce/manjarowall17_02.jpg' -> '/usr/share/backgrounds/manjarowall17_02.jpg'
'/usr/share/backgrounds/xfce/manjarowall17_03.jpg' -> '/usr/share/backgrounds/manjarowall17_03.jpg'
'/usr/share/backgrounds/xfce/manjarowall17_04.jpg' -> '/usr/share/backgrounds/manjarowall17_04.jpg'
'/usr/share/backgrounds/xfce/manjarowall17_05.jpg' -> '/usr/share/backgrounds/manjarowall17_05.jpg'
'/usr/share/backgrounds/xfce/manjarowall17_06.jpg' -> '/usr/share/backgrounds/manjarowall17_06.jpg'
'/usr/share/backgrounds/xfce/manjarowall17_07.jpg' -> '/usr/share/backgrounds/manjarowall17_07.jpg'
'/usr/share/backgrounds/xfce/manjarowall17_08.jpg' -> '/usr/share/backgrounds/manjarowall17_08.jpg'
(13/27) Configuring pacman-mirrors ...
.: INFO Downloading mirrors from repo.manjaro.org
hint: use `pacman-mirrors` to generate and update your pacman mirrorlist.
(14/27) Updating journal message catalog...
(15/27) Reloading system manager configuration...
(16/27) Updating udev hardware database...
(17/27) Applying kernel sysctl settings...
(18/27) Creating system user accounts...
(19/27) Creating temporary files...
(20/27) Reloading device manager configuration...
(21/27) Arming ConditionNeedsUpdate...
(22/27) Updating the info directory file...
(23/27) Rebuilding certificate stores...
(24/27) Updating the desktop file MIME type cache...
(25/27) Updating the MIME type database...
(26/27) Updating the vlc plugin cache...
(27/27) Updating X fontdir indices...
# 

[Testing Update x32] 2018-05-17 to 26 - Xorg 1.20, GCC 8.1.0, rebuilds, kernels, NVIDIA EOL
#13

This is a x64 kernel.

How has this gotten in your i386/x32 system?
Can you remove it?


#14

I don’t see this on my i686 system so I don’t know what’s going on here.


#15

Well, if I knew the specific package that was downloaded as part of the i686 update, then I could. But, I don’t know which package has it.


#16

Here is what’s in the file /media/sda1/usr/lib/initcpio/functions

#!/bin/bash

parseopts() {
    local opt= optarg= i= shortopts=$1
    local -a longopts=() unused_argv=()

    shift
    while [[ $1 && $1 != '--' ]]; do
        longopts+=("$1")
        shift
    done
    shift

    longoptmatch() {
        local o longmatch=()
        for o in "${longopts[@]}"; do
            if [[ ${o%:} = "$1" ]]; then
                longmatch=("$o")
                break
            fi
            [[ ${o%:} = "$1"* ]] && longmatch+=("$o")
        done

        case ${#longmatch[*]} in
            1)
                # success, override with opt and return arg req (0 == none, 1 == required)
                opt=${longmatch%:}
                if [[ $longmatch = *: ]]; then
                    return 1
                else
                    return 0
                fi ;;
            0)
                # fail, no match found
                return 255 ;;
            *)
                # fail, ambiguous match
                printf "%s: option '%s' is ambiguous; possibilities:%s\n" "${0##*/}" \
                    "--$1" "$(printf " '%s'" "${longmatch[@]%:}")"
                return 254 ;;
        esac
    }

    while (( $# )); do
        case $1 in
            --) # explicit end of options
                shift
                break
                ;;
            -[!-]*) # short option
                for (( i = 1; i < ${#1}; i++ )); do
                    opt=${1:i:1}

                    # option doesn't exist
                    if [[ $shortopts != *$opt* ]]; then
                        printf "%s: invalid option -- '%s'\n" "${0##*/}" "$opt"
                        OPTRET=(--)
                        return 1
                    fi

                    OPTRET+=("-$opt")
                    # option requires optarg
                    if [[ $shortopts = *$opt:* ]]; then
                        # if we're not at the end of the option chunk, the rest is the optarg
                        if (( i < ${#1} - 1 )); then
                            OPTRET+=("${1:i+1}")
                            break
                        # if we're at the end, grab the the next positional, if it exists
                        elif (( i == ${#1} - 1 )) && [[ $2 ]]; then
                            OPTRET+=("$2")
                            shift
                            break
                        # parse failure
                        else
                            printf "%s: option '%s' requires an argument\n" "${0##*/}" "-$opt"
                            OPTRET=(--)
                            return 1
                        fi
                    fi
                done
                ;;
            --?*=*|--?*) # long option
                IFS='=' read -r opt optarg <<< "${1#--}"
                longoptmatch "$opt"
                case $? in
                    0)
                        if [[ $optarg ]]; then
                            printf "%s: option '--%s' doesn't allow an argument\n" "${0##*/}" "$opt"
                            OPTRET=(--)
                            return 1
                        else
                            OPTRET+=("--$opt")
                        fi
                        ;;
                    1)
                        # --longopt=optarg
                        if [[ $optarg ]]; then
                            OPTRET+=("--$opt" "$optarg")
                        # --longopt optarg
                        elif [[ $2 ]]; then
                            OPTRET+=("--$opt" "$2" )
                            shift
                        else
                            printf "%s: option '--%s' requires an argument\n" "${0##*/}" "$opt"
                            OPTRET=(--)
                            return 1
                        fi
                        ;;
                    254)
                        # ambiguous option -- error was reported for us by longoptmatch()
                        OPTRET=(--)
                        return 1
                        ;;
                    255)
                        # parse failure
                        printf "%s: unrecognized option '%s'\n" "${0##*/}" "--$opt"
                        OPTRET=(--)
                        return 1
                        ;;
                esac
                ;;
            *) # non-option arg encountered, add it as a parameter
                unused_argv+=("$1")
                ;;
        esac
        shift
    done

    # add end-of-opt terminator and any leftover positional parameters
    OPTRET+=('--' "${unused_argv[@]}" "$@")
    unset longoptmatch

    return 0
}

kver() {
    # this is intentionally very loose. only ensure that we're
    # dealing with some sort of string that starts with something
    # resembling dotted decimal notation. remember that there's no
    # requirement for CONFIG_LOCALVERSION to be set.
    local kver re='^[[:digit:]]+(\.[[:digit:]]+)+'

    # scrape the version out of the kernel image. locate the offset
    # to the version string by reading 2 bytes out of image at at
    # address 0x20E. this leads us to a string of, at most, 128 bytes.
    # read the first word from this string as the kernel version.
    local offset=$(hexdump -s 526 -n 2 -e '"%0d"' "$1")
    [[ $offset = +([0-9]) ]] || return 1

    read kver _ < \
        <(dd if="$1" bs=1 count=127 skip=$(( offset + 0x200 )) 2>/dev/null)

    [[ $kver =~ $re ]] || return 1

    printf '%s' "$kver"
}

plain() {
    local mesg=$1; shift
    printf "    $_color_bold$mesg$_color_none\n" "$@" >&1
}

quiet() {
    (( _optquiet )) || plain "$@"
}

msg() {
    local mesg=$1; shift
    printf "$_color_green==>$_color_none $_color_bold$mesg$_color_none\n" "$@" >&1
}

msg2() {
    local mesg=$1; shift
    printf "  $_color_blue->$_color_none $_color_bold$mesg$_color_none\n" "$@" >&1
}

warning() {
    local mesg=$1; shift
    printf "$_color_yellow==> WARNING:$_color_none $_color_bold$mesg$_color_none\n" "$@" >&2
}

error() {
    local mesg=$1; shift
    printf "$_color_red==> ERROR:$_color_none $_color_bold$mesg$_color_none\n" "$@" >&2
    return 1
}

die() {
    error "$@"
    cleanup 1
}

map() {
    local r=0
    for _ in "${@:2}"; do
        "$1" "$_" || (( $# > 255 ? r=1 : ++r ))
    done
    return $r
}

arrayize_config() {
    set -f
    [[ ${MODULES@a} != *a* ]] && MODULES=($MODULES)
    [[ ${BINARIES@a} != *a* ]] && BINARIES=($BINARIES)
    [[ ${FILES@a} != *a* ]] && FILES=($FILES)
    [[ ${HOOKS@a} != *a* ]] && HOOKS=($HOOKS)
    [[ ${COMPRESSION_OPTIONS@a} != *a* ]] && COMPRESSION_OPTIONS=($COMPRESSION_OPTIONS)
    set +f
}

in_array() {
    # Search for an element in an array.
    #   $1: needle
    #   ${@:2}: haystack

    local item= needle=$1; shift

    for item in "$@"; do
        [[ $item = $needle ]] && return 0 # Found
    done
    return 1 # Not Found
}

index_of() {
    # get the array index of an item. sets the global var _idx with
    # index and returns 0 if found, otherwise returns 1.
    local item=$1; shift

    for (( _idx=1; _idx <= $#; _idx++ )); do
        if [[ $item = ${!_idx} ]]; then
            (( --_idx ))
            return 0
        fi
    done

    # not found
    unset _idx
    return 1
}

funcgrep() {
    awk -v funcmatch="$1" '
        /^[[:space:]]*[[:alnum:]_]+[[:space:]]*\([[:space:]]*\)/ {
            match($1, funcmatch)
            print substr($1, RSTART, RLENGTH)
        }' "$2"
}

list_hookpoints() {
    local funcs script

    script=$(PATH=$_d_hooks type -P "$1") || return 0

    mapfile -t funcs < <(funcgrep '^run_[[:alnum:]_]+' "$script")

    echo
    msg "This hook has runtime scripts:"
    in_array run_earlyhook "${funcs[@]}" && msg2 "early hook"
    in_array run_hook "${funcs[@]}" && msg2 "pre-mount hook"
    in_array run_latehook "${funcs[@]}" && msg2 "post-mount hook"
    in_array run_cleanuphook "${funcs[@]}" && msg2 "cleanup hook"
}

modprobe() {
    command modprobe -d "$_optmoduleroot" -S "$KERNELVERSION" "$@"
}

auto_modules() {
    # Perform auto detection of modules via sysfs.

    local mods=

    mapfile -t mods < <(find /sys/devices -name uevent \
        -exec sort -u {} + | awk -F= '$1 == "MODALIAS" && !_[$0]++')
    mapfile -t mods < <(modprobe -qaR "${mods[@]#MODALIAS=}")

    (( ${#mods[*]} )) && printf "%s\n" "${mods[@]//-/_}"
}

all_modules() {
    # Add modules to the initcpio, filtered by grep.
    #   $@: filter arguments to grep
    #   -f FILTER: ERE to filter found modules

    local -i count=0
    local mod= OPTIND= OPTARG= filter=()

    while getopts ':f:' flag; do
        case $flag in f) filter+=("$OPTARG") ;; esac
    done
    shift $(( OPTIND - 1 ))

    while read -r -d '' mod; do
        (( ++count ))

        for f in "${filter[@]}"; do
            [[ $mod =~ $f ]] && continue 2
        done

        mod=${mod##*/}
        mod="${mod%.ko*}"
        printf '%s\n' "${mod//-/_}"
    done < <(find "$_d_kmoduledir" -name '*.ko*' -print0 2>/dev/null | grep -EZz "$@")

    (( count ))
}

add_all_modules() {
    # Add modules to the initcpio.
    #   $@: arguments to all_modules

    local mod mods

    mapfile -t mods < <(all_modules "$@")
    map add_module "${mods[@]}"

    return $(( !${#mods[*]} ))
}

add_checked_modules() {
    # Add modules to the initcpio, filtered by the list of autodetected
    # modules.
    #   $@: arguments to all_modules

    local mod mods

    if (( ${#_autodetect_cache[*]} )); then
        mapfile -t mods < <(all_modules "$@" | grep -xFf <(printf '%s\n' "${!_autodetect_cache[@]}"))
    else
        mapfile -t mods < <(all_modules "$@")
    fi

    map add_module "${mods[@]}"

    return $(( !${#mods[*]} ))
}

add_firmware() {
    # add a firmware file to the image.
    #   $1: firmware path fragment

    local fw fwpath r=1

    for fw; do
        for fwpath in "${_d_firmware[@]}"; do
            if [[ -f $fwpath/$fw ]]; then
                add_file "$fwpath/$fw" "$fwpath/$fw" 644 && r=0
                break
            fi
        done
    done

    return $r
}

add_module() {
    # Add a kernel module to the initcpio image. Dependencies will be
    # discovered and added.
    #   $1: module name

    local target= module= softdeps= deps= field= value= firmware=()
    local ign_errors=0 found=0

    [[ $KERNELVERSION == none ]] && return 0

    if [[ $1 = *\? ]]; then
        ign_errors=1
        set -- "${1%?}"
    fi

    target=${1%.ko*} target=${target//-/_}

    # skip expensive stuff if this module has already been added
    (( _addedmodules["$target"] == 1 )) && return

    while IFS=':= ' read -r -d '' field value; do
        case "$field" in
            filename)
                found=1
                module=${value##*/} module=${module%.ko*}
                quiet "adding module: %s" "$module"
                _modpaths["$value"]=1
                _addedmodules["${module//-/_}"]=1
                ;;
            depends)
                IFS=',' read -r -a deps <<< "$value"
                map add_module "${deps[@]}"
                ;;
            firmware)
                firmware+=("$value")
                ;;
            softdep)
                read -ra softdeps <<<"$value"
                for module in "${softdeps[@]}"; do
                    [[ $module == *: ]] && continue
                    add_module "$module?"
                done
                ;;
        esac
    done < <(modinfo -b "$_optmoduleroot" -k "$KERNELVERSION" -0 "$target" 2>/dev/null)

    if (( !found )); then
        (( ign_errors || _addedmodules["$target"] )) && return 0
        error "module not found: \`%s'" "$target"
        return 1
    fi

    if (( ${#firmware[*]} )); then
        add_firmware "${firmware[@]}" ||
            warning 'Possibly missing firmware for module: %s' "$target"
    fi

    # handle module quirks
    case $target in
        fat)
            add_module "nls_cp437?"
            add_module "nls_iso8859-1?"
            ;;
        ocfs2)
            add_module "configfs?"
            ;;
        btrfs)
            add_module "libcrc32c?"
            ;;
        f2fs)
            add_module "crypto-crc32?"
            ;;
        ext4)
            add_module "crypto-crc32c?"
            ;;
    esac
}

add_full_dir() {
    # Add a directory and all its contents, recursively, to the initcpio image.
    # No parsing is performed and the contents of the directory is added as is.
    #   $1: path to directory
    #   $2: glob pattern to filter file additions (optional)
    #   $3: path prefix that will be stripped off from the image path (optional)

    local f= filter=${2:-*} strip_prefix=$3

    if [[ -n $1 && -d $1 ]]; then
        add_dir "$1"

        for f in "$1"/*; do
            if [[ -L $f ]]; then
                if [[ $f = $filter ]]; then
                    add_symlink "${f#$strip_prefix}" "$(readlink "$f")"
                fi
            elif [[ -d $f ]]; then
                add_full_dir "$f" "$filter" "$strip_prefix"
            elif [[ -f $f ]]; then
                if [[ $f = $filter ]]; then
                    add_file "$f" "${f#$strip_prefix}"
                fi
            fi
        done
    fi
}

add_dir() {
    # add a directory (with parents) to $BUILDROOT
    #   $1: pathname on initcpio
    #   $2: mode (optional)

    if [[ -z $1 || $1 != /?* ]]; then
        return 1
    fi

    local path=$1 mode=${2:-755}

    if [[ -d $BUILDROOT$1 ]]; then
        # ignore dir already exists
        return 0
    fi

    quiet "adding dir: %s" "$path"
    command install -dm$mode "$BUILDROOT$path"
}

add_symlink() {
    # Add a symlink to the initcpio image. There is no checking done
    # to ensure that the target of the symlink exists.
    #   $1: pathname of symlink on image
    #   $2: absolute path to target of symlink (optional, can be read from $1)

    local name=$1 target=$2

    (( $# == 1 || $# == 2 )) || return 1

    if [[ -z $target ]]; then
        target=$(readlink -f "$name")
        if [[ -z $target ]]; then
            error 'invalid symlink: %s' "$name"
            return 1
        fi
    fi

    add_dir "${name%/*}"

    if [[ -L $BUILDROOT$1 ]]; then
        quiet "overwriting symlink %s -> %s" "$name" "$target"
    else
        quiet "adding symlink: %s -> %s" "$name" "$target"
    fi
    ln -sfn "$target" "$BUILDROOT$name"
}

add_file() {
    # Add a plain file to the initcpio image. No parsing is performed and only
    # the singular file is added.
    #   $1: path to file
    #   $2: destination on initcpio (optional, defaults to same as source)
    #   $3: mode

    (( $# )) || return 1

    # determine source and destination
    local src=$1 dest=${2:-$1} mode=

    if [[ ! -f $src ]]; then
        error "file not found: \`%s'" "$src"
        return 1
    fi

    mode=${3:-$(stat -c %a "$src")}
    if [[ -z $mode ]]; then
        error "failed to stat file: \`%s'." "$src"
        return 1
    fi

    if [[ -e $BUILDROOT$dest ]]; then
        quiet "overwriting file: %s" "$dest"
    else
        quiet "adding file: %s" "$dest"
    fi
    command install -Dm$mode "$src" "$BUILDROOT$dest"
}

add_runscript() {
    # Adds a runtime script to the initcpio image. The name is derived from the
    # script which calls it as the basename of the caller.

    local funcs fn script hookname=${BASH_SOURCE[1]##*/}

    if ! script=$(PATH=$_d_hooks type -P "$hookname"); then
        error "runtime script for \`%s' not found" "$hookname"
        return
    fi

    add_file "$script" "/hooks/$hookname" 755

    mapfile -t funcs < <(funcgrep '^run_[[:alnum:]_]+' "$script")

    for fn in "${funcs[@]}"; do
        case $fn in
            run_earlyhook)
                _runhooks['early']+=" $hookname"
                ;;
            run_hook)
                _runhooks['hooks']+=" $hookname"
                ;;
            run_latehook)
                _runhooks['late']+=" $hookname"
                ;;
            run_cleanuphook)
                _runhooks['cleanup']="$hookname ${_runhooks['cleanup']}"
                ;;
        esac
    done
}

add_binary() {
    # Add a binary file to the initcpio image. library dependencies will
    # be discovered and added.
    #   $1: path to binary
    #   $2: destination on initcpio (optional, defaults to same as source)

    local -a sodeps
    local line= regex= binary= dest= mode= sodep= resolved=

    if [[ ${1:0:1} != '/' ]]; then
        binary=$(type -P "$1")
    else
        binary=$1
    fi

    if [[ ! -f $binary ]]; then
        error "file not found: \`%s'" "$1"
        return 1
    fi

    dest=${2:-$binary}
    mode=$(stat -c %a "$binary")

    # always add the binary itself
    add_file "$binary" "$dest" "$mode"

    # negate this so that the RETURN trap is not fired on non-binaries
    ! lddout=$(ldd "$binary" 2>/dev/null) && return 0

    # resolve sodeps
    regex='^(|.+ )(/.+) \(0x[a-fA-F0-9]+\)'
    while read -r line; do
        if [[ $line =~ $regex ]]; then
            sodep=${BASH_REMATCH[2]}
        elif [[ $line = *'not found' ]]; then
            error "binary dependency \`%s' not found for \`%s'" "${line%% *}" "$1"
            (( ++_builderrors ))
            continue
        fi

        if [[ -f $sodep && ! -e $BUILDROOT$sodep ]]; then
            add_file "$sodep" "$sodep" "$(stat -Lc %a "$sodep")"
        fi
    done <<< "$lddout"

    return 0
}

parse_config() {
    # parse key global variables set by the config file.

    map add_module "${MODULES[@]}"
    map add_binary "${BINARIES[@]}"
    map add_file "${FILES[@]}"

    tee "$BUILDROOT/buildconfig" < "$1" | {
        # When MODULES is not an array (but instead implicitly converted at
        # startup), sourcing the config causes the string value of MODULES
        # to be assigned as MODULES[0]. Avoid this by explicitly unsetting
        # MODULES before re-sourcing the config.
        unset MODULES

        . /dev/stdin

        # arrayize MODULES if necessary.
        [[ ${MODULES@a} != *a* ]] && read -ra MODULES <<<"${MODULES//-/_}"

        for mod in "${MODULES[@]%\?}"; do
            mod=${mod//-/_}
            # only add real modules (2 == builtin)
            (( _addedmodules["$mod"] == 1 )) && add+=("$mod")
        done
        (( ${#add[*]} )) && printf 'MODULES="%s"\n' "${add[*]}"

        printf '%s="%s"\n' \
            'EARLYHOOKS' "${_runhooks['early']# }" \
            'HOOKS' "${_runhooks['hooks']# }" \
            'LATEHOOKS' "${_runhooks['late']# }" \
            'CLEANUPHOOKS' "${_runhooks['cleanup']% }"
    } >"$BUILDROOT/config"
}

initialize_buildroot() {
    # creates a temporary directory for the buildroot and initialize it with a
    # basic set of necessary directories and symlinks

    local workdir= kernver=$1 arch=$(uname -m) buildroot

    if ! workdir=$(mktemp -d --tmpdir mkinitcpio.XXXXXX); then
        error 'Failed to create temporary working directory in %s' "${TMPDIR:-/tmp}"
        return 1
    fi
    buildroot=${2:-$workdir/root}

    if [[ ! -w ${2:-$workdir} ]]; then
        error 'Unable to write to build root: %s' "$buildroot"
        return 1
    fi

    # base directory structure
    install -dm755 "$buildroot"/{new_root,proc,sys,dev,run,tmp,etc,usr/{local,lib,bin}}
    ln -s "usr/lib" "$buildroot/lib"
    ln -s "../lib"  "$buildroot/usr/local/lib"
    ln -s "bin"     "$buildroot/usr/sbin"
    ln -s "usr/bin" "$buildroot/bin"
    ln -s "usr/bin" "$buildroot/sbin"
    ln -s "../bin"  "$buildroot/usr/local/bin"
    ln -s "../bin"  "$buildroot/usr/local/sbin"

    case $arch in
        x86_64)
            ln -s "lib"     "$buildroot/usr/lib64"
            ln -s "usr/lib" "$buildroot/lib64"
            ;;
    esac

    # mkinitcpio version stamp
    printf '%s' "$version" >"$buildroot/VERSION"

    # kernel module dir
    [[ $kernver != none ]] && install -dm755 "$buildroot/usr/lib/modules/$kernver/kernel"

    # mount tables
    ln -s /proc/self/mounts "$buildroot/etc/mtab"
    >"$buildroot/etc/fstab"

    # indicate that this is an initramfs
    >"$buildroot/etc/initrd-release"

    # add a blank ld.so.conf to keep ldconfig happy
    >"$buildroot/etc/ld.so.conf"

    printf '%s' "$workdir"
}

run_build_hook() {
    local hook=$1 script= resolved=
    local MODULES=() BINARIES=() FILES=() SCRIPT=

    # find script in install dirs
    if ! script=$(PATH=$_d_install type -P "$hook"); then
        error "Hook '$hook' cannot be found"
        return 1
    fi

    # check for deprecation
    if resolved=$(readlink "$script") && [[ ${script##*/} != "${resolved##*/}" ]]; then
        warning "Hook '%s' is deprecated. Replace it with '%s' in your config" \
            "${script##*/}" "${resolved##*/}"
        script=$resolved
    fi

    # source
    unset -f build
    if ! . "$script"; then
        error 'Failed to read %s' "$script"
        return 1
    fi

    if ! declare -f build >/dev/null; then
        error 'Hook '$script' has no build function'
        return 1
    fi

    # run
    if (( _optquiet )); then
        msg2 "Running build hook: [%s]" "${script##*/}"
    else
        msg2 "Running build hook: [%s]" "$script"
    fi
    build

    # if we made it this far, return successfully. Hooks can
    # do their own error catching if it's severe enough, and
    # we already capture errors from the add_* functions.
    return 0
}

try_enable_color() {
    local colors

    if ! colors=$(tput colors 2>/dev/null); then
        warning "Failed to enable color. Check your TERM environment variable"
        return
    fi

    if (( colors > 0 )) && tput setaf 0 &>/dev/null; then
        _color_none=$(tput sgr0)
        _color_bold=$(tput bold)
        _color_blue=$_color_bold$(tput setaf 4)
        _color_green=$_color_bold$(tput setaf 2)
        _color_red=$_color_bold$(tput setaf 1)
        _color_yellow=$_color_bold$(tput setaf 3)
    fi
}

install_modules() {
    local m moduledest=$BUILDROOT/lib/modules/$KERNELVERSION
    local -a xz_comp gz_comp

    [[ $KERNELVERSION == none ]] && return 0

    if (( $# == 0 )); then
        warning "No modules were added to the image. This is probably not what you want."
        return 0
    fi

    cp "$@" "$moduledest/kernel"

    # unzip modules prior to recompression
    for m in "$@"; do
        case $m in
            *.xz)
                xz_comp+=("$moduledest/kernel/${m##*/}")
                ;;
            *.gz)
                gz_comp+=("$moduledest/kernel/${m##*/}")
                ;;
        esac
    done
    (( ${#xz_comp[*]} )) && xz -d "${xz_comp[@]}"
    (( ${#gz_comp[*]} )) && gzip -d "${gz_comp[@]}"

    msg "Generating module dependencies"
    install -m644 -t "$moduledest" "$_d_kmoduledir"/modules.builtin

    # we install all modules into kernel/, making the .order file incorrect for
    # the module tree. munge it, so that we have an accurate index. This avoids
    # some rare and subtle issues with module loading choices when an alias
    # resolves to multiple modules, only one of which can claim a device.
    awk -F'/' '{ print "kernel/" $NF }' \
        "$_d_kmoduledir"/modules.order >"$moduledest/modules.order"

    depmod -b "$BUILDROOT" "$KERNELVERSION"

    # remove all non-binary module.* files (except devname for on-demand module loading)
    rm "$moduledest"/modules.!(*.bin|devname|softdep)
}

# vim: set ft=sh ts=4 sw=4 et:

I’m using Knoppix8.1 Live via USB stick to peer into the problem machine and to use clonezilla to restore the image for manjaro-xfce-17.1.7-rc1-testing-i686.iso that had kernel 4.14.29-1 that was working - as in I could login via graphics mode.

Will re-image and check if that file exists there…


#17

Just re-imaged back to k4.14.29-1 (manjaro-xfce-17.1.7-rc1-testing-i686.iso) and I found that functions file:

The contents of that file:

#!/bin/bash

parseopts() {
    local opt= optarg= i= shortopts=$1
    local -a longopts=() unused_argv=()

    shift
    while [[ $1 && $1 != '--' ]]; do
        longopts+=("$1")
        shift
    done
    shift

    longoptmatch() {
        local o longmatch=()
        for o in "${longopts[@]}"; do
            if [[ ${o%:} = "$1" ]]; then
                longmatch=("$o")
                break
            fi
            [[ ${o%:} = "$1"* ]] && longmatch+=("$o")
        done

        case ${#longmatch[*]} in
            1)
                # success, override with opt and return arg req (0 == none, 1 == required)
                opt=${longmatch%:}
                if [[ $longmatch = *: ]]; then
                    return 1
                else
                    return 0
                fi ;;
            0)
                # fail, no match found
                return 255 ;;
            *)
                # fail, ambiguous match
                printf "%s: option '%s' is ambiguous; possibilities:%s\n" "${0##*/}" \
                    "--$1" "$(printf " '%s'" "${longmatch[@]%:}")"
                return 254 ;;
        esac
    }

    while (( $# )); do
        case $1 in
            --) # explicit end of options
                shift
                break
                ;;
            -[!-]*) # short option
                for (( i = 1; i < ${#1}; i++ )); do
                    opt=${1:i:1}

                    # option doesn't exist
                    if [[ $shortopts != *$opt* ]]; then
                        printf "%s: invalid option -- '%s'\n" "${0##*/}" "$opt"
                        OPTRET=(--)
                        return 1
                    fi

                    OPTRET+=("-$opt")
                    # option requires optarg
                    if [[ $shortopts = *$opt:* ]]; then
                        # if we're not at the end of the option chunk, the rest is the optarg
                        if (( i < ${#1} - 1 )); then
                            OPTRET+=("${1:i+1}")
                            break
                        # if we're at the end, grab the the next positional, if it exists
                        elif (( i == ${#1} - 1 )) && [[ $2 ]]; then
                            OPTRET+=("$2")
                            shift
                            break
                        # parse failure
                        else
                            printf "%s: option '%s' requires an argument\n" "${0##*/}" "-$opt"
                            OPTRET=(--)
                            return 1
                        fi
                    fi
                done
                ;;
            --?*=*|--?*) # long option
                IFS='=' read -r opt optarg <<< "${1#--}"
                longoptmatch "$opt"
                case $? in
                    0)
                        if [[ $optarg ]]; then
                            printf "%s: option '--%s' doesn't allow an argument\n" "${0##*/}" "$opt"
                            OPTRET=(--)
                            return 1
                        else
                            OPTRET+=("--$opt")
                        fi
                        ;;
                    1)
                        # --longopt=optarg
                        if [[ $optarg ]]; then
                            OPTRET+=("--$opt" "$optarg")
                        # --longopt optarg
                        elif [[ $2 ]]; then
                            OPTRET+=("--$opt" "$2" )
                            shift
                        else
                            printf "%s: option '--%s' requires an argument\n" "${0##*/}" "$opt"
                            OPTRET=(--)
                            return 1
                        fi
                        ;;
                    254)
                        # ambiguous option -- error was reported for us by longoptmatch()
                        OPTRET=(--)
                        return 1
                        ;;
                    255)
                        # parse failure
                        printf "%s: unrecognized option '%s'\n" "${0##*/}" "--$opt"
                        OPTRET=(--)
                        return 1
                        ;;
                esac
                ;;
            *) # non-option arg encountered, add it as a parameter
                unused_argv+=("$1")
                ;;
        esac
        shift
    done

    # add end-of-opt terminator and any leftover positional parameters
    OPTRET+=('--' "${unused_argv[@]}" "$@")
    unset longoptmatch

    return 0
}

kver() {
    # this is intentionally very loose. only ensure that we're
    # dealing with some sort of string that starts with something
    # resembling dotted decimal notation. remember that there's no
    # requirement for CONFIG_LOCALVERSION to be set.
    local kver re='^[[:digit:]]+(\.[[:digit:]]+)+'

    # scrape the version out of the kernel image. locate the offset
    # to the version string by reading 2 bytes out of image at at
    # address 0x20E. this leads us to a string of, at most, 128 bytes.
    # read the first word from this string as the kernel version.
    local offset=$(hexdump -s 526 -n 2 -e '"%0d"' "$1")
    [[ $offset = +([0-9]) ]] || return 1

    read kver _ < \
        <(dd if="$1" bs=1 count=127 skip=$(( offset + 0x200 )) 2>/dev/null)

    [[ $kver =~ $re ]] || return 1

    printf '%s' "$kver"
}

plain() {
    local mesg=$1; shift
    printf "    $_color_bold$mesg$_color_none\n" "$@" >&1
}

quiet() {
    (( _optquiet )) || plain "$@"
}

msg() {
    local mesg=$1; shift
    printf "$_color_green==>$_color_none $_color_bold$mesg$_color_none\n" "$@" >&1
}

msg2() {
    local mesg=$1; shift
    printf "  $_color_blue->$_color_none $_color_bold$mesg$_color_none\n" "$@" >&1
}

warning() {
    local mesg=$1; shift
    printf "$_color_yellow==> WARNING:$_color_none $_color_bold$mesg$_color_none\n" "$@" >&2
}

error() {
    local mesg=$1; shift
    printf "$_color_red==> ERROR:$_color_none $_color_bold$mesg$_color_none\n" "$@" >&2
    return 1
}

die() {
    error "$@"
    cleanup 1
}

map() {
    local r=0
    for _ in "${@:2}"; do
        "$1" "$_" || (( $# > 255 ? r=1 : ++r ))
    done
    return $r
}

arrayize_config() {
    set -f
    [[ ${MODULES@a} != *a* ]] && MODULES=($MODULES)
    [[ ${BINARIES@a} != *a* ]] && BINARIES=($BINARIES)
    [[ ${FILES@a} != *a* ]] && FILES=($FILES)
    [[ ${HOOKS@a} != *a* ]] && HOOKS=($HOOKS)
    [[ ${COMPRESSION_OPTIONS@a} != *a* ]] && COMPRESSION_OPTIONS=($COMPRESSION_OPTIONS)
    set +f
}

in_array() {
    # Search for an element in an array.
    #   $1: needle
    #   ${@:2}: haystack

    local item= needle=$1; shift

    for item in "$@"; do
        [[ $item = $needle ]] && return 0 # Found
    done
    return 1 # Not Found
}

index_of() {
    # get the array index of an item. sets the global var _idx with
    # index and returns 0 if found, otherwise returns 1.
    local item=$1; shift

    for (( _idx=1; _idx <= $#; _idx++ )); do
        if [[ $item = ${!_idx} ]]; then
            (( --_idx ))
            return 0
        fi
    done

    # not found
    unset _idx
    return 1
}

funcgrep() {
    awk -v funcmatch="$1" '
        /^[[:space:]]*[[:alnum:]_]+[[:space:]]*\([[:space:]]*\)/ {
            match($1, funcmatch)
            print substr($1, RSTART, RLENGTH)
        }' "$2"
}

list_hookpoints() {
    local funcs script

    script=$(PATH=$_d_hooks type -P "$1") || return 0

    mapfile -t funcs < <(funcgrep '^run_[[:alnum:]_]+' "$script")

    echo
    msg "This hook has runtime scripts:"
    in_array run_earlyhook "${funcs[@]}" && msg2 "early hook"
    in_array run_hook "${funcs[@]}" && msg2 "pre-mount hook"
    in_array run_latehook "${funcs[@]}" && msg2 "post-mount hook"
    in_array run_cleanuphook "${funcs[@]}" && msg2 "cleanup hook"
}

modprobe() {
    command modprobe -d "$_optmoduleroot" -S "$KERNELVERSION" "$@"
}

auto_modules() {
    # Perform auto detection of modules via sysfs.

    local mods=

    mapfile -t mods < <(find /sys/devices -name uevent \
        -exec sort -u {} + | awk -F= '$1 == "MODALIAS" && !_[$0]++')
    mapfile -t mods < <(modprobe -qaR "${mods[@]#MODALIAS=}")

    (( ${#mods[*]} )) && printf "%s\n" "${mods[@]//-/_}"
}

all_modules() {
    # Add modules to the initcpio, filtered by grep.
    #   $@: filter arguments to grep
    #   -f FILTER: ERE to filter found modules

    local -i count=0
    local mod= OPTIND= OPTARG= filter=()

    while getopts ':f:' flag; do
        case $flag in f) filter+=("$OPTARG") ;; esac
    done
    shift $(( OPTIND - 1 ))

    while read -r -d '' mod; do
        (( ++count ))

        for f in "${filter[@]}"; do
            [[ $mod =~ $f ]] && continue 2
        done

        mod=${mod##*/}
        mod="${mod%.ko*}"
        printf '%s\n' "${mod//-/_}"
    done < <(find "$_d_kmoduledir" -name '*.ko*' -print0 2>/dev/null | grep -EZz "$@")

    (( count ))
}

add_all_modules() {
    # Add modules to the initcpio.
    #   $@: arguments to all_modules

    local mod mods

    mapfile -t mods < <(all_modules "$@")
    map add_module "${mods[@]}"

    return $(( !${#mods[*]} ))
}

add_checked_modules() {
    # Add modules to the initcpio, filtered by the list of autodetected
    # modules.
    #   $@: arguments to all_modules

    local mod mods

    if (( ${#_autodetect_cache[*]} )); then
        mapfile -t mods < <(all_modules "$@" | grep -xFf <(printf '%s\n' "${!_autodetect_cache[@]}"))
    else
        mapfile -t mods < <(all_modules "$@")
    fi

    map add_module "${mods[@]}"

    return $(( !${#mods[*]} ))
}

add_firmware() {
    # add a firmware file to the image.
    #   $1: firmware path fragment

    local fw fwpath r=1

    for fw; do
        for fwpath in "${_d_firmware[@]}"; do
            if [[ -f $fwpath/$fw ]]; then
                add_file "$fwpath/$fw" "$fwpath/$fw" 644 && r=0
                break
            fi
        done
    done

    return $r
}

add_module() {
    # Add a kernel module to the initcpio image. Dependencies will be
    # discovered and added.
    #   $1: module name

    local target= module= softdeps= deps= field= value= firmware=()
    local ign_errors=0 found=0

    [[ $KERNELVERSION == none ]] && return 0

    if [[ $1 = *\? ]]; then
        ign_errors=1
        set -- "${1%?}"
    fi

    target=${1%.ko*} target=${target//-/_}

    # skip expensive stuff if this module has already been added
    (( _addedmodules["$target"] == 1 )) && return

    while IFS=':= ' read -r -d '' field value; do
        case "$field" in
            filename)
                found=1
                module=${value##*/} module=${module%.ko*}
                quiet "adding module: %s" "$module"
                _modpaths["$value"]=1
                _addedmodules["${module//-/_}"]=1
                ;;
            depends)
                IFS=',' read -r -a deps <<< "$value"
                map add_module "${deps[@]}"
                ;;
            firmware)
                firmware+=("$value")
                ;;
            softdep)
                read -ra softdeps <<<"$value"
                for module in "${softdeps[@]}"; do
                    [[ $module == *: ]] && continue
                    add_module "$module?"
                done
                ;;
        esac
    done < <(modinfo -b "$_optmoduleroot" -k "$KERNELVERSION" -0 "$target" 2>/dev/null)

    if (( !found )); then
        (( ign_errors || _addedmodules["$target"] )) && return 0
        error "module not found: \`%s'" "$target"
        return 1
    fi

    if (( ${#firmware[*]} )); then
        add_firmware "${firmware[@]}" ||
            warning 'Possibly missing firmware for module: %s' "$target"
    fi

    # handle module quirks
    case $target in
        fat)
            add_module "nls_cp437?"
            add_module "nls_iso8859-1?"
            ;;
        ocfs2)
            add_module "configfs?"
            ;;
        btrfs)
            add_module "libcrc32c?"
            ;;
        f2fs)
            add_module "crypto-crc32?"
            ;;
        ext4)
            add_module "crypto-crc32c?"
            ;;
    esac
}

add_full_dir() {
    # Add a directory and all its contents, recursively, to the initcpio image.
    # No parsing is performed and the contents of the directory is added as is.
    #   $1: path to directory
    #   $2: glob pattern to filter file additions (optional)
    #   $3: path prefix that will be stripped off from the image path (optional)

    local f= filter=${2:-*} strip_prefix=$3

    if [[ -n $1 && -d $1 ]]; then
        add_dir "$1"

        for f in "$1"/*; do
            if [[ -L $f ]]; then
                if [[ $f = $filter ]]; then
                    add_symlink "${f#$strip_prefix}" "$(readlink "$f")"
                fi
            elif [[ -d $f ]]; then
                add_full_dir "$f" "$filter" "$strip_prefix"
            elif [[ -f $f ]]; then
                if [[ $f = $filter ]]; then
                    add_file "$f" "${f#$strip_prefix}"
                fi
            fi
        done
    fi
}

add_dir() {
    # add a directory (with parents) to $BUILDROOT
    #   $1: pathname on initcpio
    #   $2: mode (optional)

    if [[ -z $1 || $1 != /?* ]]; then
        return 1
    fi

    local path=$1 mode=${2:-755}

    if [[ -d $BUILDROOT$1 ]]; then
        # ignore dir already exists
        return 0
    fi

    quiet "adding dir: %s" "$path"
    command install -dm$mode "$BUILDROOT$path"
}

add_symlink() {
    # Add a symlink to the initcpio image. There is no checking done
    # to ensure that the target of the symlink exists.
    #   $1: pathname of symlink on image
    #   $2: absolute path to target of symlink (optional, can be read from $1)

    local name=$1 target=$2

    (( $# == 1 || $# == 2 )) || return 1

    if [[ -z $target ]]; then
        target=$(readlink -f "$name")
        if [[ -z $target ]]; then
            error 'invalid symlink: %s' "$name"
            return 1
        fi
    fi

    add_dir "${name%/*}"

    if [[ -L $BUILDROOT$1 ]]; then
        quiet "overwriting symlink %s -> %s" "$name" "$target"
    else
        quiet "adding symlink: %s -> %s" "$name" "$target"
    fi
    ln -sfn "$target" "$BUILDROOT$name"
}

add_file() {
    # Add a plain file to the initcpio image. No parsing is performed and only
    # the singular file is added.
    #   $1: path to file
    #   $2: destination on initcpio (optional, defaults to same as source)
    #   $3: mode

    (( $# )) || return 1

    # determine source and destination
    local src=$1 dest=${2:-$1} mode=

    if [[ ! -f $src ]]; then
        error "file not found: \`%s'" "$src"
        return 1
    fi

    mode=${3:-$(stat -c %a "$src")}
    if [[ -z $mode ]]; then
        error "failed to stat file: \`%s'." "$src"
        return 1
    fi

    if [[ -e $BUILDROOT$dest ]]; then
        quiet "overwriting file: %s" "$dest"
    else
        quiet "adding file: %s" "$dest"
    fi
    command install -Dm$mode "$src" "$BUILDROOT$dest"
}

add_runscript() {
    # Adds a runtime script to the initcpio image. The name is derived from the
    # script which calls it as the basename of the caller.

    local funcs fn script hookname=${BASH_SOURCE[1]##*/}

    if ! script=$(PATH=$_d_hooks type -P "$hookname"); then
        error "runtime script for \`%s' not found" "$hookname"
        return
    fi

    add_file "$script" "/hooks/$hookname" 755

    mapfile -t funcs < <(funcgrep '^run_[[:alnum:]_]+' "$script")

    for fn in "${funcs[@]}"; do
        case $fn in
            run_earlyhook)
                _runhooks['early']+=" $hookname"
                ;;
            run_hook)
                _runhooks['hooks']+=" $hookname"
                ;;
            run_latehook)
                _runhooks['late']+=" $hookname"
                ;;
            run_cleanuphook)
                _runhooks['cleanup']="$hookname ${_runhooks['cleanup']}"
                ;;
        esac
    done
}

add_binary() {
    # Add a binary file to the initcpio image. library dependencies will
    # be discovered and added.
    #   $1: path to binary
    #   $2: destination on initcpio (optional, defaults to same as source)

    local -a sodeps
    local line= regex= binary= dest= mode= sodep= resolved=

    if [[ ${1:0:1} != '/' ]]; then
        binary=$(type -P "$1")
    else
        binary=$1
    fi

    if [[ ! -f $binary ]]; then
        error "file not found: \`%s'" "$1"
        return 1
    fi

    dest=${2:-$binary}
    mode=$(stat -c %a "$binary")

    # always add the binary itself
    add_file "$binary" "$dest" "$mode"

    # negate this so that the RETURN trap is not fired on non-binaries
    ! lddout=$(ldd "$binary" 2>/dev/null) && return 0

    # resolve sodeps
    regex='^(|.+ )(/.+) \(0x[a-fA-F0-9]+\)'
    while read -r line; do
        if [[ $line =~ $regex ]]; then
            sodep=${BASH_REMATCH[2]}
        elif [[ $line = *'not found' ]]; then
            error "binary dependency \`%s' not found for \`%s'" "${line%% *}" "$1"
            (( ++_builderrors ))
            continue
        fi

        if [[ -f $sodep && ! -e $BUILDROOT$sodep ]]; then
            add_file "$sodep" "$sodep" "$(stat -Lc %a "$sodep")"
        fi
    done <<< "$lddout"

    return 0
}

parse_config() {
    # parse key global variables set by the config file.

    map add_module "${MODULES[@]}"
    map add_binary "${BINARIES[@]}"
    map add_file "${FILES[@]}"

    tee "$BUILDROOT/buildconfig" < "$1" | {
        # When MODULES is not an array (but instead implicitly converted at
        # startup), sourcing the config causes the string value of MODULES
        # to be assigned as MODULES[0]. Avoid this by explicitly unsetting
        # MODULES before re-sourcing the config.
        unset MODULES

        . /dev/stdin

        # arrayize MODULES if necessary.
        [[ ${MODULES@a} != *a* ]] && read -ra MODULES <<<"${MODULES//-/_}"

        for mod in "${MODULES[@]%\?}"; do
            mod=${mod//-/_}
            # only add real modules (2 == builtin)
            (( _addedmodules["$mod"] == 1 )) && add+=("$mod")
        done
        (( ${#add[*]} )) && printf 'MODULES="%s"\n' "${add[*]}"

        printf '%s="%s"\n' \
            'EARLYHOOKS' "${_runhooks['early']# }" \
            'HOOKS' "${_runhooks['hooks']# }" \
            'LATEHOOKS' "${_runhooks['late']# }" \
            'CLEANUPHOOKS' "${_runhooks['cleanup']% }"
    } >"$BUILDROOT/config"
}

initialize_buildroot() {
    # creates a temporary directory for the buildroot and initialize it with a
    # basic set of necessary directories and symlinks

    local workdir= kernver=$1 arch=$(uname -m) buildroot

    if ! workdir=$(mktemp -d --tmpdir mkinitcpio.XXXXXX); then
        error 'Failed to create temporary working directory in %s' "${TMPDIR:-/tmp}"
        return 1
    fi
    buildroot=${2:-$workdir/root}

    if [[ ! -w ${2:-$workdir} ]]; then
        error 'Unable to write to build root: %s' "$buildroot"
        return 1
    fi

    # base directory structure
    install -dm755 "$buildroot"/{new_root,proc,sys,dev,run,tmp,etc,usr/{local,lib,bin}}
    ln -s "usr/lib" "$buildroot/lib"
    ln -s "../lib"  "$buildroot/usr/local/lib"
    ln -s "bin"     "$buildroot/usr/sbin"
    ln -s "usr/bin" "$buildroot/bin"
    ln -s "usr/bin" "$buildroot/sbin"
    ln -s "../bin"  "$buildroot/usr/local/bin"
    ln -s "../bin"  "$buildroot/usr/local/sbin"

    case $arch in
        x86_64)
            ln -s "lib"     "$buildroot/usr/lib64"
            ln -s "usr/lib" "$buildroot/lib64"
            ;;
    esac

    # mkinitcpio version stamp
    printf '%s' "$version" >"$buildroot/VERSION"

    # kernel module dir
    [[ $kernver != none ]] && install -dm755 "$buildroot/usr/lib/modules/$kernver/kernel"

    # mount tables
    ln -s /proc/self/mounts "$buildroot/etc/mtab"
    >"$buildroot/etc/fstab"

    # indicate that this is an initramfs
    >"$buildroot/etc/initrd-release"

    # add a blank ld.so.conf to keep ldconfig happy
    >"$buildroot/etc/ld.so.conf"

    printf '%s' "$workdir"
}

run_build_hook() {
    local hook=$1 script= resolved=
    local MODULES=() BINARIES=() FILES=() SCRIPT=

    # find script in install dirs
    if ! script=$(PATH=$_d_install type -P "$hook"); then
        error "Hook '$hook' cannot be found"
        return 1
    fi

    # check for deprecation
    if resolved=$(readlink "$script") && [[ ${script##*/} != "${resolved##*/}" ]]; then
        warning "Hook '%s' is deprecated. Replace it with '%s' in your config" \
            "${script##*/}" "${resolved##*/}"
        script=$resolved
    fi

    # source
    unset -f build
    if ! . "$script"; then
        error 'Failed to read %s' "$script"
        return 1
    fi

    if ! declare -f build >/dev/null; then
        error 'Hook '$script' has no build function'
        return 1
    fi

    # run
    if (( _optquiet )); then
        msg2 "Running build hook: [%s]" "${script##*/}"
    else
        msg2 "Running build hook: [%s]" "$script"
    fi
    build

    # if we made it this far, return successfully. Hooks can
    # do their own error catching if it's severe enough, and
    # we already capture errors from the add_* functions.
    return 0
}

try_enable_color() {
    local colors

    if ! colors=$(tput colors 2>/dev/null); then
        warning "Failed to enable color. Check your TERM environment variable"
        return
    fi

    if (( colors > 0 )) && tput setaf 0 &>/dev/null; then
        _color_none=$(tput sgr0)
        _color_bold=$(tput bold)
        _color_blue=$_color_bold$(tput setaf 4)
        _color_green=$_color_bold$(tput setaf 2)
        _color_red=$_color_bold$(tput setaf 1)
        _color_yellow=$_color_bold$(tput setaf 3)
    fi
}

install_modules() {
    local m moduledest=$BUILDROOT/lib/modules/$KERNELVERSION
    local -a xz_comp gz_comp

    [[ $KERNELVERSION == none ]] && return 0

    if (( $# == 0 )); then
        warning "No modules were added to the image. This is probably not what you want."
        return 0
    fi

    cp "$@" "$moduledest/kernel"

    # unzip modules prior to recompression
    for m in "$@"; do
        case $m in
            *.xz)
                xz_comp+=("$moduledest/kernel/${m##*/}")
                ;;
            *.gz)
                gz_comp+=("$moduledest/kernel/${m##*/}")
                ;;
        esac
    done
    (( ${#xz_comp[*]} )) && xz -d "${xz_comp[@]}"
    (( ${#gz_comp[*]} )) && gzip -d "${gz_comp[@]}"

    msg "Generating module dependencies"
    install -m644 -t "$moduledest" "$_d_kmoduledir"/modules.builtin

    # we install all modules into kernel/, making the .order file incorrect for
    # the module tree. munge it, so that we have an accurate index. This avoids
    # some rare and subtle issues with module loading choices when an alias
    # resolves to multiple modules, only one of which can claim a device.
    awk -F'/' '{ print "kernel/" $NF }' \
        "$_d_kmoduledir"/modules.order >"$moduledest/modules.order"

    depmod -b "$BUILDROOT" "$KERNELVERSION"

    # remove all non-binary module.* files (except devname for on-demand module loading)
    rm "$moduledest"/modules.!(*.bin|devname|softdep)
}

# vim: set ft=sh ts=4 sw=4 et:

#18

Check if you have linux414 IDK how the relevant i686 kernels are named. I guess they have different names.
Anyway, how have you created this installation? Did you not format root partition during installation? On to an old one???


#19

Just the lines around 728 would have done the job.

Anyhow, it’s only affecting the fallback kernel image, not the standard one.

This won’t be affecting your ability to log in.

Can you log in with a fresh user account?

What do you get when you run startx from a text console?

What’s in your .xsession-errors, and Xorg.log.0 files?


#20

Just tried to open pkg-k4.14.44-1.tar.gz which I created after the command # pacman -Syyu completed. engrampa just stalled:

engranpa_gets_stuck.png

pkg-k4.14.44-1.tar.gz was created after updating to k4.14.33-1. This is somthing that I will try shortly to see if can open pkg-k4.14.44-1.tar.gz after applyig the k4.14.33-1 packages to the current clean installation from the manjaro-xfce-17.1.7-rc1-testing-i686.iso

manjaro-xfce-17.1.7-rc1-testing-i686.iso was downloaded using a 64-bit PC and burned to a DVD. This was then used to install on the 32-bit PC. The system partition was flagged to be formatted from within the installer after which a new partition table and partition was created before proceeding with the installation. It was all done from within the installer.


#21

Sorry, you 've caught me under-informed. I have no idea or can I imagine what that package is about!..
@jonathon ??


#22

pkg-k4.14.44-1.tar.gz was created by me after updating to k4.14.33-1 taken from /var/cache/pacman/pkg/ after # pacman -Syyu command completed but before rebooting.

Image of the contents of the folder that contains the extracted contents for pkg-k4.14.44-1.tar.gz showing the file linux414-4.14.44-1-i686.pkg.tar.xz that you inquired for above.


#23

OK, I was probably fault-alarming… Sorry.
Provide the rest info @jonathon asked you


#24

Just reinstalled from DVD containing manjaro-xfce-17.1.7-rc1-testing-i686.iso where the installer was used to format the system partition.

After the update completed, The PC was shutdown and restarted.

After login the latest updates were applied.

Then shutdown and rebooted.

Again could not login via Graphics for normal user or root.

(CTRL+ALT+F2) into console.

Issued commands to create new user:

# users
aaa
# useradd --create-home archie
# passwd archie
New password:
Retype new password:
passwd: password updated successfully
# users
aaa
# useradd archie
useradd: user 'archie' already exists
# users
aaa
# useradd quest
#
# users
aaa
# passwd quest
New password:
Re-type new password:
passwd: password updated successfully
# users
aaa
# exit
$ exit

So, NOT possible to create new user via console!

(CTRL+ALT+F7) into graphics mode.

Could NOT login via new user, normal user, super user, or root.


#25
$ users --help
Usage: users [OPTION]... [FILE]
Output who is currently logged in according to FILE.

So, yeah. Wrong command maybe?


#26
# users /var/run/utmp
aaa
# users /var/log/utmp
#

GNU coreutils documentation shows users command lists users currently logged-in: “20.5 users: Print login names of users currently logged in”

OK, just found that user quest was created successfully because used following command:

# useradd quest
#
# passwd quest
New password:
Re-type new password:
passwd: password updated successfully
# exit
$ exit
ga7-pc login: quest
Password: 
Last login: Sun May 27 09:36:01 on tty2
[quest@ga7-pc ~]$

(CTRL+ALT+F7) into graphics mode
Tried to login under quest, but failed.

Will try to retrieve the log files you requested using Knoppix live.