Can't load kernel and can't troubleshoot because pacman won't work ( Error: file ‘/boot/vmlinuz-5.15-X86-64’ not found you need to load the kernel first)

Hi, due to an interrumped update i can’t boot manjaro and i already tried doing this method

sudo su -
manjaro-chroot -a
pacman-mirrors -f 5 && pacman -Syyu

with no success because i get stuck at the pacman part

Aparently theres an issue with pacman because everytime i write a pacman command it always returns “pacman: error while loading shared libraries: /usr/lib/ file too short”
any help is appreciated

from chroot run this:
pacman -S openssl --overwrite '*'
then rerun again:

pacman-mirrors -f 5 && pacman -Syyu

any errors post here;
if there are none, reinstall kernel:
pacman -S linux515
if there are errors, post them here, if there are none, exit chroot, reboot

Thanks for the quick answer, when i write pacman -S openssl --overwrite '*' it keeps telling me “pacman: error while loading shared libraries: /usr/lib/ file too short” and if i run pacman-mirrors -f 5 && pacman -Syyu it tells me “ImportError: /usr/lib/ file too short”

post the whole output from:
pacman -S openssl --overwrite '*'

Hi and welcome to the forum :+1:

Start by explaining from the start in details:

  • how do you start your pc, (LiveMedia, Desktop, Laptop, etc. incl. model.)
  • which bootloader you use
  • especially the steps you take to get to the point where you can chroot…
  • and what you get as errors etc…

Anyhow maybe you need to download a fresh LiveISO, or maybe reinstall some base packages inside the chroot environment, or simply fix your bootloader, or a combination of these :woman_shrugging:

The more details you give the better people can assist you…

Your title:
Error: file ‘/boot/vmlinuz-5.15-X86-64’ not found you need to load the kernel first

Means your bootloader isn’t able to find your kernel, because the filename you mention IS the kernel.
So let people assist you in fixing that first, you can’t fix a problem starting from the end…

Since the library is not complete (too short), it cannot be loaded. You need to download the package manually from a mirror server, extract it and copy it as root to the correct location. That is the only way to fix it, or do a fresh reinstallation (backup files!).

Keep in mind that you can use timeshift, which is recommend, to restore the system files.