Can't install vim-x11

I was installing vim-x11 in pacui, then I get this:

Error: Could not find all required packages:
    vim-runtime=8.1.1467-2 (Wanted by: vim-x11)

I already have vim-runtime though:

pacman -Ss vim-runtime

extra/vim-runtime 8.1.1467-1 [installed]
Vi Improved, a highly configurable, improved version of the vi text editor (shared runtime)

But it didn't matched the required version. I tried to remove and reinstall vim-runtime but I get the same version.

The 8.1.1467-2 version is available in the unstable branch.

And since vim-x11 is an AUR package, it is kept in line with Arch repo's, not manjaro stable repo.

So you can either switch to unstable branch and get the updated runtime package, or wait until it gets updated in stable branch.

PS: Make sure you have an all up to date system with sudo pacman-mirrors -f5 && sudo pacman -Syyu before installing/updating anything from AUR.

1 Like

Yep, I did update before I encountered the error.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark