Cant install the subliminal-git 2.1.0.r22.g160ea63-1 AUR package

It used to be installed and, it stopped working at some point so I uninstalled it and tried to reinstall it, and I cant reinstall it. here’s the error message

A user on the aur page seems to have faced the same issue.
Another user suggested doing

yay -S --asdeps python-babelfish

but I do not know how to do that in manjaro.

Thanks in advance.

The user on the AUR page had a completely different error than you did. Their error was with Subliminal not being able to find Babelfish and yours is with Guessit not being able to find Rebulk:

File "/usr/lib/python3.9/site-packages/guessit/", line 9, in <module>
    from rebulk.match import Match
ModuleNotFoundError: No module named 'rebulk'

You should already have Rebulk installed as it’s required by Guessit and Subliminal requires Guessit:

❯ pactree -r python-rebulk

I’m not sure why pamac would have trouble there, but you can try yay. It’s a good alternative AUR Helper.

pamac install yay
yay -S subliminal-git

I just successfully built and installed subliminal-git with yay. You can ignore the Sphinx errors building the man pages.


yay -S subliminal-git

also seems to not work. here’s what it returns.

Do you have python-rebulk installed? It should be being pulled in as a dependency of python-guessit.

pamac search -i rebulk

there is an AUR python-rebulk installed

Start over with a clean build. This will remove subliminal-git and all it’s dependencies:

yay -Rs subliminal-git

Then reinstall:

yay -S --rebuildall subliminal-git

this returns

error: target not found: subliminal-git

Ha! That’s right, you haven’t installed it yet. :upside_down_face: Remove the dependencies from the AUR and rebuild them is what I meant:

yay -Rs python-sphinxcontrib-programoutput python-guessit python-enzyme python-rarfile

Then reinstall:

yay -S --rebuildall subliminal-git

It worked, subliminal was installed and works again, thanks.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.