Can't install - Screen gets turned off


Hello. I am newish to linux. I am trying to install manjaro. Tried both the i3wm edition and xfce. Both have the same problem. I start installation, pick which version to start (free, non-free), get to the part where there is a black screen with several things written on it and green OKs, then my screen gets suddenly turned off, the pc keeps running and nothing happens. I tried both free and non free drivers ( I have NVIDIA GTX 660). I updated my BIOS. I tried booting UEFI or not UEFI. Don’t know what else to do.

I haven’t had this problem with any other linux distros. I’m trying to install different distros to pick the one I like the most. I’ve tried ubuntu, mint and antegros.

Please help. I really wanna use manjaro, I think it’s the best for me, because I like that it’s sort of a noob-friendly arch.


If you feel up to it, I recommend trying to use the Architect installer. It isn’t really recommended for new linux users, but it has worked for many where the regular installers don’t.

Just follow this tutorial and you should be good. FYI, when you get to the choosing Desktop Environment, you also get to choose if you want the full or minimal version. I personally choose the minimal one because it takes less time to install, and I can install the rest of the packages later if I want them (I don’t like having stuff like thunderbird, firefox, libreoffice, etc preinstalled via full version).

I recommend installing via UEFI and not legacy.

Well, Welcome to Manjaro! And I hope that it’ll all work out for you. After distro hopping around so much, I finally settled with Manjaro and never regretted it.

If you have any questions, we are always here to help.


Well, I tried installing with architect. Everything went fine during installation, but after it finished, I couldn’t boot. Not sure if I messed up somewhere, but I pretty much stuck to the defaults.