Can't install rtl8723de drivers

Hi everyone. I am trying to install the drivers for my wireless network card, namely a Realtek rtl8723de.
Here is what I do: first, i use the command git clone https://github.com/smlinux/rtl8723de.git -b 5.0-up to download the drivers. This spits out no error at all.
Then I proceed by executing dkms add ./rtl8723de. The terminal says

Creating symlink /var/lib/dkms/rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414/source -> /usr/src/rtl8723de-5.1.1.8_21285.20171026_COEX20170111-1414
DKMS: add completed. 

Finally, I run dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414. The output of this command is

Kernel preparation unnecessary for this kernel.  Skipping...
Building module:
cleaning build area...
'make' all KVER=5.0.15-1-MANJARO............................................
cleaning build area...
Kernel cleanup unnecessary for this kernel.  Skipping...
DKMS: build completed.
rtl8723de.ko:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /usr/lib/modules/5.0.15-1-MANJARO/kernel/drivers/net/wireless/
depmod.....
DKMS: install completed.

Then I run depmod -a and reboot.
When I get back to the OS, the wifi icon in the bottom right corner has a red bar on it and I can't activate it. If I press on enable bluetooth, it doesn't do anything. If I check my network controllers in Hardware Configuration, it still shows Unknown device name (realtek semiconductor co., ltd). If I run dkms status rtl8723de, it will just output
rtl8723de, 5.1.1.8_21285.20171026_COEX20170111-1414, 5.0.15-1-MANJARO, x86_64: installed.
The weirdest thing of all, is that if I run inxi -Fxz, it will output

System:    Host: mangoppola-pc Kernel: 5.0.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 
           Desktop: KDE Plasma 5.15.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Laptop 15-bw0xx v: Type1ProductConfigId serial: <filter> 
           Mobo: HP model: 8330 v: 27.30 serial: <filter> UEFI: Insyde v: F.40 date: 11/23/2018 
Battery:   ID-1: BAT1 charge: 39.0 Wh condition: 39.0/41.6 Wh (94%) model: Hewlett-Packard PABAS0241231 
           status: Full 
CPU:       Topology: Dual Core model: AMD A9-9420 RADEON R5 5 COMPUTE CORES 2C+3G bits: 64 type: MCP 
           arch: Excavator L2 cache: 1024 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 11982 
           Speed: 1397 MHz min/max: 1400/3000 MHz Core speeds (MHz): 1: 1418 2: 1404 
Graphics:  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Hewlett-Packard driver: amdgpu 
           v: kernel bus ID: 00:01.0 
           Display: x11 server: X.Org 1.20.4 driver: amdgpu FAILED: ati unloaded: modesetting 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: AMD STONEY (DRM 3.27.0 5.0.15-1-MANJARO LLVM 8.0.0) v: 4.5 Mesa 19.0.4 
           direct render: Yes 
Audio:     Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:01.1 
           Device-2: AMD Family 15h Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:09.2 
           Sound Server: ALSA v: k5.0.15-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard 
           driver: r8168 v: 8.047.01-NAPI port: 3000 bus ID: 02:00.0 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter vendor: Hewlett-Packard driver: rtl8723de 
           v: v5.1.1.8_21285.20171026 port: 2000 bus ID: 03:00.0 
           IF: wlp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 186.67 GiB (78.3%) 
           ID-1: /dev/sda vendor: Samsung model: MZNLN256HMHQ-000H1 size: 238.47 GiB 
Partition: ID-1: / size: 31.26 GiB used: 25.03 GiB (80.1%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 60.2 C mobo: 20.0 C gpu: amdgpu temp: 60 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 177 Uptime: 7m Memory: 7.33 GiB used: 1.13 GiB (15.4%) Init: systemd Compilers: 
           gcc: 8.3.0 Shell: bash v: 5.0.7 inxi: 3.0.34

You can see that the device is recognized in the network devices and its driver is also there. I do not know what is going on

See here.

2 Likes

It looks as though your install was done properly. My guess would be your driver is broken on kernel 5.0 & 5.1 like some of the other Realek adapters recently. I think you will find your driver will work on kernel 4.19 or below.

Thanks for the suggestion, but I am afraid I cannot do that. With those kernel version, I have another bug: when I turn off my pc, it never shuts down completely; instead, the screen goes black and my capslock LED blinks forever, and I am forced to remove the battery/keep the power button pressed. But thanks anyways, it was very kind of you to respond to my question

Just did this. I already had git, dkms, and the proper linux headers, but I used those commands anyways. I just changed branch on the git command to fit my kernel (I updated to version 5.1.1-2, to no avail). The result is the same: dkms says the module is " already installed on kernel 5.1.1-2-MANJARO/x86_64". Running "dkms status rtl8723de" now outputs this
dkms status rtl8723de
rtl8723de-5.1.1.8_21285.20171026_COEX20170111, 1414, 5.1.1-2-MANJARO, x86_64: installed (WARNING! Diff b etween built and installed module!) rtl8723de, 5.1.1.8_21285.20171026_COEX20170111-1414, 5.0.15-1-MANJARO, x86_64: installed rtl8723de, 5.1.1.8_21285.20171026_COEX20170111-1414, 5.1.1-2-MANJARO, x86_64: installed
See that WARNING! there? That also popped up some other time, while trying to install these drivers. I really can't figure this out. I am now going to try another full uninstall and reinstall of the driver and give you an update soon

Unless a new updated driver surfaces on Github, I don not think the driver will work under the newest kernels (until either the kernel or the driver are updated ti fix this).

You could try rhe real time kernels to see if they perform differently.

I also tried using a real time kernel, to no avail. I guess I should just wait for a new update on GitHub

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark