Can't install proprietary NVIDIA drivers

I currently have the nouveau driver running on my device, and was following the tutorial on the official Manjaro wiki to install the proprietary NVIDIA drivers. However, when I ran the command sudo mhwd -i pci video-nvidia-450xx I get the following output:

Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-450xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
warning: nvidia-450xx-utils-450.66-1 is up to date -- skipping
warning: lib32-nvidia-450xx-utils-450.66-1 is up to date -- skipping
error: target not found: linux56-nvidia-450xx
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 sublime-text is up to date
Error: pacman failed!
Error: script failed!

Any help with this issue would be greatly appreciated.

Please reboot in either 5.4 kernel as is LTS, or in 5.8 kernel and remove the 5.6 kernel as is EOL. Then try again the drivers install procedure.

1 Like

This fixed it, thanks a lot!

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please mark a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.