Can't install PHP56 on Manjaro 21.2.4

i’m trying to install php56 from AUR repositories and it fails with:

php-5.6.40.tar.xz ... HA FALLADO (clave pública desconocida C2BF0BC433CFC8B3)
==> ERROR: ¡No se ha podido verificar alguna de las firmas PGP!
Fallo al construir el php56

i did what’s mentioned on another post on forums (can’t include links yet) about this problem, and also did what said the pinned message on the package detail page but i always end with the same problem.

searching, i found that sks-keyservers [AT] net (is suggested on the pinned message) is not online anymore, so i test with others keys gpg servers but ended up with the same error.

any suggestions?

thanks in advance

Did you follow the pinned comments? The most important one is the one about no support since January 2019. has both keys.

1 Like

i did read comments and also saw the comment you mention :weary:

i did use openpgp [AT] org but it didn’t work :man_shrugging:

thanks anyway

gpg --keyserver --recv-keys 6E4F6AB321FDC07F2C332E3AC2BF0BC433CFC8B3 0BD78B5F97500D450838F95DFE857D9A90D90EC1

tested, same result: it fail

If you don’t give more information how you’re trying to build it, I can’t help.

Custom packages from AUR is unstupported so if you cannot make the script work - get in touch with AUR maintainer.

You should learn how build packages by reading the articles on Arch Wiki.

PHP56 is long deprecated - the version in the repo is v8.

git clone https:://
cd php56
makepkg -is

i used both, command line pacman instalation and gnome visual package manager, both with same result

Pacman can’t install AUR packages and I don’t know what the second one is.

Why don’t you read the articles from the post above and then come back with the actual error message.

LANG=C pamac build php56