Can't install on my GL62 6QF laptop

Hi guys, i was a windows user until yesterday, decided to swap but my laptop seems not to want let me install manjaro, Already used the OS in the past in VM's, and decided to start using it as my main OS now that i left windows. Just said that for you to know that i know almost nothing about linux/linux comands.
When I try to boot I can't get past a line that says "a start job is running for livemedia mhwd script".
Once it managed to boot and install, but after that i was only getting a black screen when the system started so i'm stuck on the previous step again.
Thanks for the attention and hope you can help me

If it was only the second problem I'd say problems with graphics drivers.
Now tho I would suspect either a damaged image, or a damaged USB stick

Is this happening when trying to boot the live media, even before actually installing? Then yes, either the download got corrupted or the actual USB stick is damaged. Most likely.

This error happens when i try to boot live media, it only entered there once and was the time i managed to install, but no success after as said

Did you check the checksum on the download?

Also, what graphics card do you have on that machine? If it is an Nvidia card it might be worth trying the non-free option in the boot image GRUB, that auto-enables the NVIDIA drivers.

I got a GTX960m and an Intel HD graphics, I saw that the problem could be related to having 2 graphic cards and having a Skylake laptop, but none of the solution worked for me

tried a new USB drive and non free drivers and got stuck at "started tlp system startup/shutdown"
using non-free drivers on that option doesnt mean i ain't gonna be able to use the nvidia gpu after the install, right?

Actually it's the other way around. If you pick the non-free option the proprietary NVIDIA drivers (inclusive drivers for double gfx-cards) will be auto-installed during the install with no extra input needed from you, period.

my computer still freezes after the "started tlp system startup/shutdown", do you know any way arround that?

i have the same setup, and yes it is due to the optimus graphics. optimus graphics often need a little extra effort to get working properly. selecting "nonfree" will use bumblebee and it's terrible and often results in a black screen as you have already noticed.

the "free" nouveau drivers are usually less problematic to get manjaro installed but using them after install is hardly ideal.

:point_up: this. is that manjaro install still in tact? if yes, boot the manjaro usb and select the free drivers so you have a graphical environment to work from, connect to network, open a terminal and
sudo manjaro-chroot -a
this should drop you to a root shell on your installed manjaro where you can make the needed changes to get things working. if it ask's you to pick a choice and the only number is " 0 ", enter number " 1 " anyway

choose an optimus solution from here and follow it's directions


i suggest optimus-switch or prime. if you have any questions, just ask.

I have a very similar setup with a gl752 (960m/intel) and had the same issue you are having. @dglt helped me get my computer going in with the prime setup and it works great.

Most of the time I was unable to get the system to boot so I could work on it. But it would boot about every 1 out of 10 times. I usually had to add acpi_osi=! acpi_osi=“Windows 2009 to grub when booting, but even that didn't always work. Once you get it booted, use the guide that @dglt provided.

I'm using the optimus switch method which is great. It requires a restart but lets you use the intel chip or Nvidia.

1 Like

i'm pretty new with linux so sommetimes its hard for me to understand.
do I open the terminal when I launch the usb with free drivers and get stuck at the "a start job is running for livemedia mhwd script" and type "sudo manjaro-chroot -a"? if yes, how do i open the terminal?

i can't even lauch the live media, I get stuck when the usb is loading, already readownloaded and changed the usb drive and same problem

when you boot the usb and get to the grub screen where you select free or nonfree drivers, move selector to the boot option and hit " E " instead of enter. you should see a bunch of parameters like nouveau.modeset=1 radeon.modeset=1, next to one of those parameters add this parameter

systemd.mask=mhwd-live.service

make sure you leave a single space between parameters, then CTRL+X to boot. that should get you to a graphical desktop where you can follow the directions i posted previously

1 Like

now the pc still getting stuck at "started TLP system startup/shutdown", but now it doesn't freezes it still blink on the underline

ughh.. optimus :face_with_symbols_over_mouth:.

did you try this on both free and nonfree options?

if, yes then try these parameters with the nonfree drivers

first try just adding nomodeset as a parameter, if that doesnt work, try again with these 2 parameters together

acpi_osi=! acpi_osi='Windows 2009'

with "nomodeset" i got stuck once at "a start job is running for livemedia pac man mirror ranking script" and the secont time it froze at the "tlp startup" again
with the "acpi_osi=! acpi_osi='Windows 2009" i get to a diferent screen where it gives a error "/dev/disk/bylabel/ device did not showup after 30 seconds"

says it all...

ok lets go about this a different way,
currently manjaro is installed, you just cant get it to finish booting right?

do you have a second device you can follow directions from? having the graphical environment of the live usb makes it easier but it's not absolutely necessary.

you're talking about another computer to use? if so, yes i have

the manjaro installed on the disk only start if i got the boot options on legacy on bios, but gives a black screen, but if i use UEFI or UEFI with CSM the pc starts and after the msi logo goes automatically to the bios and doesn't load the system

is this a dual boot with windows setup, or is manjaro the only OS installed?

Forum kindly sponsored by Bytemark