Can't install new package with old keyring installed


#1

So, I’m having a problem performing a system upgrade. I have tried ALL the solutions I could find, but when I do:

sudo pacman -Sy archlinux-keyring manjaro-keyring

I get:

error: archlinux-keyring: signature from "Erich Eckner (just to sign arch packages) <arch@eckner.net>" is unknown trust
:: File /var/cache/pacman/pkg/archlinux-keyring-20171213-1.0-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

Any help would be greatly appreciated!


Issues with "signature is marginal trust" or "invalid or corrupted package"
#2

The solution that Kouros17 posted in this thread worked for me:

https://forum.manjaro.org/t/cannot-update-system-getting-invalid-or-corrupted-package-pgp-signature-error/24240/4


#3

Thanks for your help, but that didn’t work. I ended up having to resort to his extreme solution:

It’s really too bad this is still such an issue with Manjaro. Even after doing the above, then a complete system upgrade, I still cannot install packages with pgp signatures enabled!


#4

If you don’t keep your rolling-release distro up-to-date then packages may be signed by a key that you don’t have. This is not an issue with Manjaro or with Arch, but with you running an out-of-date system.

Then something else is wrong.

If you haven’t updated your system for a long time then it’s possible your mirror is out-of-date, or you have a corrupt download. Alternatively, if you’re running a i686 system then none of the packages will be signed by the Arch Linux devs, so you need to install the archlinux32 keyring instead.

If you provide full output someone might be able to help.


#5

Aaaaaaarghhhhhhh… That was it. I needed to switch to archlinux32-keyring.

Thank you so much for your help!!!


closed #6

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.