Can't install Manjaro XFCE on new laptop - no network device drives

I just bought a new laptop - only for Manjaro. Lenovo Ideapad 5 14" with AMD Ryzen 5.
All nice and dandy but I can’t install Manjaro, because I have “no network devices available”.

What I see with mhwd -lh : invalid network drivers

Aside of not having access to an ethernet connection at all, this laptop does not have rj45.
How can I resolve this?
I will add once more - I do not have any possibility to connect it to the network with a cable :frowning:
Please help…

Try to use Android tethering - ArchWiki

Since you might have

or maybe different model that requires some driver that might be only available in AUR … More information is required. Here is [HowTo] Provide System Information


I do not have an Android device at all.
Since 2008 I use only macOS (or macos x) and iOS.
Manjaro joined in 2018 on my old MacBook (almost no issues with it on that 2008 laptop). It died recently after 13 years.

My Lenovo is my first ever laptop not from Apple.
It is IdeaPad 5 14ALC05 (no touch screen)
8GB Ram and AMD integrated graphics.
It has Windows 10 on - Just trying to wipe it with a proper OS :slight_smile:

There you go Lenovo IdeaPad Flex 5 14alc05 - ArchWiki read along about the wifi and all the goods there.

I am reading this :slight_smile:
I do not have access to an USB to networking port adapter, and have no idea how to clone network card drivers from another device to USB flash drive :confused:
If I had issues with my Manjaro in the past - I could install the drivers on it. I never had a problem to install Linux on my macs… :confused:
Now I have with Lenovo
And what I am finding on the net is - install drivers with Windows…
On Windows, connect your USB drive…
I did sanity check in UEFI - wifi is enabled.
In the Arch doc is link to the driver on Git - ()packages/rtw89-dkms-git
This tells me nothing :confused:
Since 1996 I just downloaded a driver, copied it (floppy, USB later) and installed it on another machine.
Now I am trying to learn some more about linux and I can’t install it… embarrassing

That is an AUR package. You still need internet connection to compile and install it, but it points to the source of it here GitHub - lwfinger/rtw89: Driver for Realtek 8852AE, an 802.11ax device and you can download it on a USB stick as zip file and then extract it … run the compilation … But you will also need linux headers for the running kernel.
[root tip] Kernel - Headers - DKMS

1 Like

I understand that I can install it from an usb stick.
Question is - what with the linux headers?
My kernel is 5.15.28-1-MANJARO (linux515)
How can I use pacman without network connection?
And this:
" For Arch:
After installing the necessary kernel headers and base-devel,
git clone aur.archlinux (dot) org/rtw89-dkms-git.git cd rtw89-dkms-git makepkg -sri"
Still network connection… I am lost…

then you get the headers from a mirror, for example

You save the file on USB, then from that USB/folder where you save it, you run:

sudo pacman -U linux515-headers-5.15.28-1-x86_64.pkg.tar.zst
1 Like

The only USB sticks I have at home… physically do not fit near each other. Will try with SD card :slight_smile:

(here was a pic of my screen, but it looks I can’t add media to post yet :confused: )
No luck :confused:
It has to be USB stick? All shops are closed here in Bergen now…
4 warnings and an error - couldn’t find or read package

Seems to be a nice place there :wink:

When trying to install the rtw89-dkms-git from AUR? That can happen, yes, that is why i proposed to build it from source.

But another question: are you trying this on live media ?

If you have a bigger USB stick where now is the manjaro install, probably best to use Ventoy, drop the iso there and you can also copy the other files to it, hence is becoming also a storage.

So - my situation is:
I changed booting order to USB first on the Lenovo.
It started from my USB stick.
I choosen proprietary drivers (open source was the same for now)
It loaded. I see that I have no wifi and it has invalid drivers.

Now I am stuck with a new laptop with a USB stick in one of two USB A ports (Live Manjaro) and I can’t install it :confused:

I know what you mean, have no idea how to do it.
Now I have foudn a smaller USB stick and they both fit.
How the OS will recognise what USB to read from?
Because I have the same error on and on…

It is. Even when its rainging (aprox. 200 days a year) :smiley:

No worries about that in Live Media. Install the system, and once is installed and can have permanent changes, then you install the drivers for wifi, or did i miss something and the install does not work without internet connection?

Let me download the latest iso and try without internet …

Indeed. That is what I am against. I can’t install Manjaro without network connection.
It won’t let me through.

I did what I always do - dwl the latest ISO with all drivers and install it. Last time (macbook white 2008) I had issues with BT only. I just went to Arch depos and done. Drivers updated, bluetooth works.
Now… Installation is impossible without network connection…

Ok, so you see this once you started the installer

And you clicked Next and did all that and is not installing ? From my test is should work, and deal with the driver later. Also, from a fellow team member, plugging your iPhone into Manjaro box with enabled tethering on the phone makes it come up as a USB network interface.

1 Like

Jeez! I totally forgot!

Thanks!!! :smiley:
And I already miss Apple’s trackpad… this thing is atrocious!
So - now I am installing Manjaro. Will se what I can do with the network drivers

…but you did not check linux compatibility, so calm down. There are already topics about the problem you could have searched here in the forum.

I am calm. Just was in the mist. And I do not understand why I need network connection to install OS.
Anyway - I got help.
And I did not check if it is running Manjaro, because I already installed it on 3 other computers. Without a glitch.
All macs.
Only this bugger is a troublesome bastard.

Hello - my laptop is not flex and has Network card:
Intel Wi-Fi 6 AX200 (a/b/g/n = Wi-Fi 4/ac = Wi-Fi 5/ax = Wi-Fi 6), Bluetooth 5
What is interesting - my bluetooth is enabled, but sees no devices. I can see my Lenovo, but ca|t connect.
Neither wifi nor bluetooth.
Since this module is for both radios, I will assume both are not working.
I tried this:

  • dwl AX200 driver from intel(dot)com/content/www/us/en/support/articles/000005511/network-and-io/wireless.html,
  • extracted iwlwifi-cc-a0-46.ucode into /lib/firmware,
  • executed sudo modprobe -r iwlwifi and `sudo modprobe iwlwifi
  • no change