Can't install Manjaro (or any other distro) 3500u

I’ve tried for over 7 hours just to get this thing to boot into a Linux distro so I’m giving up on forums/google searches for now. I’m asking directly :frowning:

I’ve just purchased a Dell 5585 with a Ryzen 3500u and Radeon Vega 8. If I try to boot into any Linux live USB all I get is a black screen. I can boot into the grub Menu just fine, but as soon as I try to load the live Distro, black screen. Nothing. Can’t even do CTRL ALT F keys to bring up tty.

Now the distro I want to use is Manjaro KDE. But I have tried Ubuntu, and Arch (just cause of newer kernel built into the installer by default. But still does the same).

I’ve update the BIOS and have tried all sorts of recommendations found through google searches / forum searches such as modifying various modsets in the grub menu.

I’m not sure how to go about diagnosing this issue as I get 0 feedback due to the black screen. I can get to the Grub CLI from the Grub menu but I have no idea what to do once there. I’m suspecting this is some sort of video issue.

Does anybody have any ideas? I’m at a total loss.

Thanks for anyone that tries to help me, though at this point, I’m suspecting I’ll have to wait for the kernels to be more compatible with this processor.

Try one of the 18.2 RC's found here:

I successfully installed the KDE edition with 18.1 RC1 on my ThinkPad E495 with a 3500U

Check BIOS settings. What else could produce that?
AHCI maybe?
Any link to your MB manual to list settings?

Here you go sir:

https://www.dell.com/support/manuals/ca/en/cabsdt1/inspiron-15-5585-laptop/inspiron_15_5585-servicemanual/system-setup-options?guid=guid-7e3310e8-b157-4c58-9c4e-972b47f38db6&lang=en-us

Under SATA operation there is no other option other than AHCI

I've tried both RC1 and RC2, they both do the same thing. Thanks for the recommendation though :slight_smile:

Take a look at this guide. This may help you.

This sounds like an ACPI issue.

1 Like

you are choosing the free drivers right?

from bios, disable CSM and set either legacy bios or full uefi.

have you tried these 3 parameters together?

acpi=off noapic
setparams 'Boot: Manjaro.x86_64 kde '  'x86_64 lang=en_US keytable=us tz=UTC driver=free nouveau.modeset=1 i915.modset=1 radeon.modset=1 misobasedir=manjaro misolabel=M1804 quiet systemd.show_status=1'
# set arguments above with the editor
		linux boot/vmlinuz-$2
		initrd boot/amd_unicode.img boot/intel_unicode.img boot/initramfs-x86_64.img

The above is the default. So I would put this?

setparams 'Boot: Manjaro.x86_64 kde '  'x86_64 lang=en_US keytable=us tz=UTC driver=free nouveau.modeset=1 i915.modset=1 radeon.modset=1 misobasedir=manjaro misolabel=M1804 quiet systemd.show_status=1 setparams 'Boot: Manjaro.x86_64 kde '  'x86_64 lang=en_US keytable=us tz=UTC driver=free nouveau.modeset=1 i915.modset=1 radeon.modset=1 misobasedir=manjaro misolabel=M1804 quiet systemd.show_status=1 acpi_osi='Windows 2018.2' '
# set arguments above with the editor
		linux boot/vmlinuz-$2
		initrd boot/amd_unicode.img boot/intel_unicode.img boot/initramfs-x86_64.img '
# set arguments above with the editor
		linux boot/vmlinuz-$2
		initrd boot/amd_unicode.img boot/intel_unicode.img boot/initramfs-x86_64.img

change those paramters from 1's to 0's and try adding amdgpu.modeset=1

That doesn't work either. It does seem to be ACPI related though as @linesma suggested. When I do acpi=off, as you recommended, it starts to boot but then stops at -

[9.675477] note: (journald)[242] exited with preempt_count 4

then try these

acpi=off pci=noaer
acpi_osi=!
acpi_rev_override=1   (common for dell laptops, not sure about amd)
acpi=off pci=noaer iommu=soft
pci=noacpi
acpi=strict

try each line separately.

Change this to: acpi_osi='Windows 2018'

As stated in the linked guide, Grub does not recognize Windows 2018.2

@dglt

Tried each line separately, those that don't have the black screen hang at the same spot as acpi=off

@linesma
Yeah I noticed that after re-reading your guide. Still has the same issue. I also tried acpi_rev_override=1 (tried 1 to 5 separately)

try these:

amdgpu.dc=0
amdgpu.powerplay=0 amdgpu.dc=0
amdgpu.dc=0 iommu=soft

same deal :frowning:

pci=noacpi seems to be the common fix for 3500u. are you certain your putting it in the right place?

from the grub menu where you select free/nonfree drivers, select free, then move selector to the "boot:" option then hit " E ", change other driver modesets to 0, then add this parameter next to them, be sure to leave a space, remove the word "quiet" from the line, then ctrl+x to boot.

 nouveau.modeset=0 i915.modset=0 radeon.modset=0 pci=noacpi pci=noaer

then try:

 nouveau.modeset=0 i915.modset=0 radeon.modset=0 amdgpu.dc=0 pci=noacpi pci=noaer 
#then try
 nouveau.modeset=0 i915.modset=0 radeon.modset=0 amdgpu.dc=1 pci=noacpi pci=noaer 
#then
 nouveau.modeset=0 i915.modset=0 radeon.modset=0 amdgpu.dc=0 amdgpu.powerplay=0 pci=noacpi pci=noaer 
#then
 nouveau.modeset=0 i915.modset=0 radeon.modset=1 pci=noacpi pci=noaer nomodeset

if you try using pci=noacpi nomodeset, be sure the radeon.modeset=1 because amdgpu requires kms (kernel modesetting).

also try this:

systemd.mask=mhwd-live.service pci=noacpi

i may be remembering incorrectly but IIRC there was a weird ryzen/black screen issue when virtualization was enabled in bios. anyway try both, with/and without virtualization enabled from bios.

1 Like

Yep, I've been doing it like it is in your examples. Have tried all of them individually and have tried most of them with virtualization disabled. Still no dice :frowning: . I think I need to step away from this for a few hours, been at it since yesterday afternoon.

Thanks for your time and for trying :slight_smile:

2 Likes

I had the same problem with my Inspiron 5485. I tried multiple kernel flags and versions and had no success until I found this bug report. https://bugzilla.kernel.org/show_bug.cgi?id=203431

Following that report I discovered that setting Advanced -> Sleep Mode = "Force S3" in the bios allowed me to install and run without any additional flags required. Please give that a try.

1 Like

This worked. Thank you!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.