Can't install Manjaro on UEFI. GRUB error.

Hello.
It's my first time installing Manjaro.

But everytime i install, doesn't matters if i do it manually or let Manjaro create partitions, it gives same error.

I already tried to install Kubuntu, it gave me same error

As i found out from online forums, my laptop HP probook x360 11 g1 EE, is not friendly with GRUB.

I do not have legacy or fast boot, its UEFI system and secure boot is off.

*i can't upload partitions screenshot *
i have /dev/sda1, fat32 as a efi, 300mib
/dev/sda2, ext4 and /dev/sda3 as a swap.

maybe there is an alternative, like reefind or smth like this? sorry, i'm newbie in linux distros.

Thanks.

Not friendly with non-Windows, I would say...

You may want to use Manjaro Architect.
There are some tutorials on usage IIRC.

1 Like

Here is an old link, maybe still worth to try:
https://lists.gnu.org/archive/html/bug-grub/2017-12/msg00024.html

1 Like

this error happens at the very end of installing?

if yes, then manjaro is installed but only grub fails to install. after it fails, reboot back into the live environment again, connect to network, open a terminal and

sudo manjaro-chroot -a

if your presented with an option and the only option is zero "0", enter the number "1" anyway. this should drop you to a root shell of your installed manjaro where you can manually do a grub install

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
update-grub

if it fails for whatever reason, post these outputs

inxi -Fxxxza
parted -l
1 Like

Ok, basically what i did.

I downloaded reefind files. Then deleted everything from efi/boot and then i put these reefind files there.

It booted successfully, there was a reefind boot menu, i chose my ext4 partition and voila. Manjaro is installed (there is no "install manjaro" and + its not a live session, i created folder before restarting and its still there after restart) but after i unplug my USB and restart laptop, it says that "boot device not found". Huh?

HP used to not allow any UEFI entry other than "Windows Boot Manager" by description (!)

1 Like

Ok, so, what should i do now? I'm really confused

I'm no expert on this subject, but in your case I would verify if you feel comfortable with the suggestions in the link of my first comment, or have a look into this Ubuntu thread which maybe provides some ideas as well:
https://ubuntuforums.org/showthread.php?t=2399115

1 Like

Go in your UEFI/BIOS menu and find the page with Boot order or similar.
See if you can see some Manjaro related entry and make it default.
How did you install refind to your system?
Is grub still installed?

Post any entries you find in UEFI menu.

Just to make sure.
You have /boot/efi not just /efi. Right?

1 Like

if you can boot with USB manjaro ( not the disk )
open a terminal an returns

inxi -Fxxxza
parted -l 
efibootmgr 

Thank you everybody.

I used this video and it worked.

@Wollie especially thank you for that thread

3 Likes

Just checking..
So now you're using refind and it works.
Can you let us know what is the 'description' at the refind menu entry that boots manjaro?
Is it....
o Boot Manjaro from XXX
o Boot vmlinuz-5.x-x86_64 from XXX
o Boot EFI\xxx\grubx64.efi from XXX

To be clear, go to Refind Line Editor - press F2 at menu
(you may have to press 2 times, press 'esc' to go back)
is it...
o root=UUID=xxxxxxxxxxxxxxx initrd=initramfs-5.xx.86_64.img
o blank (nothing)

Thanks.

Boot EFI\Manjaro\grubx64.efi from 299 MiB FAT volume (when i boot from here grub "bash like line editor" appears and i'm stuck)

boot\vmlinuz-5.3-x86_64 from 110 GiB ext4 volume (this boots successfully)

and there is a different icon, it says boot EFI\refind\refind_x64.efi from 299 MiB FAT volume and when i enter here, i get same menu but with only first two options (EFI|manjaro\grub and boot\vmlinuz)

1 Like

Okay. Understand. Thanks for this info.
grub fails and kernel boots. Got it.

And since you're booting okay now, I won't go into how to get grub (grubx64.efi) working (unless you want to).

Cheers and take care.
Welcome to Manjaro.

2 Likes

i just booted from the grub.

1 Like

Forum kindly sponsored by