Can't install Manjaro Gnome to 4KN drive

I’m having a really weird problem. I’m trying to install Manjaro Gnome to a Western Digital SN750 NVME drive which, like most drives in the world, uses a 4K native sector size (4K physical/4K logical). I chose the option to erase the disk and use Manjaro’s automatic partitioning. The graphical installer says the installation completed successfully, but when I reboot there is no EFI entry listed in my computer’s boot menu, just the option to enter the firmware setup. Upon rebooting to the Manjaro live install environment I ran “efibootmgr” which showed there was an entry labeled Manjaro. Running “Gparted” showed an EFI partition with the ESP and Boot flags enabled, a swap partition and an Ext4 root partition. Below is my system configuration. Does anyone know why my computer isn’t booting?

I’m using a System76 Gazelle laptop with the following configuration:

Intel Core i7-6700HQ CPU (4C/8T)
Western Digital SN750 SSD (NVME)
Intel HD 530 graphics

Hey @techguy378 :wave:

looks like an UEFI Issue… that laptop seems not to use coreboot.

Is there anything in the UEFI you can change? I haven’t found any UEFI docs about that laptop.

No, it’s not Coreboot. This laptop was originally manufactured in 2016 before Coreboot existed. If I install Ubuntu 20.04.1 with its default settings everything works fine. It uses Grub like Manjaro does. If I install Arch Linux with the Systemd bootloader I have no issues booting. I tried installing a Samsung EVO 960 250GB NVME drive which reports a 512b sector size (512b physical/512b logical) and Manjaro has no trouble booting from this drive when installing with the default settings. Manjaro simply refuses to boot with a 4kn sector drive.