Can't install jitsi via AUR

I’m asked to install /usr/lib/jvm/java-16-openjdk/bin/java, when I only have /usr/lib/jvm/java-17-openjdk.

Trying to install jdk16-openjdk leads to needing to have java-environment-jdk<=16.

Does this make jitsi impossible to install via AUR?

Are you sure about that? It says it needs java-environment=8…

1 Like
We cannot run Java, please ensure you have Java installed.
  We have tried to execute /usr/lib/jvm/java-16-openjdk/bin/java but failed.
If you have installed Java in a unusual place you can set JAVA_HOME
to the directory containing the Java installation.


I see. My JAVA_HOME was set to 16. I set it to 17 with

echo export "JAVA_HOME=\$(readlink -f /usr/bin/java | sed "s:/bin/java::")" | sudo tee /etc/profile.d/

But now I’m getting…

/var/tmp/pamac-build-folaht/jitsi/src/jitsi-5633/build.xml:269: Error running javac compiler


Setting java to version 8 seems to work for me.

sudo archlinux-java set java-8-openjdk


The next issue:


I’m not used to use Java applications on Manjaro, so i can’t reply a straight solution.
But from the errors, it seems your Java environments aren’t set up correctly. Have you checked the wiki as suggested?

I get the feeling it’s asking for Oracle JDK 8 and that’s a bit too much for me.
I’m downloading linphone instead.

From the comments in the AUR page, it seems to run fine with OpenJDK8.
Did you make sure you have jdk8-openjdk installed before setting it as the default JDK to use?