Can't install any linux on my HP X360 G1 EE

#1

Hello,
I'm sorry for a bod english but i am french.
i can't install manjaro (and any linux with grub) on my hp x360 g1 ee.
Install fails on "Start procedure and passes ‘fw_type’ to other routine" at 90%

Here the return of fdisk -l :

Disque /dev/loop0 : 18,1 MiB, 18948096 octets, 37008 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets


Disque /dev/loop1 : 274,6 MiB, 287969280 octets, 562440 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets


Disque /dev/loop2 : 1,1 GiB, 1229180928 octets, 2400744 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets


Disque /dev/loop3 : 475,5 MiB, 498573312 octets, 973776 secteurs
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets


Disque /dev/sda : 119,2 GiB, 128035676160 octets, 250069680 secteurs
Modèle de disque : SanDisk SD8SN8U-
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d'étiquette de disque : gpt
Identifiant de disque : B02553E4-6A43-4D7E-8985-B7C406D40ECB

Périphérique  Début       Fin  Secteurs Taille Type
/dev/sda1      4096    618495    614400   300M Système EFI
/dev/sda2    618496 250067789 249449294   119G Système de fichiers Linux


Disque /dev/sdb : 29,8 GiB, 32015679488 octets, 62530624 secteurs
Modèle de disque : Cruzer Slice    
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque : 0x00000000

Périphérique Amorçage   Début     Fin Secteurs Taille Id Type
/dev/sdb1    *             64 4094111  4094048     2G  0 Vide
/dev/sdb2             4094112 4102303     8192     4M ef EFI (FAT-12/16/32)

inxi -Fxxxx :

[manjaro@manjaro Bureau]$ inxi -Fxxxx
System:
  Host: manjaro Kernel: 4.19.28-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: KDE Plasma 5.15.2 tk: Qt 5.12.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP ProBook x360 11 G1 EE v: N/A 
  serial: <root required> Chassis: type: 10 serial: <root required> 
  Mobo: HP model: 82EE v: 54.20 serial: <root required> UEFI: Insyde 
  v: 01.09 date: 04/10/2017 
Battery:
  ID-1: BAT0 charge: 31.6 Wh condition: 34.2/34.2 Wh (100%) 
  volts: 12.2/11.6 model: Hewlett-Packard Primary type: Li-ion 
  serial: 26988 06/27/2017 status: Discharging 
CPU:
  Topology: Quad Core model: Intel Celeron N3450 bits: 64 type: MCP 
  arch: Goldmont rev: 9 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8756 
  Speed: 928 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 796 2: 796 
  3: 796 4: 796 
Graphics:
  Device-1: Intel vendor: Hewlett-Packard driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5a85 
  Display: x11 server: X.Org 1.20.4 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa compositor: kwin_x11 resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6) 
  v: 4.5 Mesa 18.3.4 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio 
  Cluster 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:0e.0 
  chip ID: 8086:5a98 
  Sound Server: ALSA v: k4.19.28-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 1000 
  bus ID: 01:00.0 chip ID: 10ec:8168 
  IF: enp1s0 state: down mac: 18:60:24:4b:0d:89 
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: 1000 
  bus ID: 02:00.0 chip ID: 8086:095a 
  IF: wlp2s0 state: up mac: 88:b1:11:29:91:27 
Drives:
  Local Storage: total: 149.06 GiB used: 6.03 GiB (4.0%) 
  ID-1: /dev/sda vendor: SanDisk model: SD8SN8U-128G-1006 
  size: 119.24 GiB speed: 6.0 Gb/s serial: 171455802966 rev: 0006 
  scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Slice 
  size: 29.82 GiB serial: 4C532000031230107025 rev: 1.26 scheme: MBR 
Partition:
  ID-1: / size: 2.75 GiB used: 220.7 MiB (7.8%) fs: overlay 
  source: ERR-102 
Sensors:
  System Temperatures: cpu: 27.0 C mobo: 26.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 236 Uptime: 43m Memory: 3.67 GiB used: 1.22 GiB (33.2%) 
  Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 
  running in: konsole inxi: 3.0.32

df -hm :

[manjaro@manjaro Bureau]$ df -hm
Sys. de fichiers blocs de 1M Utilisé Disponible Uti% Monté sur
dev                     1857       0       1857   0% /dev
run                     1879      93       1787   5% /run
/dev/sdb1               2000    2000          0 100% /run/miso/bootmnt
cowspace                 256       0        256   0% /run/miso/cowspace
overlay_root            2818     221       2597   8% /run/miso/overlay_root
/dev/loop0                19      19          0 100% /run/miso/sfs/livefs
/dev/loop1               275     275          0 100% /run/miso/sfs/mhwdfs
/dev/loop2              1173    1173          0 100% /run/miso/sfs/desktopfs
/dev/loop3               476     476          0 100% /run/miso/sfs/rootfs
overlay                 2818     221       2597   8% /
tmpfs                   1879      29       1850   2% /dev/shm
tmpfs                   1879       0       1879   0% /sys/fs/cgroup
tmpfs                   1879      10       1869   1% /tmp
tmpfs                   1879       2       1877   1% /etc/pacman.d/gnupg
tmpfs                    376       1        376   1% /run/user/1000
/dev/sda2             119378    5956     107316   6% /run/media/manjaro/0e0e36a8-5956-489a-9642-bbd8a76be9a5

Thank youu for help.

#2

to clarify i little.

  • you are able to boot to the live environment.
  • when you try to install, the installer fails at 90%

is that right?

  • what ISO are you using, where did it come from?

  • how did you write the ISO the USB? etcher? rufus? other?

  • did you go to bios settings and do these:
    make sure secure boot and fast boot are disabled
    make sure it's set to full UEFI
    set storage to AHCI

  • did you let manjaro's installer format and make partitions on it's own, or did you do it manually? if manually, please explain the procedure?

#3

I use 18.0.4-stable kde from official manjaro website , wrote with rufus. I did everything in bios settings. I let manjara format by itself.

Thank you

#4

did you use "DD mode" when you wrote it with rufus? if not this will cause issues

etcher is what i use, it's simple and it's never once failed to write the iso properly.

also when booting the USB, sometimes there 2 entries for the same USB. one is UEFI and the other is not. use the UEFI option.

i also noticed HP models seem to have more trouble like your having more often than others. if installing in UEFI wont work you can go into bios and enable legacy support and then boot manjaro in legacy/bios mode. at the boot selection menu instead of picking the UEFI option choose the other listing which you should see if you have legacy support enabled in bios.

#5

You can use the #français section. There are many Francophones on the forum.

#6

I chose the DD mode.

Here the settings of rufus

#7

to be honest, i've never used rufus. i've never needed anything other than etcher.

select iso > select usb > write

there is zero margin for error. you can try etcher, if that does not work you can install in legacy bios mode which is fine also. just be sure to enable legacy/bios support in bois settings before booting the usb and make sure you boot in legacy bios mode.
also let manjaro wipe the disk and create a new MBR partition table

1 Like
#8

I tried it, but still stuck at 90 :confused:

#9

stuck at 90?

#10

The installer fails at 90% , with « Start procedure and passes ‘fw_type’ to other routine »

#11

is this uefi? or legacy bios?

#12

In this bios there is no choice for it..

#13

ok, then using a slightly older iso is my only suggestion left. but are you sure you dont have in option in bios to switch from UEFI to legacy? or at least enable legacy support?

#14

I have only that

#15

#16

ok, some bios require that a bios password to be set before your able to disable or enable certain features.

boot to bios settings, set bios password and other options should become available.

disable the options i mentioned previously secure boot,fast boot. check that the drive is in AHCI mode. then check the other options carefully.

@Fibule i just now seen the image you posted last. secure boot is enabled in that picture and needs to be disabled , also disable Express Boot.

#17

I did all u said , still stucks at 90%

#18

use an older ISO, for some reason they tend to work better with some very stubborn hardware

https://sourceforge.net/projects/manjarolinux/files/archive/17.1.7/kde/

and write it with etcher

#19

I have still the same problem

#20

i really dont get it, others have this exact model laptop and are using manjaro so it obviously installs. im left with the only possibly reason being something in bios not setup the way it needs to be.

search "hp x360" and you'll see what i mean. manjaro can install so its something configuration related.

have you tried the older ISO in both legacy bios and UEFI mode?

try resetting BIOS to it's defaults and start over and make sure the correct options are set. i guess you could take pictures of each bios screen and showing the available options, this would be alot of pictures though so use something like imgur or other photo hosting site and link them here.

here, this ISO was custom made by @lolix for someone with your exact model. there's ISO's for KDE,GNOME,XFCE, and DEEPIN at this link
https://sourceforge.net/projects/lolix-remix-of-manjaro/files/ISO/OnDemand/

thread i found it on:

but i seriously still think its something in your bios settings

1 Like