Can't install 455 nvidia drivers , Error: config ‘video-hybrid-intel-nvidia-prime’ conflicts with config(s): video-hybrid-intel-nvidia-390xx-bumblebee

I’am using qt-optimus-manager but i have only bumblebe now wtf

No … you only have 390 available - both alone and with bumblebee

… Is your card compatible with 455 ?

Why are you using the real-time kernel?

Before update i had 455 driver for my 1050ti

MK … well … modules are dependent on kernels.
And you are using the niche 5.9-rt (realtime) … and it maybe does not have that available.
Why are you using RT ?

I’m pretty sure something went wrong with mhwd. This is the 3rd issue I’m seeing where mhwd does not display a configuration that should be available. And Linux 5.9-rt has the 455.45.01 NVIDIA driver.

@cpp73 have you tried reinstalling mhwd-db? That solved the problem here.

Fair enough - I had seen something similar because of some (IMHO unecessary) gymnastics being done to automatically change (deprecated) kernels and drivers during update… but I thought it was fixed.
Maybe a partial-upgrade/bad-timing scenario ?
Or maybe just not-so-fixed ? :sweat_smile:

I used 54 with the same trouble

Have you tried 5.10?

Check these maybe ?

find /var/lib/mhwd -type f -name "*.old"

pacdiff -o

Wow it helps but
Error: config ‘video-hybrid-intel-nvidia-prime’ conflicts with config(s): video-hybrid-intel-nvidia-390xx-bumblebee
but i have now a prime driver

Then remove bb first…

i can’t solve this problem

Have you tried to switch in over the GUI (Manjaro settings manager)?

Yep , i tried to delete it but

Removing video-hybrid-intel-nvidia-390xx-bumblebee…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-hybrid-intel-nvidia-390xx-bumblebee/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
modprobe: FATAL: Module bbswitch not found.
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-390xx-utils breaks dependency ‘nvidia-utils’ required by cuda
:: removing nvidia-390xx-utils breaks dependency ‘nvidia-utils’ required by nvidia-prime
Error: pacman failed!
Error: script failed!

Remove cuda and nvidia-prime temporarily, then you can reinstall them after you installed the latest hybrid configuration.

Thanks but i still can’t install 450xx

Error: config ‘video-hybrid-intel-nvidia-450xx-prime’ does not exist!

Because it does not exist. You want video-hybrid-intel-nvidia-prime.

Yay my bad , it works now
nvidia nvidia-utils lib32-nvidia-utils lib32-nvidia-libgl
Thanks a lot

same thing i have a gtx 1060 and after updating i can install only 390xx driver