Can't instal the latest updates (package dependencies)

Whenever I try to update my system I get this error:

:: Synchronizing package databases...
core is up to date 0,0 B 0,00B/s 00:00 [----------------------] 0%
extra is up to date 0,0 B 0,00B/s 00:00 [----------------------] 0%
community is up to date 0,0 B 0,00B/s 00:00 [----------------------] 0%
multilib is up to date 0,0 B 0,00B/s 00:00 [----------------------] 0%
herecura is up to date 0,0 B 0,00B/s 00:00 [----------------------] 0%
:: Starting full system upgrade...
warning: faba-icon-theme: downgrading from version 1:4.3-1 to version 4.3-1.1
:: Replace linux50 with community/linux-latest? [Y/n] Y
:: Replace linux50-bbswitch with community/linux-latest-bbswitch? [Y/n] Y
:: Replace linux50-nvidia-390xx with community/linux-latest-nvidia-390xx? [Y/n] Y
:: Replace linux50-r8168 with community/linux-latest-r8168? [Y/n] Y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-390xx-utils (390.129-1) breaks dependency 'nvidia-390xx-utils=390.116' required by linux51-nvidia-390xx

Kernel 5.0 is EOL and no longer in the repos. If you have another kernel installed reboot into it and remove kernel 5.0

1 Like

I don't think that's the problem since I'm running kernel 5.1. I've removed the 5.0 kernel and the error persists.

[wingnux@wingnux-laptop ~]$ uname -a
Linux wingnux-laptop 5.1.21-1-MANJARO #1 SMP PREEMPT Sun Jul 28 09:33:43 UTC 2019 x86_64 GNU/Linux

After removing kernel 5.0:

[wingnux@wingnux-laptop ~]$ sudo pacman -Syuu
[sudo] password for wingnux:
:: Synchronizing package databases...
core is up to date 0,0 B 0,00B/s 00:00 [----------------------] 0%
extra is up to date 0,0 B 0,00B/s 00:00 [----------------------] 0%
community is up to date 0,0 B 0,00B/s 00:00 [----------------------] 0%
multilib is up to date 0,0 B 0,00B/s 00:00 [----------------------] 0%
herecura is up to date 0,0 B 0,00B/s 00:00 [----------------------] 0%
:: Starting full system upgrade...
warning: faba-icon-theme: downgrading from version 1:4.3-1 to version 4.3-1.1
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-390xx-utils (390.129-1) breaks dependency 'nvidia-390xx-utils=390.116' required by linux51-nvidia-390xx

Kernel 5.1 is now eol too.

Remove "nvidia-390xx-utils", update your system and install "nvidia-390xx-utils" again.

2 Likes

That did the trick! Thank you very much!