Can't get Tor browser working

There are 3 items in the repos: tor, tor browser launcher and tor browser launcher settings
Installed but getting the same error every time I try to run any of them -

“Error Starting Download
(tried a bunch)
Trying to download over Tor. Are you sure Tor is configured correctly and running?”

Say what? I can’t get at it to configure it or start it.
Any help?

Did you already try to download tor from the official website? The tor projects says its the recommended way to get tor, also on Linux. Keep in mind that you should check the signature manually to verify integrity using gpg.

2 Likes

Yes, I did.
And then I just get an error-fest from here - https://support.torproject.org/tbb/how-to-verify-signature/

Just not worth the effort. I’ll use Tor on another box.

If you want to risk it, meaning not verify that the package your downloaded is legit, you can just run the package from the website without verifying the package.

Also, Tor themselves says you should only use the package directly from their website, not from your distro’s repo.

2 Likes

Tried it.
Massive crash issues.

Thanks for trying. Runs just fine on the other box - different distro.

Too bad. Like using Manjaro.

AFAIK tor-browser can connect to the TOR network by itself, you don’t need the tor package installed and running on top of it. Maybe that’s where your trouble comes from.

1 Like

This is what I get after downloading direct from Tor:

sudo pacman -U tor-browser-linux64-9.5.3_en-US.tar.xz
loading packages…
error: missing package metadata in tor-browser-linux64-9.5.3_en-US.tar.xz
error: ‘tor-browser-linux64-9.5.3_en-US.tar.xz’: invalid or corrupted package

Where do I find this missing metadata?

  1. Download from Tor Project | Download (-> https://www.torproject.org/dist/torbrowser/9.5.3/tor-browser-linux64-9.5.3_en-US.tar.xz)
  2. Check the signature (-> https://www.torproject.org/dist/torbrowser/9.5.3/tor-browser-linux64-9.5.3_en-US.tar.xz.asc)
  3. Extract the file in a Folder (-> /home/$User/Downloads/tor-browser_en-US/) or wherever you like. Right-click -> Extract here
  4. Open the folder
  5. Double-click on Tor Browser
  6. Enjoy anonymous surfing
1 Like

Thanks all round!
My problem seems to have been trying to follow the Tor instructions…rabbit hole

Got it going now. :grinning: :grinning:

Please remember to mark the topic as solved and the post containing the solution :slight_smile:

Greetings,

I’ve got the same issue with tor on Manjaro.

Describe the problem:

tor browser don’t want to start. Like a month before everything worked pretty well however.

What I have done to fix the problem:

Removed the tor browser packages and reinstalled it over Official Repositories.

After starting it shows:

Error starting download:

https://aus1.torproject.org/torbrowser/update_3/release/Linux_x86_64-gcc3/x/en-US

Trying to download over Tor. Are you sure Tor is configured correctly and running?

[Exit]

After this, I uninstalled the tor packages and applied the solution of @rovovav982.
If I click on “start-tor-browser.desktop” it opens a text file.

I don’t know what the problem is… :sleepy:

Little update on the topic:

After some googeling and digging through archive posts of manjaro forums… still the same problem :sleepy:

Does anyone have an idea?

this is very strange…

Use command: $ chmod +x start-tor-browser.desktop
or

Right click on your script and chose Properties -> Permissions -> Allow executing file as program

chmod +x on a file (your script) only means, that you’ll make it executable. Right click on your script and chose Properties -> Permissions -> Allow executing file as program , leaves you with the exact same result as the command in terminal.

If a file you want to change permissions on is located within the systems directory you may need to be root , like so: (be careful, while using sudo command)

1 Like

Sorry for bumping this old thread, but i know that you can move the start-tor-browser.desktop file to /usr/share/applications/ or to your home folder in ~/.applications/ and it will be accessible from the start menu

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.