Can't get my monitor to work at 144hz

Hi, I solved the problem by incrementally adding ModeValidation Parameters to /etc/X11/xorg.conf.d/20-nvidia.conf until I could add whatever mode I wanted. Then I generated a modeline using this command:

cvt12 2560 1440 144 -b
# 2560x1440 @ 144.000 Hz Reduced Blank (CVT) field rate 144.000 Hz; hsync: 222.192 kHz; pclk: 586.59 MHz
Modeline "2560x1440_144.00_rb2"  586.59  2560 2568 2600 2640  1440 1529 1537 1543 +hsync -vsync

As you can see it uses -b which makes it use CVT 1.2 reduced blanking timings.

Here is the updated 20-nvidia.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 465.31

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
    Option         "UseEDIDFreqs" "FALSE"
    Option         "ModeValidation" "AllowNonEdidModes, NoMaxPclkCheck, NoEdidMaxPclkCheck, NoHorizSyncCheck, NoVertRefreshCheck"

For Reference: Appendix D. X Config Options

I also added this to my /etc/profile:

export __GL_SYNC_TO_VBLANK=1

I don’t know if that has anything to do with the solution but I read somewhere that it might help in some cases. Here is the link to the corresponding arch wiki paragraph: NVIDIA - ArchWiki

I’ve also updated the nvidia driver to v465.31:

Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 465.31 bus-ID: 20:00.0
           Display: server: 1.20.11 driver: loaded: nvidia resolution: <missing: xdpyinfo>

Thank you so much for your help!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.