Can't get my mic to work in Zoom

Neither my cam mic nor my headphone mic seem to register with Zoom I got from AUR.

When I’m testing the mic, the sound bar shows there is input, but Zoom doesn’t echo what I said during the test.

There is the button to test the speakers, but there is no button to test the mic.

Also, my Alt+Shift keybinding for keyboard layout switching doesn’t work anymore. I looked into Zoom’s keybindings and some contain the Alt+Shift combination. Seems like Zoom’s keybindings are overriding the system keybindings, and permanently!

UPDATE Alt+Shift works again.
UPDATE 2 I tried Zoom in VirtualBox (ArcoLinux). Same issue. No luck.
UPDATE 3 Workaround: use phone as mic, but that’s not enough for me. My current mic is in my headset. Will get a standalone mic and see what happens.

What’s wrong with my setup?

  Device-1: Intel Tiger Lake-H HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel alternate: snd_sof_pci bus-ID: 00:1f.3 
  chip-ID: 8086:43c8 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.68-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.37 running: yes 

I would also be interested in a fix for this.

try this (i didn’t make it it’s Copied)


I have a headset (combined stereo headphones and mic) jack on my Dell PC with Ubuntu 16.04 and experienced the same problem.

First use hdajackretask check that the problem is not related to the jack:

  1. Press Ctrl+Alt+T to access the terminal.
  2. Type sudo pacman -S alsa-tools-gui
  3. Once installation is complete, launch HDAJackRetask app from the dash
  4. Check that the jack you’re trying to access is identified correctly.
  5. If the jack setting is incorrect, then override the incorrect setting, test that the override works and then Install boot override.

I was trying to use the the front headphone jack and it was alredy correctly detected as ‘Headphone’ so I had install the HD-Audio Codec to get my headphone jack to work.

  1. Press Ctrl+Alt+T to access the terminal.
  2. Type cat /proc/asound/card*/codec* | grep Codec in the terminal and take note of the codecs listed.
  3. If there are multiple codecs listed, determine which one relates to your headset jack. For me there were two listed – one related the the video card (Codec: ATI R6xx HDMI) and another related to the sound card (Codec: Realtek ALC3861). In my case, I was interested in the sound card because I was connecting to the PC headset jack and not a HDMI device such as a PC monitor.
  4. Look up the HD-Audio model for your codec in HD-Audio Codec-Specific Models. For my headset jack, the best fit was the headset-mic model.
  5. Type cd /etc/modprobe.d/ in the terminal.
  6. Type sudo cp alsa-base.conf alsa-base.conf.bak to backup the file before editing.
  7. Type gksudo gedit ./alsa-base.conf to edit the file.
  8. Insert this line at the bottom of the file options snd-hda-intel model={HD-Audio model for you codec}. For example, for it me it was options snd-hda-intel model=headset-mic.
  9. Save file and reboot.


also this worked for me

Enjoy :smiley:

install : sudo pacman -S alsa-tools-gui
then run : hdajackretask

Select the appropriate sound card up top in Select a codec, then make the Black Mic (headphone jack) override, and set to Not connected

In the lower right corner, select Install boot override.


you can do the same thing for speaker too

Suggest the Second Link
Sorry for the looong reply :smiley:

1 Like

Thanks a bunch, will try all this if I can.

Well, Did it Work?

I also am curious since my oldest daughter will be using this laptop (System 76 Darter Pro gen one) as an emergency Zoom terminal if her HP Windows laptop goes down. I am very curious and look forward to learning about Zoom and Manjaro (and other) Linux.

Thank you, I will give that a try.

Stuck at step one:

error: target not found: alsa-tools-gui

Couldn’t find it in the webpage. My codec is ALC897.

I did this. Had to create the file. Can’t be created in the file manager. I opened the terminal from the folder via right click menu and ran sudo touch alsa-base.conf. Edited the file in Kate. Saved and restarted.

Started Zoom, started a meeting and recorded myself speaking. When I listened to the recording, I could hear my voice. So I don’t seem to have the problem anymore. I have yet to try it out in a meeting with other participants.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.