Can't get my Hori RAP N to be recognized as a gamepad

Hello everyone,

I have a Hori Real Arcade Pro N, and I am having issues with getting it recognized as a gamepad. If I run lsusb I can see that it is recognized as being plugged in, but it is not recognized by the game controller portion of system settings. When I go there it simply says “No joystick device automatically found on this computer.
Checks were done in /dev/js[0-4] and /dev/input/js[0-4]
If you know that there is one attached, please enter the correct device file.”

Does anybody here have experience with getting less mainstream controllers, like fightsticks, working? I would really appreciate the help. Let me know if you need me to provide more info.

I have a similar problem with a Personal Communication Systems PSX adapter, though the controller functions nothing sees it so I can’t use Open Joystick Display with it.

For anyone that may see this in the future, I found out what was causing my issue. Apparently I had too many USB devices plugged in and there was not enough bandwidth to handle all of them. If you are having a similar issue, here is how you can see if it can be fixed in the same way (removing some USB devices)

  1. Unplug the device from computer (If already unplugged, you can skip this step if you like to live life on the edge)
  2. Open Konsole (ctrl+alt+t by default)
  3. Type sudo dmesg -w
  4. If you were having the same issue I was, as soon as you plug in your device it will output something similar to this:
  • 48231.986350] usb 7-2: new full-speed USB device number 6 using xhci_hcd

[48232.145800] usb 7-2: New USB device found, idVendor=0f0d, idProduct=00ae, bcdDevice= 1.14

[48232.145803] usb 7-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3

[48232.145805] usb 7-2: Product: RAP.N4

[48232.145806] usb 7-2: Manufacturer: HORI CO.,LTD.

[48232.145807] usb 7-2: SerialNumber: F24E8140

> [48232.146079] usb 7-2: Not enough bandwidth for new device state.

> [48232.146142] usb 7-2: can’t set config #1, error -28

which means you should be able to fix it immediately by removing other devices. I hope this helps! My stick is working natively now.

1 Like

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please mark a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.