Can't get Manjaro to run on HP EliteDesk 705 G4 (AMD Ryzen)

Trying to get Manjaro KDE live to boot from USB on a new HP EliteDesk 705 G4 system but it just locks up at a random point. Occasionally it will get as far as the desktop but mouse and keyboard are frozen and I can’t do anything. Suspect it might be a GPU issue as I found I could get Ubuntu to boot from USB if I selected the basic graphics option (it crashed using standard graphics boot).

Windows 10 on the same system runs without issue.

Any help would be much appreciated. Thanks.

After a long while spent googling the issue, I found the solution (or at least workaround) is to go into the BIOS and set the ‘Optional Rom Launch Policy’ to ‘All UEFI’. Now Manjaro Live will boot successfully every time but there’s also a new problem - the keyboard and mouse are completely unresponsive on the log-in screen :frowning: This seems to be a general Arch problem as EndeavourOS also did the same thing after installation.

Where are the keyboard and the mouse plugged ?

Both are HP USB devices, plugged in the front and back panels. I then tried GeckoLinux (openSUSE based) and both mouse and keyboard worked OK with that.