Can't get Cisco Packet Tracer working!

Hey there, Manjaro community. I can’t get packet tracer working to save my life, and I need it for school so it’s rather troublesome. I would rather not have to boot into windows to solve this problem so hopefully we can fix it together.

I’m using Manjaro Sway, running the 5.10 kernel. AMD hardware.

So I go on the AUR with yay and install packettracer using the .deb from the Cisco website, last time I installed it on Manjaro it worked without a hitch but on this fresh-ish install I have no such luck.
I notice after the install it says there is an issue with permissions, saying the package wants 775 permission, but the file system is 755. It’s complaining about many of the folders in /usr/. I don’t remember exactly which ones but it was easy of course to change the permissions but it didn’t fix it.
It also gives the error

gtk-update-icon-cache: No theme index file.
error: command failed to execute correctly

Which I don’t know what that means exactly and my searches haven’t helped me much.

But it acts as if the program successfully installed, so I go to run it and I get

/usr/bin/packettracer: line 8: 6503 Aborted (core dumped) ./PacketTracer7 “$@” > /dev/null 2>&1

better check out line 8 on said file.


echo Starting Packet Tracer 7.3.1

export LD_LIBRARY_PATH=/opt/packettracer/bin
pushd /opt/packettracer/bin > /dev/null
./PacketTracer7 “$@” > /dev/null 2>&1 #LINE 8
popd > /dev/null

I’m no bash scripter so I’m not really sure what that means.

Anyway, I appreciate any help I can get!

Try this:


Yeah, I tried that way but it is exactly the same as if I had copied it into the yay cache.
I did search here on the forums and none of the methods other people tried worked for me.
It acts as if it installed properly but it just gives
/usr/bin/packettracer: line 8: 6503 Aborted (core dumped) ./PacketTracer7 “$@” > /dev/null 2>&1
when you try to run it.

I ran into a similar issue. I fixed it when i went to usr/share/applications and found the cisco -pt .desktop and ran it. It worked