cant find sogoupinyin after installed just follow the step on the web, how to fix it?

I follow the step on the web to install the sogoupinyin a input method for Chinese this way.

  1. sudo pacman -S fcitx fcitx-im fcitx-configtool
    and sudo pacman -S fcitx-sogoupinyin
  2. add the
export XMODIFIERS="@im=fcitx"
export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx

to ~/.xprofile

  1. reboot

  2. after reboot I cant change the input method by pressing ctrl + space, I right click on the keyboard icon at the right bottom and hover mouse on the input method, just show english input method and sometimes nothing pops out.

I enter the fcitx configtool , in the first tab just see one input method named Keyboard-English(US)

I check many post on web but still cant get this done. So how to fix it.

here is other picture, I am a new user cant upload more than one image in a post.

You may need to uncheck 'Only show current language'.

If you cannot find Sogou, try installing fcitx-libpinyin, which is in the repository.

Run fcitx-diagnose in a terminal to make sure everything that you need is installed and configured.

Do you use KDE? You need to put the export content to ~/.pam_environment in KDE instead of ~/.xprofile

fcitx-sogoupinyin is in the AUR, not manjaro's repositories. you cannot install it with sudo pacman -S. i suspect you didn't actually look at the output when you ran that command.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by