Can't find secondary hard drive from Windows

Hey there, I just today installed Manjaro onto my SSD after being a Windows user, and while I’m able to easily access the other partition with Windows through /run/media, my secondary drive isn’t showing up there nor anywhere else.
I’m brand new to Manjaro and my only Linux experience is using a Raspberry Pi when I was 14, so patience would be appreciated.

lsblk -f output:

sda                                                                                     
├─sda1 vfat   FAT32 ESP             3AA2-1864                              46.2M    52% /boot/efi
├─sda2                                                                                  
├─sda3                                                                                  
├─sda4                                                                                  
└─sda5 ntfs         Recovery        7466A78066A7422A                                    
sdb                                                                                     
├─sdb1 ntfs         System Reserved 542EBB982EBB721A                                    
├─sdb2 ntfs                         8ACEBC24CEBC0A89                       45.7G    90% /run/media/noelle/8ACEBC24CEBC0A89
├─sdb3 ntfs                         F2AC1E18AC1DD845                                    
├─sdb4 vfat   FAT32                 FADE-C70B                                           
├─sdb5 ntfs                         E2DEB2EDDEB2B8DD                                    
└─sdb6 ext4   1.0                   b1581353-f1b1-4e88-a51a-e2f4f4f5de19    6.5G    62% /

I believe the drive is sda4, since that’s the one with the largest size in KDE Partition Manager.

Relevant information from inxi

Drives:
  Local Storage: total: 1.36 TiB used: 411.63 GiB (29.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 1J scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WDBNCE5000PNC
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 20RL scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 20.16 GiB size: 19.68 GiB (97.60%) used: 11.98 GiB (60.9%)
    fs: ext4 dev: /dev/sdb6 maj-min: 8:22 label: N/A
    uuid: b1581353-f1b1-4e88-a51a-e2f4f4f5de19
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 49.8 MiB (51.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: ESP
    uuid: 3AA2-1864
  ID-3: /run/media/noelle/8ACEBC24CEBC0A89 raw-size: 444.4 GiB
    size: 444.4 GiB (100.00%) used: 399.6 GiB (89.9%) fs: ntfs dev: /dev/sdb2
    maj-min: 8:18 label: N/A uuid: 8ACEBC24CEBC0A89
  ID-4: /run/user/1000/41dacd5c5a52d3d4 raw-size: N/A size: 1000 GiB
    used: 0 KiB (0.0%) fs: fuse.sshfs remote: kdeconnect@10.6.1.67:/
Swap:
  Alert: No swap data was found.
Unmounted:
  ID-1: /dev/sda2 maj-min: 8:2 size: 1024 KiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/sda3 maj-min: 8:3 size: 15 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/sda4 maj-min: 8:4 size: 930.4 GiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-4: /dev/sda5 maj-min: 8:5 size: 1024 MiB fs: ntfs label: Recovery
    uuid: 7466A78066A7422A
  ID-5: /dev/sdb1 maj-min: 8:17 size: 50 MiB fs: ntfs label: System Reserved
    uuid: 542EBB982EBB721A
  ID-6: /dev/sdb3 maj-min: 8:19 size: 563 MiB fs: ntfs label: N/A
    uuid: F2AC1E18AC1DD845
  ID-7: /dev/sdb4 maj-min: 8:20 size: 100 MiB fs: vfat label: N/A
    uuid: FADE-C70B
  ID-8: /dev/sdb5 maj-min: 8:21 size: 508 MiB fs: ntfs label: N/A
    uuid: E2DEB2EDDEB2B8DD

I’ve tried using the systemd-mount command but it gives me the error /dev/sda4 does not contain a known file system. so I’m not sure what I’m doing wrong.

Have you install ntfs-3g?

Yep, got that installed

Can you post fdisk -l on console ?

When the device shows the partition but not the filesystems the filesystem is damaged on the device.

You can possibly use testdisk or photorec (testdisk package) to see if something can be recovered

Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: TOSHIBA MQ04ABF1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 746D6084-E397-498D-9E6D-2DCF0B66C976

Device          Start        End    Sectors   Size Type
/dev/sda1        2048     206847     204800   100M EFI System
/dev/sda2      206848     208895       2048     1M Microsoft LDM metadata
/dev/sda3      208896     239615      30720    15M Microsoft reserved
/dev/sda4      239616 1951426559 1951186944 930.4G Microsoft LDM data
/dev/sda5  1951426560 1953523711    2097152     1G Windows recovery environment


Disk /dev/sdb: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: WDC  WDBNCE5000P
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: BAED76EA-F295-11EB-A358-DE46A0F19E0F

Device         Start       End   Sectors   Size Type
/dev/sdb1       2048    104447    102400    50M Microsoft basic data
/dev/sdb2     104448 932082412 931977965 444.4G Microsoft basic data
/dev/sdb3  974368768 975521791   1153024   563M Windows recovery environment
/dev/sdb4  975523840 975728639    204800   100M EFI System
/dev/sdb5  975728640 976769023   1040384   508M Windows recovery environment
/dev/sdb6  932082414 974366829  42284416  20.2G Linux filesystem

Partition table entries are not in disk order.

I don’t know why it would be damaged since it still works perfectly fine in Windows, but I’ll try those commands out.

It is Windows Logicial Disk Management - much like Linux Lvm - I don’t know how to access such device if it is even possible using Linux.

I Learned something - you may too from reading this entry

Wasn’t able to solve the problem through that so I just ended up reformatting the drive as standard ntfs and that worked fine. Sorry for anyone with this issue in the future :stuck_out_tongue:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.