Can't enable screen sharing - Gnome

I’m having the exact same problem as describe here. It seems that the vino-server.service that is in user space is expected to be somewhere else. I don’t understand much about systemd configuration but that is probably the problem there.

Here is the specific log that shows when opening the Sharing section of Gnome settings

couldn't list networks: GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: Invalid service name 'vino-server'

I too was getting this error on Manjaro GNOME (3.38.4). When looking through the possible solution on Reddit linked by johnyasantoss, I found this reply:
I modified it a little bit, so my steps looked like this:

  1. Remove vino. (sudo pamac remove vino)
  2. Install gnome-remote-desktop (sudo pamac install gnome-remote-desktop)
  3. Force the use of Wayland I think? (sudo nano /etc/gdm/custom.conf, then uncomment the WaylandEnable=false line and set it to true.) I’m not positive this step is really necessary but I did it anyway.
  4. Restart

I tried this on two of my devices and curiously it worked flawlessly on the first one but not the second one.

On the second one, the option does show up in the settings, and configuring it throws no errors, but then when you try to connect it just denies everything access. I’ll post any updates if I can get it working on that one!