Cant enable Bluetooth in Asus X205TA

Ive installed Manjaro on an Asus X205TA after testing many many OS, Manjaro has been the only one thats working like a champ, never freezes or tilt.

Been able to turn everything On except for the bluetooth BCM43341.

Ive tried the wiki archlinux org/index.php/ASUS_x205ta solution but when I enable bluetooth the icon tray disappears.

Here the output of btattach:

$ sudo systemctl status btattach
● btattach.service - Btattach
     Loaded: loaded (/etc/systemd/system/btattach.service; enabled; vendor preset: disabled)
     Active: active (running) since Wed 2021-02-24 14:53:19 -03; 1h 44min ago
   Main PID: 482 (btattach)
      Tasks: 1 (limit: 2275)
     Memory: 212.0K
     CGroup: /system.slice/btattach.service
             └─482 /var/lib/snapd/snap/bluez/266/usr/bin/btattach --bredr /dev/ttyS0 -P bcm

feb 24 14:53:19 domain systemd[1]: Started Btattach.

seems ok by me. the only thing i did was modify the serial port to ttyS0 because on ttyS1 couldnt start the service. Not sure if this modification is making things go wrong.

I’ ve try differnent firmwares but the main one Ive worked with is
github com savagezen x205ta tree master firmware

Not sure how to continue since I’ve have not found any other solution.
Currently i’ve installed kernels 5.11 5.10.15-1 5.9.16-1 4.19.175-1 4.4.257-1 (probably not a good idea that many kernels but it did not change the bluetooth problem)

Any help and guide are welcome!


I gave away my X205TA to my roommate and installed Linux Mint Cinnamon on it for him. Bluetooth isn’t working on it, either. I haven’t bothered troubleshooting it since my roommate doesn’t really mind.

If you haven’t already, see my thread on the Ubuntu Forums and save the ISO creation script somewhere.

What’s the output of:

sudo dmesg | grep brcm

Hi Yochanan!

Not sure about the script, if its for creating an ISO Im already good with Manjaro now, wasnt easy with Manjaro but I could finally do it following some tutorial (that I’ll search to share in this forum where someone asked about installing manjaro in the X205TA.

The output of sudo dmesg | grep brcm is :

[    7.461407] Bluetooth: hci0: BCM43341B0 'brcm/BCM43341B0.hcd' Patch
[    8.219193] brcmfmac: F1 signature read @0x18000000=0x1602a94c
[    8.226913] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43340-sdio for chip BCM43340/2
[    8.228002] usbcore: registered new interface driver brcmfmac
[    8.238330] brcmfmac mmc0:0001:1: Direct firmware load for brcm/brcmfmac43340-sdio.ASUSTeK COMPUTER INC.-X205TA.txt failed with error -2
[    8.467180] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43340-sdio for chip BCM43340/2
[    8.467292] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[    8.467750] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM43340/2 wl0: Aug 29 2019 05:13:37 version (r722178) FWID 01-e7bd1c9f
[ 7861.524059] Modules linked in: hid_logitech_hidpp hid_logitech_dj uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_common videodev mc snd_hdmi_lpe_audio bnep ofpart cmdlinepart iTCO_wdt intel_spi_platform intel_spi snd_soc_sst_cht_bsw_rt5645 spi_nor intel_pmc_bxt mtd iTCO_vendor_support mei_hdcp gpio_keys hid_asus intel_rapl_msr usbhid joydev mousedev intel_chtdc_ti_pwrbtn intel_soc_dts_thermal intel_powerclamp coretemp kvm_intel vfat fat kvm squashfs irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel loop btsdio brcmfmac aesni_intel brcmutil crypto_simd cfg80211 cryptd glue_helper i915 intel_cstate asus_nb_wmi asus_wmi sparse_keymap pcspkr i2c_algo_bit drm_kms_helper snd_soc_rt5645 snd_intel_sst_acpi snd_soc_acpi_intel_match cec snd_soc_rl6231 intel_gtt snd_soc_acpi syscopyarea sysfillrect snd_intel_sst_core sysimgblt lpc_ich fb_sys_fops mei_txe snd_soc_sst_atom_hifi2_platform mei hci_uart btqca btrtl btbcm btintel bluetooth mac_hid snd_intel_dspcfg

That looks familiar. Similar output as harryharryharry posted on the Ubuntu thread. He didn’t actually say if his Bluetooth was working or not, but I would assume not since yours isn’t.

When I get a chance to steal the wee netbook from my roommate, I’ll see what the output is on it.

That would be great !
Thanks : )

Maybe try what was just posted in the Ubuntu forum thread.

Hi Yochanan , thanks for the sharing.

Didnt work here. But right now im not running the btattach service. Because last day I uninstalled the Bluez and blueman for planing installing it again, since I installed one of those with snap packages, and since that i had to change something in the /usr/bin/btattach part of the battach because manjaro dont come with btattach in usr/bin.
The thing that surprised me a lot was when uninstalling the bluez and blueman. the hole wireless and even internet from thetering was gone, could not get to work and i was left with a computer with no way to conect the web. So i reinstalled everything.

The thing is. do you think that i have to install bluez or blueman (dont remember wich one was the one) to get the btattach in usr/bin ?

Or how should I ?

also sound on headphones is gone now not sure how i maneged to get it working last time thought it was the 4.14 kernel but i have it now installeded and nothing…

❯ pacman -F btattach
extra/bluez-utils 5.56-1 [installed]


Thanks Yochanan!

Managed to get the bluetooth in Linux Mx, but it freezes… So trying to go back to Manjaro to test your solution, but not sure what happens sometimes with Calamares it can not complete the installation having problems with the EFI/grub (gives an error I dont have right now to paste the output)
Perhaps I’ll try the script you mentioned at the beginning. Thanks a lot for your help!

That’s because it has 32-bit EFI. Makes no sense since it has a 64-bit CPU.

Why do you think I suggested saving it for later? :wink:

Hehe yes I thought about it :yum:

I tried the harryharryharry script but didn managed to get it working, sincerely I was to tired to read all the thread or to figure that out… so… I tried again with the Iso that worked before, and managed to get it to a clean install. The think is when calamares does the automatic partitioning of the disk in my case erasing everything and partitioning then, it looks ok, it has the efi, as fat32, but at the grub installation point it fails with a large error output.

What did work in my case was to partition it through calamares but manualy

efi 512mb boot/efi
swap 4096
root /
home / home

and doing that it goes ok

Ill check in a moment the bluetooth if I have luck to get it work, in the headphones is very easy just adding

options snd_soc_rt5645 quirk=0x31

as the arch asus x205ta wiki mentioned

Thanks for your help! :raised_hands:

Oh, I forgot about the issue I had until I saw your comment you deleted. Just remove --locales="en_GB" from line 109:

< "${grub_mkstandalone}" -d /usr/lib/grub/i386-efi/ -O i386-efi --modules="part_gpt part_msdos" --fonts="unicode" --locales="en_GB" --themes="" \
> "${grub_mkstandalone}" -d /usr/lib/grub/i386-efi/ -O i386-efi --modules="part_gpt part_msdos" --fonts="unicode" --themes="" \

Well i tried the bluetooth thing but cant get it.

I’ve run pacman -F btattach

and outputs:
extra/bluez-utils 5.55-3

but dont see the file created in that folder, also the btattach says it cannot find the file

Loaded: loaded (/etc/systemd/system/btattach.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Tue 2021-03-02 18:20:10 -03; 4min 4s ago
Process: 1062 ExecStart=/usr/bin/btattach --bredr /dev/ttyS1 -P bcm (code=exited, status=203/EXEC)
Main PID: 1062 (code=exited, status=203/EXEC)

mar 02 18:20:10 compu systemd[1062]: btattach.service: Failed at step EXEC spawning /usr/bin/btattach: No such file or directory
mar 02 18:20:10 compu systemd[1]: Started Btattach.
mar 02 18:20:10 compu systemd[1]: btattach.service: Main process exited, code=exited, status=203/EXEC
mar 02 18:20:10 compu systemd[1]: btattach.service: Failed with result ‘exit-code’.

i probably missed something

That output will be the same no matter if you have the corresponding package installed or not. The point was to show you how to find the package a file belongs to.

Do you have bluez-utils installed?

Installed now the bluez/utils (sorry before i so bluez and not bluez/utils)

$ sudo systemctl status btattach
● btattach.service - Btattach
Loaded: loaded (/etc/systemd/system/btattach.service; enabled; vendor preset: disabled)
Active: active (running) since Wed 2021-03-03 09:12:30 -03; 1s ago
Main PID: 2019 (btattach)
Tasks: 1 (limit: 2277)
Memory: 160.0K
CGroup: /system.slice/btattach.service
└─2019 /usr/bin/btattach --bredr /dev/ttyS2 -P bcm

mar 03 09:12:30 domain systemd[1]: Started Btattach.

(i started the serial communication with ttyS2. numbers 0 and 2 give me no errors 1 and 4 dont work)
heres the output of btattach but still not working the Bluetooth icon goes away when i turn on bluetooth

also tried the bluetooth-addr.service that you mention before but it cannont start heres the status of it:

● bluetooth-addr.service - Set Bluetooth device address
Loaded: loaded (/etc/systemd/system/bluetooth-addr.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Wed 2021-03-03 09:20:29 -03; 1s ago
Process: 2180 ExecStart=/usr/bin/btmgmt -i hci0 public-addr {YOUR_BLUETOOTH_MAC_ADDRESS} (code=exited, status=1/FAILURE)
Main PID: 2180 (code=exited, status=1/FAILURE)

mar 03 09:20:29 domain systemd[1]: bluetooth-addr.service: Scheduled restart job, restart counter is at 5.
mar 03 09:20:29 domain systemd[1]: Stopped Set Bluetooth device address.
mar 03 09:20:29 domain systemd[1]: bluetooth-addr.service: Start request repeated too quickly.
mar 03 09:20:29 domain systemd[1]: bluetooth-addr.service: Failed with result ‘exit-code’.
mar 03 09:20:29 domain systemd[1]: Failed to start Set Bluetooth device address.

I think you forgot something. :wink:


well tried to find the Mac address with:

Agent registered
[bluetooth]# show
No default controller available

if I delete the bcm43341b0 from the firmware and the previous command shows a Mac address, but im assumming its wrong, because bluetooth-addr.service dont starts well with that Mac address.

So I put again the bcm43341b0… but cant start the bluetooth

Does your BT is a dual BT with WIFI? (seems the case)
If so I solved my BT problem (but ymmv since I dr,tl all of this thread :wink: )

Basically I disabled the BT hardware on the bios… Booted a couple of times…
And then enabled it again.
Then it worked.

Also check for the value of bt_coex_active. You can run:

sudo cat /sys/module/iwlwifi/parameters/bt_coex_active

In my case it as better with the Y (or 1 option).
You can change the content of /etc/modprobe.d/iwlwifi.conf like so:

options iwlwifi bt_coex_active=Y

Hope this helps…

hi Sanji , ive misspelled the name so not shure but probably since the bluetooth is BCM43341b0 and wifi is brcmfmac43340, ill check what you mention thanks!

Downgraded to kernel 4.19.177-1 and BLUETOOTH IS WORKING NOW !!

now I can see the real MAC address of the device, so perhaps I’ll try a kernel 5.xx to see if what is mentioned in this post works

What do you think Yochanan?