Can't download Plasmoid widgets - Manjaro Testing

Hey all. Recently reinstalled Manjaro through the Architect TUI and booted into KDE Plasma. However, I’m running into issues. Trying to install new widgets from the native widget browser on my desktop returns the error “Download of _____ failed, error: Socket operation timed out”. Trying to install global themes through the same process returns the same error as well. So, I tried to install it from the KDE store using ocs-url, but it hangs at downloading. Trying to download the package directly from any of the pling-related sites attempts to download it but hangs the page with no download popping up. I tried downgrading to Stable, reinstalling ocs-url multiple times, getting pling-store to install, but it all returned the same issues. Did I screw something up with my mirrors? Are the pling sites just down?
Would love any feedback on this.
Thanks for your help!


You will need the package knewstuff installed, restart your session and try again.