Can't create a new kde activity

I have a laptop and a desktop both running manjaro stable with kde. My laptop is able to create activities like normal, however, my desktop shows the dialog but when you hit create it just highlights the button and nothing happens. I've looked into error messages with:

sudo journalctl | grep kactivitymanager

Errors:

kactivitymanagerd[3645]: The X11 connection broke (error 1). Did the X11 server die?
file:///usr/share/kf5/kactivitymanagerd/workspace/settings//qml/activityDialog/OtherTab.qml:32: ReferenceError: content is not defined

I, however, get these on my laptop too, which works.
kactivitymanagerd seems to not be running for some reason on my desktop.

I tried clearing out configs and cache:

rm -rf ~/.local/share/kactivitymanagerd
rm -rf ~/.config/kactivitymanagerd*
rm -rf ~/.cache

I also tried creating a new user, and it doesn't work for that user either. I reinstalled various kde packages. I looked at permissions in my home and it looks fine.

Any success with reinstalling kactivitymanagerd package?

No, tried reinstalling that and other kde packages as well.

Same issue here, can't find anyone else with the issue online

Forum kindly sponsored by