Can't consistently log into Wayland session

Hello guys, I’ve recently made the transition from Debian-based distro hopping to this, really loving it so far!
I’m having one issue tho. When I login after a reboot or a shutdown (regular ones, not forced or anything) it’s a bit of a lottery if im going to get an x11 or Wayland session, and I have no idea what might be causing it, I installed the OS 2 days ago, and besides from installing a few programs haven’t messed with it much, didn’t change any drivers or load a lot of extensions. Any way I can start searching where the culprit must be?

Go to /etc/gdm/custom.conf and change WaylandEnable=false to WaylandEnable=true as root. You have to reboot and login into Gnome session to see changes. You can confirm if you are using wayland or not by echo $XDG_SESSION_TYPE.

Do note that gnome silently disables it on the background even if you enable it if you have a Nvidia card.

1 Like

I did this, and the first reboot it went into x11, second reboot into wayland, same behaviour as before. etc/gdm/custom.conf retained the changes I made, only difference is now I can choose xorg on the login screen, but apparently doesnt choose it automatically every time.

Are you selecting Gnome during login? (dont select Gnome classic or Gnome Xorg)

I’m not manually selecting any, just letting the OS do it automatically (I just looked to see the options it gave me)

How do you expect the OS will know what you want. Select Gnome there:


Made a few reboots/shutdowns, made sure GNOME was always selected, still same behaviour. Sometimes it’ll log into a x11 session, sometimes into Wayland (Xorg option was not always there).

I do have an Nvidia graphics card, so that might be the culprit as you said on your first post. It’s just that it doesn’t disable it every time, it does it randomly.

If you want to run Wayland with Nvidia GPU and proprietary drivers, have a look here:

1 Like

Thanks, I’ll check that post out.

Just to clarify a bit, when Wayland session works, it does flawlessly, no issues whatsoever so far. So I might just reboot when x11 is loaded for now